L4D Level Design/Your First L4D Level

From Valve Developer Community
Jump to: navigation, search
Português-Brasileiro Русский 简体中文

A brush is a simple 3D shape created with Hammer's Block tool Hammer block.png. Brushes are used to created the majority of large surfaces in your level, such as ceilings and floors. We will now create a simple room using brushes.

Creating a floor brush

Drawing a brush.
  1. From the Tool bar on the left, select the Block tool Hammer block.png.
  2. Now, left-click and drag in the Top 2D view in a movement that is Right and Downward as shown below.
  3. You should see a dotted outline of a rectangle or square as you drag.
  4. Create a square 512x512 units and let go of the left-mouse button.
  5. Press Enter on your keyboard to create this brush that you've just drawn.

To go back to selection mode, click on the Selection tool Hammer select.png icon on the Tool bar or press the Esc key.

In selection mode, with the brush selected, you can change the size of the brush by left-clicking on any of the boxes that appear on the borders of the brush and dragging them out or in.

Let's decrease the thickness of the brush (which we'll be using as a floor) from the default 64 units to 16. To do this, we need to change the size of the grid.

The grid

A grid is displayed in all the 2D views. By default, all objects snap to the grid. Although you can turn this off, it is considered good practice to leave it on because it prevents leaks and other errors in your map.

The default grid size is 64 units, which means that each line is 64 units apart. The current size of the grid is displayed in the status bar at the bottom of the Hammer window.

  • Clicking the Smaller Grid icon Hammer SmallerGrid.png will make the grid half as big, for finer adjustments. You can also decrease the grid size with the [ key
  • Clicking the Larger Grid icon Hammer LargerGrid.png will make the grid twice as big, for larger adjustments. You can also increase the grid size with the ] key.

To bring the grid size down to 16 units, press the [ key twice. Look at the Status bar at the bottom right of the Hammer window and make sure it reads Grid: 16. If it doesn't, press [ or ] until it does.

Resize the floor

Lowering the height of a brush in the Side viewport.

Now the grid should be small enough.

Switch to the bottom right viewport. It should be labeled Side when you mouse over it. Drag the top border of the brush down so that it's 16 units thick.

Moving brushes

Click & drag in any 2D view to move a brush.

You can move brushes around once they're created. Select the Selection tool Hammer select.png and mouse over the brush in one of the 2D views, staying clear of the corner handles. The pointer will change into four arrows pointing in all four directions FourArrows.png, indicating the option to move the object.

Click and drag the brush to move the brush in any of the 2D views. Upon release, the brush will be moved to that position.
Configuring the options in Hammer.

You can also move objects with the arrow (cursor) keys. To do that, we'll need to change a setting in the Hammer options to allow the arrow keys to be used:

  1. Go to Tools menu and pick Options to bring up the Configure Hammer dialog box.
  2. Click on the 2D Views tab.
  3. There are other settings here as well, but for now, we just need to check the box marked Arrow keys nudge selected object/vertex.
  4. Press OK to confirm the change and close the settings.

Now let's move the floor brush down 16 units by placing the mouse cursor over the Side viewport and pressing the Down_arrow once.

Moving a brush down in the Side viewport.
Note:You'll need your ground plane on the same level as the origin line so that the nav file included will work.

Navigating in the 2D viewports

  • You can use the scrollbars to pan the view.
  • For a faster method, hold down the Spacebar and left-click and drag to pan.
  • Use the Mouse Wheel to zoom in and out.

Texturing

To see textures in the 3D Camera viewport, right-click on the camera text in the 3D Camera viewport and select 3D Textured.

Selecting the 3D Textured mode in the Camera viewport.

Navigating in the 3D Camera viewport

Moving around in 3D is a bit different from the 2D viewports:

  • Hold down the Spacebar and left-click and drag to rotate the camera.
  • Hold down the Spacebar and right-click and drag to move up/down and left/right.
  • Hold down the Spacebar and both right and left-click and drag to move forward and backward.
  • You can also use W, A, S, and D to move forward, backward, strafe left and strafe right respectively.
  • The Z key toggles on and off "mouse look" mode. Move your mouse cursor over the 3D Camera viewport and press the Z key. You can now move your mouse around as if mouse look was on in the game.
Note:The W A S D keys can be used in combination with the Spacebar navigation

Move up in the 3D Camera viewport and look downward at the floor that you've just created.

The Browse button on the Texture bar.

You'll notice there's a default texture on your floor. You'll probably want to change it. To change the current texture, click on the Browse button on the Texture Box.

This will bring up the Texture Browser window.
The generic gray developer texture.

In the Filter field at the bottom of the browse, you can filter the textures shown based on name. For this tutorial, type in the word "dev_measure" (with the underscore) into the field. This will bring up a listing of "developer" textures that will make it easier to create something quickly.

Now, find the texture called dev/dev_measuregeneric01b and double-click on it.


Applying the current texture to the selected brush.

This should bring back the 4 viewports of the editor and place the generic developer texture as the current one in the Texture bar.

Select the floor brush, if it isn't already selected, by clicking on it in the Camera viewport. It should turn red.

After the brush is selected, click on the Hammer ApplyCurrentTexture.png Apply current texture icon on the Tool bar to apply the current texture to the selection. The gray developer texture should appear on the floor as shown.

Creating the walls and ceiling

Now let's go over how to create the walls and ceiling of the room. The easiest way to do this is to duplicate the floor brush.

Duplicating

You can also select an existing brush and duplicate it to create them.

Note:To duplicate, you will need to have the Arrow keys nudge selected object/vertex option set if you didn't do this earlier in the tutorial. You can find it under Tools > Options > 2D Tab.
Duplicating brushes to make a room.

To duplicate:

  1. Select the floor brush that you've created.
  2. Move your cursor over the Side viewport.
  3. Hold the Shift key down and press the Up_arrow key to create a duplicate and move it up 1 grid unit.

This will create a brush exactly like the floor on top of the existing floor.

You can now change the size and dimensions of this new brush to create a wall grabbing the corner handles on the brush and dragging it to the size you wish. Let's make the wall 128 units tall and 16 units thick.

Tip:To move the brush you created, using the arrow keys or simply click and drag inside the center of the brush to drag it to another location.
Now duplicate the wall 3 more times to outline the floor.
Duplicating the floor to create a ceiling.

Duplicate the floor brush 1 more time and raise it to become the ceiling.

Tip:Keeping your level clean will become very important when you start to run it in the game. It's a good idea not to have overlapping brushes (brushes that intersect one another). This can cause "z-fighting" in the game, which is where multiple faces fight to get drawn over one another.

Deleting brushes

To delete a brush, select it with the Selection tool Hammer select.png and press the Delete key.

Multiple selection

Applying the generic orange developer texture to the walls.

You'll notice that in the Camera viewport, if you navigate inside the room, it's hard to tell what's going on because all of the walls, floor and ceiling are the same texture. Next we'll change the walls to a different texture.

You can select all of the walls by holding down the Ctrl key and clicking on them one at a time in the Camera viewport. You will have to use the Spacebar camera controls (or turn on mouse look with Z) to rotate the camera around so you can select each wall.

After you have all of the walls selected, click on the Browse button in the Texture bar. This time, select the orange texture next to the current one, labeled dev/dev_measuregeneric01. Double-click it to select it and close the browser window.

Use the Hammer ApplyCurrentTexture.png tool on the Tool Bar to apply the orange texture to the walls.

Saving the file

To save a level, you can use Ctrl+S or Save from the File menu.

You will need to give the map a file a name and choose the directory to place it in.

For this tutorial, name the map "tutorial01" and save it into the mapsrc directory, located by default at:

C:\Program Files\Steam\steamapps\common\left 4 dead\sdk_content\mapsrc\

Your directory may be slightly different, depending upon where you have installed Steam.

Included sample maps

When you went to save your map, you may have noticed other directories underneath the mapsrc path. The Left 4 Dead Authoring Tools come with some example maps to help you.

Directory Contents
mapsrc\No Mercy Apartments Contains an example map from the "No Mercy" campaign that ships with Left 4 Dead.
mapsrc\standards Examples maps that contain many of the standard pieces for co-op and Versus mode maps.
mapsrc\Your_First_L4D_Level_Tutorial Contains completed versions of all the sections of this tutorial.
mapsrc\zoo "Style guide" maps for rural and urban types of Left 4 Dead maps.

At times, this tutorial will refer you to different maps in these directories.

Tip:Of these, the "Your_First_L4D_Level_Tutorial" is probably the most immediately useful. If you have a hard time completing one of the sections of this tutorial, you can refer to the files in the this directory to give you an idea of what the finished map for that section should look like.

Placing entities

Selecting the entity.
Placing an info_survivor_position.

Next we'll place an entity in our level:

  1. Select the Entity tool Mt-entities.png on the Tool Bar.
  2. Once the Entity tool Mt-entities.png is enabled, the Entity selection list on the Object bar becomes active.
  3. Keep the Categories entry as Entities.
  4. Click the arrow on the Objects drop down list and select info_survivor_position.
  5. Now, navigate in the Camera viewport to the middle of the inside of the room.
  6. left-click on the floor to place the entity.
This will place an info_survivor_position entity in the middle of the room.

The model for an info_survivor_position is Francis. He's the tallest character in Left 4 Dead, so this is a good entity to drop down to check your scale.

Placing a light

Now we'll place a source of illumination in the map:

  1. Select the Entity Tool again
  2. Select light from the Objects drop down list on the Object bar.
  3. This time, place the light on the ceiling (above Francis' head).
  4. Go back into selection mode by clicking on the Selection tool Hammer select.png in the Tool Bar or by pressing the Esc key.
The Object Properties for a light.

Next we'll change some settings on the light. Bring up the light's properties by double-clicking it in the Camera viewport or by selecting it (left-clicking on it) and then pressing the Alt+ Enter keys. This will bring up the Object Properties dialog box.

From the Object Properties, you can change various properties of the entity. For example, you can change the Brightness of this light. Click on the Brightness row under Keyvalues and you will see a set of numbers on the drop down menu on the right side. The default setting for the brightness of a light is 255 255 255 200. The first three numbers represent the RGB values (color) and the last number represents the intensity of the light.

You can click on the Pick Color button to select a color rather than input values for it.
Picking a color for a light.

Simply click on the color you want the light to be and click OK.

This will bring you back to the Object Properties dialog box for the light. You should see any changes you made to the brightness on the Brightness row and the drop down field on the right side if the Brightness row is selected.

Click the Apply button to set your changes to the entity and close the dialog box by clicking on the "X" at the upper right side of the window.

Placing a prop_static

The Object Properties for a prop_static entity.

Entities also consist of props like furniture, decoration, and complex parts of architecture. There are a variety of different kinds of props. Prop_static entities are props that are static – they don't move, animate, turn on or turn off. There are also prop_dynamic entities that can move, animate, be enabled and disabled. There are also prop_physics entities which the player can interact with and behave physically as they would in the real world.

To place a prop:

  1. Select on the Entity tool Mt-entities.png again.
  2. Go to the Object bar and change the Objects field to prop_static.
  3. Point to the floor in front of the model of Francis and left-click to place a prop_static. You will see a red cube that represents the prop_static before a model is attached to it.
  4. Go back into selection mode by clicking on the Selection tool Hammer select.png in the Tool Bar or by pressing the Esc key.
  5. Double-click on the red cube to open the properties.
  6. Double-click on the World Model field to open the Model Browser.
Warning:The first time that the Model Browser window loads, it can take a while to load in all of the models. It might not immediately look like the image you see below. If you cannot find the model you're looking for, give it a minute to finishing loading.

Selecting the model

Selecting the table model in the Model Browser.
  1. In the Filter field at the bottom of the dialog box, type in "table". This will show all the models that have the word "table" in their name.
  2. Scroll down to the one named:
    "props_furniture\it_mkt_table2.mdl".
    It should look like the image shown.
  3. Click OK to select it and close the browser and return to the Object Properties dialog box. You should see the name of the model now in the World Model row.
  4. Click the Apply button to set your changes to the entity.
  5. Close the Properties box.
You will see the table that you just placed in the room in any of the viewports in the editor.

Moving entities

Placing the table in the corner of the room.

You can move entities like our table the same way you can move brushes. Click and drag inside the bounding box of the selected entity to move it around with your mouse or put your mouse over any of the viewports and use the arrow keys on your keyboard to move them around.

Move the table to a corner of our room and set it so that it sits on the floor.

Rotating entities

Selecting the shotgun from the Objects list.

Next we'll try placing a pump shotgun on the table in our room and rotating it so that it looks like it's in a natural position.

Click on the Entity tool Mt-entities.png in the Tool bar.

Select weapon_pumpshotgun_spawn from the drop down menu under Objects.

Placing the weapon_pumpshotgun_spawn.

Click on the floor underneath the table prop to place the shotgun entity.

Note:In the Camera viewport, entities can only be placed on brush surfaces.
Circles at corners indicate that the object is ready to be rotated.
Click & drag a circle in any 2D view to rotate the object.

To rotate an object , you simply select the object you wish to rotate using the Selection tool Hammer select.png, then click once on the object. You should see the object surrounded at the corners with circles. Mouse over a circle in any 2D view, then click and drag to rotate the object.

Rotating the shotgun in the Front viewport

Use your mouse wheel to zoom into the Front viewport and click once inside the bounding box of the pump shotgun model to make its four corners highlight with circles around each one.

Left-click and drag in a counter-clockwise motion to rotate the pump shotgun so that it's lying on its side.
Decreasing the grid spacing.
Zoom into the Side viewport and press the [ key 4 times to decrease the grid spacing. Click and drag inside the bounding box of the shotgun to move it to sit on top of the table. You don't have to place it exactly as long it is above the table and not inside it.
Rotating the shotgun in the Top viewport.

In the Top viewport, click inside the bounding box of the shotgun until it's in the rotate mode again. Left-click and drag one of the corners counter-clockwise until the shotgun sits almost parallel to the table.

Now you will have a shotgun that you can pick up from the table.

Adding to your room

Creating the hallway and second room.

Using the duplication, scaling and moving of the brushes you currently have in your room, you can now build a hallway and another room identical to the first.

Make sure to create openings into both rooms from the hallway.

You can also duplicate the light in the first room and move it to the middle of the second room.

Tip:Remember you can duplicate any object in your level by holding the Shift key and then moving the object by dragging it or using the arrow keys. It's much faster than always creating objects from scratch. You can even have multiple objects selected and clone them together. This is a much safer strategy for creating passageways than using the Carve tool.

After you've finished making your second room and hallway, save the level as "tutorial01.vmf" if you haven't already.

Add a player start

One last thing we'll want to do is add a player start entity to test out the map. This will be where the player will spawn in a simple level.

Placing an info_player_start.
  1. Select the Entity tool Mt-entities.png on the Tool Bar.
  2. Pick info_player_start from the Objects drop down list.
  3. Now, navigate in the Camera viewport to the center of the room next to the model of Francis.
  4. Left-click on the floor to place the player_start.
The exact position isn't critical. Just make sure it's in this general location. You can even rotate it another direction if you wish and the player will be facing that way when they spawn.

Running your level in the game

Change the Run Map parameters to match these settings, then click OK.

You have saved your map, but you will also need to compile it before it can be played in the game engine.

When a map is compiled, it is converted from the raw .VMF file that you just saved, into the .BSP format used by the game engine. The geometry is processed and the proper lighting and shadows are pre-calculated with several compile programs.

  • Open the File menu, and choose Run Map... or press the F9 key.
  • The Run Map dialog will open.
  • This dialog is used to set some basic compile parameters.
    1. Make sure that Normal is set under the Run BSP, Run VIS, and Run RAD settings.
    2. Under Additional game parameters:, make sure these settings are present, and type them in if not:
      -toconsole -dev -console +sv_lan 1
    3. Now click the OK button to start the map compile process.

The Compile Process Window will show the progress of the compile. When the compilation is done, the game you are mapping for will automatically launch, and load your map in the engine.

Note:If you wish to compile with High Dynamic Range lighting, simply check the box that says HDR. The time to compile the map will be twice as long, but that is completely normal.
Click Continue on this dialog.

Your level in the game should load up after compiling. It may take a minute or two.

  • When the game launches, the "Map is unplayable!" dialog will immediately appear. This is OK because we haven't created a navigation file for our level yet. You'll learn about navigation files later in the tutorial.
  • Press the Continue button.
Running the level in the game.

A screen shot of the running map. Note that without a navigation file, the Survivor bots won't respond fully.

Tip:Your .vmf source map is automatically saved to disk when you compile and run it with the Run Map command. However, it's a good idea to save every once in a while so you don't lose any work.

The Developer console

Making levels for Left 4 Dead sometimes involves using commands typed into the Developer Console window. The console can also be used to do things like spawn Infected zombies to test your level.

Enabling the developer console.

If you haven't already, make sure the console is enabled in the game:

  1. Press the Esc key in the game.
  2. Click on Options, then Keyboard/Mouse.
  3. Click on the Allow Developer Console and select "Enabled".
  4. Click on the Done Button.
  5. Click on Return to Game.

Using the developer console:

  1. Bring down your developer console ` (tilde).
  2. Type any console command and press the Enter key.
  3. Hide the console again with `.

Noclip mode

One console command you'll find constantly useful is noclip mode. This is a mode that let's you fly around the level without being stopped ("clipped") by anything in the level. It's useful to get around large levels quickly.

To enter noclip mode:

  • Press ` to enter the console.
  • Type noclip in the console and press Enter.
  • Fly around the level.
  • Type noclip again to leave noclip and walk around the level normally.

Some useful console commands

There are lots of console commands available. Here is a sampling.

sv_cheats 1
Turns on cheats. Necessary for many console commands.
director_stop
Stops the AI Director (no spawning for common Infected or Specials).
director_start
Starts the AI Director (spawning resumes).
nb_delete_all
Deletes all existing NPCs (Infected and Survivors).
map <name of map>
Loads a map or reloads the level you're in.
changelevel <name of map>
Loads a map while continuing the session.
god 1
Turns on god mode for all Survivors. The Survivors are invulnerable.
noclip
Allows you to fly through the world.
z_spawn
Spawn a common Infected zombie where the cursor is.
z_spawn smoker
Spawn a Smoker.
z_spawn hunter
Spawn a Hunter.
z_spawn boomer
Spawn a Boomer.
z_spawn tank
Spawn a Tank.
z_spawn witch
Spawn a Witch.
nb_blind 1
Make the infected blind to the player.
Note:nb_blind 1 isn't fool proof. If you bump into an infected, they will attack. If a mob is spawned, they will come after you.
sb_stop 1
Stop the survivor bot AI -- the Survivors will stop moving.
director_force_panic_event
Start a panic event (Infected mob).



L4D Level Design Basics Tutorial
L4D Level Design/Getting Started
L4D Level Design/Ladders