L4D关卡制作/场景组织

From Valve Developer Community
Jump to: navigation, search
English

译者:joyo_a(百度ID)

到目前为止,你可能已经注意到本教程中包含的一个名为“tutorial_standards.vmf”的vmf文件。打开Hammer并打开此文件。

这个文件包含很多例子用来说明Valve在原来的求生之路地图中是如何做到的。

确保你的left4dead\mapsrc\standards目录中有“tutorial_standards.bsp”和“tutorial_standards.nav”,然后加载它以查看其中的一些示例。

注意:译者注:在最新版本的SDK中不再包含tutorial_standards.vmf,该文件已作为官方示例战役DeadLine的一部分。请打开该官方示例战役第二关的源文件l4d_deadline02.vmf以代替tutorial_standards.vmf。

复制/粘贴

复制/粘贴与其他程序类似。使用Ctrl+C复制笔刷或实体和Ctrl+V来进行粘贴。

Hammer的一个很好的功能是你可以将地图中的一部分从一个文件复制并粘贴到另一个文件。例如,你可以将tutorial_standards.vmf中的楼梯复制到您自己的地图。

在这里找到的金属楼梯:

选择标准的金属楼梯。

通过左键单击来选择它。

通过按Ctrl+C或使用Edit > Copy来复制它。

打开要粘贴的地图。

将鼠标放在窗口和要粘贴的位置。

通过按Ctrl+V或使用Edit > Paste来粘贴它。

你现在可以将其移动或编辑,就像在你的地图中创建的一样。

你也可以特殊粘贴。尝试使用Ctrl+ Shift+V或使用Edit > Paste Special

Paste Special Dialog窗口将出现:

Paste Special对话框。

如果你保留默认设置字段并单击OK,则楼梯将被粘贴到你的地图中位于你将其复制的地图中的准确位置。

组/对象/固体

Hammer允许你将对象组合在一起,使编辑更容易。例如,你可以组合灯实体,光源的prop_static和env_sprite来表示光的发光。

选择起始房间使用的灯光组。

在tutorial_standards.vmf中,在起始房间中找到灯光组:

通过左键单击属于该组的任何实体来选择它。

然后你可以复制此组或将其整个复制/粘贴到你的地图。

要将对象组合在一起,只需选择要组合的所有对象,然后按Ctrl+G或使用Tools > Group

类似地,你可以选择一个组并通过按Ctrl+U或使用Tools > Ungroup取消组合形成的对象。

从Tools菜单中选择Group。 从Tools菜单中选择Ungroup。

选择组中的单个对象。

选择模式

你会注意到Hammer的Selection Mode面板,有三种选择方法:

‘组’,‘对象’和‘固体’

你刚刚发现了一个组(Groups)是什么——你将不同类型的对象组合在一起的地方。对象(Objects)是地图的单个组件,例如世界笔刷或func_detail。它也可以是一个实体,如灯,一个prop_static,或者一个门。

切换到对象模式,现在只选择刚刚选择的灯光组下方的灯。即使灯在较大的组中,由于我们处于对象模式,所以只选择灯。
在笔刷实体中选择单个笔刷。

这些组件中的一些东西(func_detailfunc_brush等)可以由多个固体(solids)组成,它们是被创建的笔刷,然后组合成单个对象。

例如,你可以将在tutorial_standards.vmf里的楼梯示例中的所有楼梯作为单个func_detail。如果要删除一些梯级,可以切换到固体模式然后选择要删除的梯级。

现在切换到固体模式并选择楼梯的两个梯级。即使这些梯级是整个func_detail对象的一部分,我们仍然可以选择单个梯级,因为我们处于固体模式。

然后你可以删除这些固体或者复制它们以制作更多的楼梯。

提示:固体模式中,你在任何时候进行复制或复制/粘贴,它们将不会保留其笔刷实体属性。你需要使用Ctrl+TTools > Tie to Entity来作为笔刷实体重新创建它们。如果你在对象模式下选择完整的楼梯,并且要将新的固体绑定,可以使用Ctrl+T将它们组合到原来的笔刷实体。

可见组

选择楼梯,栏杆和伸展台。

Hammer还允许你将对象放入可见组。可见组是一组对象,你可显示/隐藏它以帮助你组织你的地图,并帮助你编辑你的地图而无需一次查看其中的所有内容。

对象模式中,再次选择楼梯,但这次也选择连接到楼梯的栏杆和伸展台。

现在,点击顶部工具栏上的L4d hammer visgroups 02.jpg点线的红色立方体。

可见组对话框。

这将显示可见组对话框。

你可以通过点击“Place object in existing visgroup”旁边的按钮将对象放入现有的组中并选择要添加到的组。你还可以通过在框中键入新名称并单击确定来创建新的可见组。

在这个例子中,新的可见组被称为“Stairs”。

当你点击OK时,你会发现楼梯,栏杆和伸展台从你的视野中消失。这意味着他们现在被隐藏在可见组“Stairs”中。
楼梯,栏杆和伸展台现在被隐藏在一个可见组中。

通过点击VisGroups面板中“Stairs”左侧的复选框,你可以显示和隐藏楼梯,栏杆和伸展台。

当你想继续编辑时,你现在可以隐藏这些对象,并可能有助于更好地查看东西。
Auto VisGroups选项卡。

自动可见组也是非常有帮助的。

点击VisGroups面板中的Auto选项卡,你会看到Hammer自动创建的可见组。

通过点击每个类别旁边的框,您可以隐藏或显示任何这些类别的对象。

例如,在所有自动可见组打开的情况下,在tutorial_standards地图的镜头视图中移动。然后,关掉Brush EntitiesClips,看看它有什么区别。

警告:隐藏可见组时要小心。如果你忘记重新启用一个可见组,你的地图将在可见组关闭的情况下编译。在编译地图之前,请确保你在Auto VisGroups选项卡中的Auto左侧框中单击两次。通过这样做,你将确保所有的自动可见组都被打开。



L4D关卡制作基础教程
L4D关卡制作/室外场景
L4D关卡制作/场景标准