August 2006 Community Buglist

From Valve Developer Community
Jump to: navigation, search

This article is an archival copy of Talk:Source SDK Known Issues and Source SDK Bugs/Hammer bugs. Check those pages for the latest copies.

Hammer Bugs

General Hammer issues

  • Hammer crashes trying to load a map. Finishes getting chunks, then crashes as the map begins to display. Unknown cause. Any help will be nice. Dr.Scrots 17:52, 6 October 2007 (CST)
This may be due to the issue I quote below - an entity with a missing classname. I have written a a tool that scans a given map and fixes any known issues - namely the 'no classname' issue. Simply drag your map onto the program, and it will create a new file, yourmap_fix.vmf which is the altered version. See if that one works for you. --Daedalus 06:48, 8 Oct 2007 (PDT)
  • Ragdolls and other physics objects like grenades or props fall right through my displacement maps. This only happens with levels I create, the in-game HL2-levels work. --Sterd 12:12, 20 May 2007 (PDT)
See this article.--Fitzroy doll 06:28, 2 Jun 2007 (PDT)
  • Hammer will crash trying to load a map (Postload processing) if there is an entity in the map that has no classname. I fixed this in a map that was doing it by setting the classname to "unknown_entity" --Daedalus 20:29, 30 Apr 2007 (PDT)
  • Comments appended to entities, where able, don't like ctrl-enter for a carriage return. FIX: I had to manually open the .vmf file in a text editor and remove that particular keystroke to get my map running again. Hammer 4.1 Build 3576. (18 Nov, 2006)
  • Defining custom colors under the 'Pick Color' button aren't saved when restarting Hammer 4.1 Build 3576. (17 Nov, 2006)
  • All of a sudden the compiler will refuse compiling even the bsp of the map, giving an "unexpected symbol" error, pointing to symbols like ".", "{" or "}", and pointing toward a line and an entity. However, this bug does not seem dependent of an entity or a symbol, will move between entities and symbols if the mentioned entity is cordoned off, and will remain even though everything has been cordoned off in the map. The bug is map specific - other maps will work just fine.
Verifying the cache, reloading Steam, and reloading the SDK resources, will not help. If loading the map again, Hammer will give the same "unexpected symbol" error, then a "memory could not be 'read'" error, and then shut down Hammer. If trying to salvage the map, Hammer will crash with the "Send Error Report" message.
This bug is (or at least "can be") caused through proving one or several quote (") characters in a keyvalue (like for instance the Message Text field of a game_text entity). The compiler/loader will interpret the character as the end of the keyvalue argument and the execution of the following commands will not make any sense to it.
Fix: There are two ways of fixing this problem:
The first fix is to use a reverse compiler to reverse engineer your latest BSP file into the last working VMF file.
The second fix is to load the malfunctioning VMF file up a text editor and changing it manually. As the file is usually quite humongous, you will need to try to load the map up in Hammer and check the error message that will report which line the error occurs at. Then go to that line, remove the quote characters within the quoted argument, and save it. (If Notepad is used, you will need to turn off "Automatic Linefeed" and thereafter turn on "Status bar" in the "Show" menu, to be able to display the current row.
Note.png Note: I'm Swedish, so I'm just guessing their names here - please correct them if necessary.
  • I can't import basic brushwork from GTKradiant .map anymore, was working fine before last update. When loading the .map, hammer crash with that Fatal Error: "BlockArray <0,0> - invalid block index.". Suggestions?
  • I've received the same error while attempting to import hl1 .map files from Hammer 3.4 and GTK Radiant.
  • I can't import .map files from Hammer 3.5 either, I've tried basically everything, including trying to roll back SDK updates or starting older versions, VALVe just doesn't appears to have added in something to allow that. Solokiller 06:14, 19 Aug 2006 (PDT)

EDIT: .rmf files now work, try to import .map files in hammer 3.4/3.5 and save as .rmf.

  • I am having a similar problem to JustinMstroud, but I have some additional information. I just installed SourceSDK and when I try to save my initial Hammer configuration I get an error. When I close the hammer configuration screen it says "Changes will not take effect until the next time you run Hammer. After clicking OK I get a Windows Application Error for hammer.exe - "The instruction at '0x0d94dc24' referenced memory at '0x0000001c'. The memory could not be 'read'." As JustinMstroud described below, the new Hammer configuration doesn't save. Also, after the first time this happened, Hammer could no longer be started through Steam. When I try to start Hammer from Source SDK in Steam I get - "Error: No game configurations to run with." The only way to get back to the Hammer configuration screen is to run Hammer.exe directly from the [email protected]\sourcesdk\bin folder, and then I'm just back where I started- in the specify configuration screen and unable to exit without getting that error and losing all the settings. This is on an Athlon 3000+ with Radeon 9800 pro 256 and 512 RAM --Tehblinkenlights! 21:04, 11 Jul 2006 (PDT)
  • I downloaded the Hammer editor; when I open it, it asks me to specify a configuration. I do so, but then I get a windows crash. The data does not save, so my configuration is gone. When I restart Hammer, it sees no configurations. I have looked around, but haven't found an existing issue that maps to my problem. Any suggestions? I'm running a P4 2.8 (dual core) with a GF6800, 1gb of RAM. Thanks JustinMstroud 15:08, 8 Jun 2006 (PDT)
    • Try again after deleting the file game/bin/GameConfig.txt. --Roastbeaf 18:05, 7 Dec 2006 (PST)
      • Ok I have the Same Problem, but that message occurs when i try and run the map. I tried deleting the gameconfig.txt and that didn't do anything. Any suggestions? user:mrabele 18:13 23 Dec 2006 (PST)
    • I have the same problem over here but deleting the GameConfig.txt file does not change anything
  • The following is said as the description for the "There is no player start." map problem:
There is no player start in the map. To add one, select the Entity (axe) tool, drag the crosshairs to the position you want the player to start at, and press ENTER.

The entity tool is not an axe though!—ts2do 12:37, 14 Apr 2006 (PDT)

  • Sometimes (This has randomly happened three times this week.) Hammer will be unable to find a normally available .mdl file (like for a camera-window preview of a shotgun). When it doesn't find the .mdl file, it will display a dialog box about not being able to, and then simply quit. To start Hammer again, you must restart Steam. --Andreasen 05:10, 2 Feb 2006 (PST)
  • When I compile my map, and run it, I can pickup weapons but I have no HUD! I have no health bar, no armor, I cant switch weapons (unless I run out of ammo). Can someone please tell me whats happening?
    • I also am experiencing the same problem, sort of. I'm running an Athlon 64 3000 1.5GB, GeForce 7300 GS. At first, when I would compile the map to test (the map I'm working on is a deathmatch one), everything worked fine. After not too long, it would load up fine, but after 5 - 10 seconds of playing in my map all model textures (Guns, Hands, Barrels, Boxes, Fences, Grenades, Powerups, etc.) would become solid colors. All textures on walls were fine. In addition, HUD becomes blank - as in it displays the black --NykO18 19:46, 16 Aug 2006 (PDT)background box, but none of the detail inside. For instance, the health box you can see the transparent black box, but no numbers. At this point, if you press ESC, you see no words for the menu, however hovering the mouse pointer still creates the sound of hovering over the words. No crosshair either. I found a solution temporarily - If I threw a grenade in a corner and killed myself, when I respawned, everything would be back to normal for as long as I stayed in the map. As soon as I left HL2 and went back to Hammer, made changes, recompiled, everything would again get messed up until I killed myself. NOW though, everything is ALWAYS messed up, regardless if I kill myself or not. Even my dead body is a solid grey. Any solutions would be appreciated. I'll check back here occasionally, otherwise shoot me an e-mail at [email protected] Thanks! --Keitaro 18:09, 25 Jul 2006 (PDT)
      • This happens to me too. I am using hl2 single player when it happens. Is it only in hl2 that this problem occurs, or other games as well? Post on here or answer at [email protected] Thanks.--Calard 23:15, 17 Feb 2007

edit: i put in a info_node and used newgame_spawn and everything works now.

  • I had set up a closed path_track circuit, marked one path_track entity, brought up its property box, opened the Orientation Type dropdown list, held down the Ctrl key and clicked on another path_track to try to see if you could select several path_tracks simultaneously, and at that point Windows explained to me that Hammer had crashed and shut it down. --Andreasen 14:25, 31 Jan 2006 (PST)
I tried to reproduce this bug with the same track, but couldn't, so it's probably random. --Andreasen 05:30, 2 Feb 2006 (PST)
  • Clip mode acts funky when a grip for the clip line is held down with the mouse button while enter is pushed—ts2do
  • Windows Error reporter whining about hammer when closing hammer (this happened after the "cursor lost in model browser"-bug, not sure about this two bugs may be in conjunction?).
  • When you have a group selected, and you try to carve, Hammer freezes.
Workaround: Don't carve.
  • Displacement Alphas in hammer when compiled appear inverted in-game. Such as using sand with sand/rocks as the alpha. If you have it setup in hammer one way when you compile and play it will invert the alpha. Additional notes are that this bug occurred even without the new sdk beta and therefore is a bug that I hope is fixed soon. Thanks --RomeoGuy 16:57, 23 Nov 2005 (PST)
Workaround: Invert Alpha before compile, but is tedious.
Request: I have the same problem, how about a command line argument for the compiler to do it for me? Angry Beaver 20:20, 10 Feb 2006 (PST) should work like it's supposed to!!!—ts2do 21:13, 10 Feb 2006 (PST)
  • Selection of a Displacement only considers the original box it was made from.
  • Brush creation manipulation box isn't cleared after a new brush has been creation, yet the handles aren't usable. If you try to use them, it starts drawing a new brush.
  • if u change the name of the file, the search path is changed, but not the place where they are
Please clarify. --JeffLane 14:15, 9 Jan 2006 (PST)
  • When scaling objects the texture is not scaled along anymore (ie creating 3d skyboxes)
Was this with Scaling Texture Lock enabled? --JeffLane 14:59, 9 Jan 2006 (PST)
  • Something scary about the animations of props.. try this manipulation : Create a prop_x and select a model that is animated (like 'models/Combine_Dropship_Container.mdl') then make a copy (shift+drag & drop) of this prop_x next to the first one.. (in order to see the problem) Now open up the properties of one of the two props and try to change it's default animation to something else than 'idle'.. And yes, this is magic, the second prop_x just beside appear to follow the other one.. it's animation changes too. You can't create an opened Dropship Container and a closed one in the meantime.. (and it happens with all the models) --NykO18 11:06, 29 Dec 2005 (PST)
    • Not a bug. The model tab is only for preview, it does not change the entity itself. We should change the name of the tab and/or add some help text. --JeffLane 14:59, 9 Jan 2006 (PST)
      • Ok, thanks for clarifying.. because as far as I can remember (Worldcraft 2.0) there was a way to change the animations in the model properties. Am I wrong ?
      • You can specify the animation to use in the object properties for a prop in the class info tab. - RodeoClown 19:25, 20 Mar 2006 (PST)
  • In the Face Edit dialog box when applying textures, the Select option in the Mode drop-down menu behaves identically to the Lift+Select mode. Instead of just selecting the face without changing the current texture, it will select the face and lift its texture, making it the current texture. --Font38 23:58, 16 Jan 2006 (PST)
  • In Hammer Torus Properties, inputting a Rotation Start Angle of more than 360 degrees results in a infinite loop of "Please enter a number between -360 and 360" dialogs (also, alt+tabing into Hammer while it is in this state will create more dialog boxes and when they reach the end of the screen, Hammer crashes). Jupix
  • When compiling, it says "BuildVisLeafs", when correct English is "BuildVisLeaves". This has lead to much confusion: The majority of all Hammer users now seem to believe the plural of "leaf" is "leafs", and is calling it "visleafs". (Edit: Even if you claim that a leaf node in general doesn't abide by the same grammatical rules as a normal leaf does, user-who-wishes-to-be-anonymous, I'd like to hear this from Valve, so don't delete.) --Andreasen 22:06, 12 Apr 2006 (PDT)
  • Can't compile when using map names that contain numbers
  • When minimizing Hammer (while a map is opened) the program shuts down or crashes randomly. Reaper47 04:58, 7 Aug 2006 (PDT)
    • When I use my 'Go to the desktop' shortcut to reduce all the opened windows, if I try to restore Hammer from the taskbar, it crashes. --NykO18 19:46, 16 Aug 2006 (PDT)
    • I can confirm the "Go to Desktop"-shortcut problem. I've tried various things (Windows applications, games requiring 3D renderings, changing my pc configurations), but the only thing causing the crash is the "Go to Desktop"-button next to your Windows Start button. I understand why Reaper47 files this under "random crashes", it's a very common thing to use this button, often you don't even realize you are using it (automatism). - Hezus
    • I can confirm this too, it also does it while using the Win+D Hotkey. (I'm using NT 7.0 with 2.4GHz P4 and 1.5GB RAM) --Kayedj 03:43, 18th August 2007 (BST)
  • The Window menu doesn't display the list of maps currently open if a map has been opened, closed and a new one opened.
  • Having Hammer open and a map loaded, and then opening model viewer when keeping Hammer open(not minimized) causes hammer to crash, most likely due to the same files being used( model render tools used by both programs) Solokiller 11:16, 9 Sep 2006 (PDT)
  • Selecting an entity in the 3D view, then selecting an entity right after causes a crash. Unsigned comment added by Quanta (talkcontribs). Please use four tildes (~~~~) to sign your username.
  • EDIT: I can't duplicate the bug; must've been the current session of Hammer I was running, although I've had it crash before just by clicking on something. Unsigned comment added by Quanta (talkcontribs). Please use four tildes (~~~~) to sign your username.
  • I've had this too. Usually after I change an entity's type. It's quite hard to reproduce, some times it keeps happening, other times it doesn't. --Daedalus 01:51, 9 Apr 2007 (PDT)
  • Only 3 tool textures show up under the 'Tools' keyword. The rest show up under the 'combine' keyword. --Quanta 14:46, 2 Jun 2007 (PDT)
  • Clipping tool doesn't seem to like spheres with 16 sides. Keep getting that 'memory couldn't be read' error message, at instruction 0x0daf7a85. --Quanta 16:23, 6 Jun 2007 (PDT)
  • There's something about an instruction at 0x0daf7a85, because every time hammer crashes with 'memory couldn't be read', it says something about that exact same location. I've even confirmed this with a few of my friends. --Quanta 10:51, 10 Jun 2007 (PDT)
  • The SDK sometimes deletes Game Configurations, most likely it refreshes the SDK content without being told to do so. Solokiller 05:27, 20 Jun 2007 (PDT)
  • When the SDK is started, "the copying files, please wait..." dialog always pops up, preventing fast usage of the SDK. Picture below. Solokiller 05:27, 20 Jun 2007 (PDT)


  • Hammer should not crash if there's an error reading the file. Instead it should tell you the error, and stop trying to load, but keep running. --Quanta 14:41, 4 Jul 2007 (PDT)
  • Creating a prefab (Ctrl+R) with any kind of light entity selected won't retain the light's color - it defaults to white, making it frustrating to add colored light prefabs in.
Workaround: Select the light entity, click 'Pick Color' for the brightness attribute, click 'OK', then 'Apply'. --Quanta 16:58, 4 Jul 2007 (PDT)

The Hammer Vertex Tool

  • Vertex tool is unable to maintain coordinate precision when dealing with "complex" shapes, despite these shapes being concave. (See such an example in Talk:Hammer Vertex Tool.) Upon reloading a map, certain coordinates will be moved less than half a unit off the grid. This bug is persistent and easily reproducible. --Andreasen 06:21, 25 Oct 2007 (PDT)
  • When vertices are coincident, Hammer is no longer prompting to combine the vertices. When left coincident and brush is put in Vertex edit mode again, this error displays: "Edge with both face id's already filled, skipping..." --Spektre1 10:42, 25 Nov 2005 (PST)
    Note.png Note: This occurred on a brush that was 1 unit wide. It seems to function normally on wider brushes. --Spektre1 10:46, 25 Nov 2005 (PST)
"Edge with both face id's already filled, skipping..." also happened to me once when I made a cylindrical object of pretty normal size (11 faces). The error does not seem to go away: Every time that object is selected in vertex editing mode, that error message is given twice. Possibly related: After removing that brush and creating another, when trying to move the first vertice on that brush (using a unit scale of 1 for precision), two vertices was automatically moved about 100 units down and 1119 units to the side, making it end up far outside the window! This might mean that the bug lingers around even after the brush is removed. --Andreasen 06:21, 25 Oct 2007 (PDT)
  • Get "Edge with both ID's already filled, skipping..." after combining vertexs and selecting another brush to vertex. Noticed that some faces were missing, too. Wasn't in a way that it was an invalid brush.
  • Moving a vertex with the vertex tool while holding <Ctrl> or <Shift> will constrain the vertex along an axis of the Origin, rather than along an axis based on the vertex's original location, making this feature very unresponsive.
  • After manipulating a brush in vertex mode, then undoing the operation, Hammer thinks the brush is still in its previous state (before the undo), and draws the selection box around that previous state. --Quanta 08:53, 26 Jun 2007 (PDT)
Invalid Box.PNG
  • In Vertex Manipulation, if you drag across points and let go before the selection is drawn and then hit <enter> three times to try to select the points you thought you selected, Hammer crashes.
  • Vertex editing mode: When manipulating vertices in a grid size of 1, the vertice(s) will move to the lower right location of whichever grid square the cursor has been dragged to. With larger grid sizes, the vertice(s) move to whichever grid location the cursor is closest to.
  • After doing some vertex manipulation, then saving and closing, Vertices on manipulated object messed up upon reload. Ex: three really closely spaced vertices (less than one unit) now where before there was one. Also, the "check for errors" does not appear to working correctly: after reloading the map, some solids were not loaded due to errors, when before closing the error check said no errors were found.
Existing issue. Not a Beta SDK bug. --JeffLane 14:59, 9 Jan 2006 (PST)
Will this bug be fixed with the episode 2 SDK update? It is very annoying, i can't create a good dome for my level without it screwing up the vertexes and making all my work bad. It seems to happen with several triangle brushes placed close together. Solokiller 10:52, 29 Aug 2007 (PDT)
  • Width length height values in the status bar are weird in vertex tool when there is no selection box—ts2do

Hammer 2D and 3D Views

  • Hammer's 3D View is completely black, regardless of what is actually in the map. I tried resetting the view, changing the 3D View settings, I tried deleting the SDK and all sdk settings and files then reinstalling, but it still has the same problem. Moldrat 16:02, 2 Sep 2006 (PDT)
Yes, for some reason the default camera has been removed. You'll have to make another camera, using the Camera tool. --Andreasen 16:07, 2 Sep 2006 (PDT)
  • 3d and 2d views begin to flicker black and flicker graphics mess ups (like polygons stretching to edges of screens, or certain wall s becoming invisible. this gets gradually worse as time goes on, restarting hammer fixes temporarily. I think this isn't only a beta thing, it may just be me, but hammer worked fine for 6 or 7 months before doing this.
    • Picture:
    • Solution: Go to C:\Program Files\Valve\Steam\SteamApps\Account_name\sourcesdk\bin\ and create a shortcut to Hammer.exe with the parameter -dxlevel 80 like this: "C:\Program Files\Steam\SteamApps\Account_name\sourcesdk\bin\hammer.exe" -dxlevel 80
    • I've started getting this problem too. Only in the last few days and only in the CS:S SDK, HL2 SDK works fine. Entity polygons corrupt in the 3D view and stretch out of shape. I'm using a Radeon 9700pro.
    • I've also been getting these issues, on two different system setups in fact. Both were using radeons, though, an X800XL and an X1900XTX.
    • I'm suffering from this too, but only recently. The one thing that's changed - drivers. Reverting to earlier drivers has not helped however. Models in 2D views render fine. Radeon 9800Pro256. --johnsto 10:59, 8 Jun 2006 (PDT)
    • This issue also occurs in the Model Browser.
      • Cleaning out all traces of old drivers and updating to latest Omega drivers (3.8.252) has not helped. --johnsto 12:54, 19 Jun 2006 (PDT)
    • As of the August 4th, 2006 SDK update, this issue has been fixed.
  • Possibly related to the cursor issues below: Block, Camera, and Entity tools don't use any special cursors at all, just the default Windows pointer, even when dragging. Also, the "Use Crosshair Cursor" option has no effect. --EsBe 23:41, 1 May 2006 (PDT)
  • Using ctrl+shift+f to do a target name search while the cursor is over the 3d window will result in an inability to move in 3d view using the WASD keys next time the user attempts to do so. This happens regardless of whether the 3d window is maximized or not. Also happens when opening texture browser with shift+a, but in this instance the problem only occurs when the 3d window is maximized. In the target name case, workaround is to move the cursor into a 2d window. In the texture browser case, workaround is to minimize the 3d window. 14 February 2006
  • Using Shift+Z to maximize the main camera window while the Z key is enabled (mouse rotating the view in camera window), will make the cursor and the view get stuck. --Olavenspire 18 Jan 2006
    • This is most likely because enabling the Z key restrains the cursor to the 3D window (found out when my Hammer crashed with Z key enabled), and maximizing the 3D window causes the cursor to try to be out of the box, but it must stay in the box, which makes the view stick. --Quanta 15:13, 15 Apr 2007 (PDT)
  • There is no special mouse cursor for creating brushes until you start dragging
  • There is no special mouse cursor for applying overlays
  • 'Textures' screen element does not close after use, even if it was closed beforehand. Would be a useful fix for people who use only hotkeys and don't have any buttons on-screen unless needed.
Please clarify how you expect this to function. --JeffLane 14:59, 9 Jan 2006 (PST)
The window would only be open while the tool was in use, unless it was open before. A little like it comes out of the sidebar when used and pops back again when you exit texture mode. --TomEdwards 01:19, 18 Jan 2006 (PST)
  • move_rope is created with a bad Position Interpolator setting (0 should be 2), and setting it to anything higher than 2 causes Hammer to crash.
  • Pasting or manipulating light_spot entities turns the light cones green. properties remain the same.
workaround: restart hammer.
  • Rotating models does not go smoothly anymore, it now is like having shift pressed when rotation. The old way allowed for much more freedom.
Workaround: Hold ALT while rotating.
Or hold SHIFT :D
  • The rotation handles on brushes are open circles instead of solid.
  • The camera handles when using the camera tool are open circles instead of solid.
  • Overlays are not rendering correctly in the 3D views.
  • Textures are stretched in 3d view when scaling an object, and then retain original scales when brush is set to desired size.
    • It would make a lot more sense if the 3D scaling preview only happened if <tl> is on. Otherwise it's showing a change that won't actually occur.
This is a new feature, it will appear like that when the texture scaling lock is off, it's the button with <tl> on it. When on, it will not retain the original scales.
It would be handy if the texture showed actual results instead of stretching, speeding things up.
  • 3D Textured Shaded view doesn't always shade, client dependent.
Could be GFX related, my card is a 9100 and only PS 1.4 (DX81) compatible.
  • You can't select wireframe'd props/actors in 2D views by clicking. You've got to drag a selection box or select the ent's bbox (which isn't drawn!).
    • workaround: you can do it by clicking the center handle
  • When the texture application tool is open, when you use the right click method to apply textures, it seems to break movement in the 3D view with ASDW. ASDW movement functions again once you click back in a 2D view.
    • It fixes for me when I undo as well.
    • Happens for me when I have the window open at all. No clicking required!
Not a Beta SDK bug. This occurs when the Texture Application window is over the center of the 3D view. Workaround: Move the Texture Application view to the side before applying any textures. --JeffLane 14:59, 9 Jan 2006 (PST)
  • Can not compile maps. A Windows error occurs stating "Microsoft Visual C++ Runtime Library Runtime Error! Program: d:\steam\steamapps\[email protected]\sourcesdk\bin\vbsp.exe R6025 - pure virtual function call" The issue occurs with both the beta and original versions of Hammer on a FRESH install of Windows.
    • I got this problem too. It seemed to be caused by displacements intersecting other brushes. Deleting intersecting brushes fixed the problem.
  • 2D views do not have their labels displayed unless you mouse-over where the label should be. This will confuse people who don't know what orientation each port is showing.
  • After not being active some time, reopening hammer made all textures purple-black checkboard and there were also no models. After trying to close and reopen map, hammer crashed.
Is this a chronic issue, or did it only occur once? --JeffLane 14:59, 9 Jan 2006 (PST)
I believe this is a chronic issue, because this has happened to me a few times as well - it seems to be mostly after running the map with Hammer minimized, then restoring Hammer. This doesn't happen all the time, but it has happened before. --Quanta 18:39, 30 Apr 2007 (PDT)
Also, it happens most often if Hammer is open when Steam crashes and disconnects. Even when it reconnects, Hammer isn't running from the same session that Steam is now running from, and everything goes missing. --Quanta 13:42, 13 May 2007 (PDT)
  • IME language bar on the desktop causes each view flickering between 2D views and 3D textured view, making hammer near unusable. It doesn't happen when the language bar is minimized in the taskbar.
  • Skew tool (i.e. when you select a brush, then click it a second time to bring up the skew handles) does not snap to grid, and instead snaps to seemingly random points.
  • Selecting a large amount of brushes and then moving them before undoing the operation results in the selected brushes disappearing in the 3d view. Rotating the camera results in the brushes reappearing at certain view angles. After this occurs, other brushes will sometimes disappear in the 3d view, too. My current setup = Windows XP Pro (32 bit), latest dx drivers, 6800GT and driver version 81.95. -- Defrag
    • Workaround: Avoid moving lots of brushes if possible. If the issue occurs, restart hammer.
    • I've seen this problem too. It seems that Hammer thinks the brush is still in its previous position so it disappears when that position is off the screen. You can fix it by moving the brush in some way.--DBN 13:36, 3 Dec 2006 (PST)
  • With Direct3D debug version of DLLs selected in DirectX control panel, clicking in the Hammer 3d view on a 3d rendering causes Hammer to crash. Occurred after last SDK update. DX9 (Dec 2005), Windows XP Home. See Hammer_3D_View_MouseDown_Crash -- BJ
  • The view legend ( Top(x/y), Front(y/z), etc. ) does not appear unless the cursor is positioned in the upper left corner. The legend then pops into view but disappears when the cursor leaves the window. — BJ 12 May 2006
  • Hammer will, for me, will 'offset' the textured piece of the brush up to 16 units away from it's origin point, while leaving a red selection box where the brush actually is. Additionally, Hammer will draw a 1 to 2 unit red selection box (the texture select mask) over brushes (instead of just highlighting the texture). Additionally, earlier, moving a large amount of brushes and entities and undoing the operation caused the brushes to disappear, then randomly reappear as the camera viewpoint was moved - Reselecting them in the 2D view still caused them to remain invisible in the 3D viewport.

Here's a screenshot:

Movingblock hammer.JPG

Also, note the clipping on the selection mask on the right brush as well. This usually happens at distance, but seems to be reversed - Up close there is no selection mask and it fades in with distance.

--RabidMonkey 23:08, 2 Jun 2006 (PDT)

  • Hammer no longer renders ropes that do not have MoveSpeed set. --Raeven0 15:51, 14 Jun 2006 (PDT)
  • Centering via Ctrl E and the pasting with Ctrl V doesn’t paste in the center of the views anymore. This is really disruptive to workflow. Sometimes it doesn't even paste within view.
    • Objects in the clipboard are pasted at the cursor's location. Again, this is a new feature and not a bug per se. --Raminator
  • If the 2D view is zoomed all the way in, you can’t hold shift bar and drag the view.
  • If an invalid displacement exists and is visible in the 3d view, it will draw garbage, faces on the wrong solids, distorted solids, failing to draw a solid at all, etc. --Gman003 17:04, 3 Sep 2006 (PDT)

Hammer VGUI Model Browser

  • Suggestion: Model Browser already loads the current model when you launch it more then once. It should also select the folder, scroll to the currently displayed file string in the "filter" tab and select/highlight it. This will make navigation through the browser easier and more consistent. — Matveims 18:31, 2 Feb 2006 (PST)
  • Model viewer currently loads it's GUI incorrectly the first time; on close and re-open, it functions as expected.
    • Resizing the window also fixes this.
  • Choppy performance.
    • using the search, results in a hangup for short time and it takes long to see what you wrote
  • Rotating the model will reset view translations.
  • Filter text input slow.
    • Suggestion: Put a .1-.3 second delay on filtering, before the program parses the text, so the user can finish inputing a string before it searches. (Or a search button that also is pressed when Enter is hit.)
    • Yes because in fact, if you type 'rock' in the filter, it will first search all models containing the letter 'r', and sometimes it takes a really.. really long time...
  • The model browser should remember the state it was previously in when reopened; i.e., remember what folder was previously selected.
    • It should also FORGET the text filter last used.
      • Why? I consider that to be a feature, not a bug. When adding props of a similar type, it would be a real pain to keep re filtering. It's slow enough as it is! — BJ 12 May 2006
  • The 3D crosshair model, for things like the move_ropes, is so tiny it's really difficult to select in the 3D view. It would be a good idea to fatten the model up a bit, so it's easier to select.
  • Suggestion: Add a field that indicates if model is a static prop or a physics model or a detail model.
  • Suggestion: Allow user to toggle model skin in viewer.
  • Suggestion: Allow switching between old model browser and new model browser.
  • The model browser isn't loading. Don't know if it's related to the "SteamAppID 211" problem that has been report by others.
Please clarify. Does Hammer crash, or does the model browser actually just take a long time to appear? --JeffLane 15:26, 9 Jan 2006 (PST)
  • All model folders are empty except for the starting folder.
Was the filter control empty? --JeffLane 15:26, 9 Jan 2006 (PST)
  • We cannot browse models located directly in the "models" folder anymore. The 'root' directory isn't accessible (got All .MDLs instead of the root where all the NPCs are located) --NykO18 09:48, 29 Dec 2005 (PST)
    • This is a feature request, not a bug. --JeffLane 15:26, 9 Jan 2006 (PST)
      • Hum.. this is more like a needed feature that was present in the non-beta sdk and which was deleted.
  • When it can't find a model, it doesn't even bother to load an error model or something else. But it just crashes.
    • If "model" key is set, the model viewer try to open the model set in this key. But the viewer doesn't test if the model exist or not. If the Key isn't set (so World Model is empty), the viewer display the Error.mdl. If not, The viewer crash and hammer follow it. How to reproduce : Set "bla" or what you want as string and apply now use browse.
  • Selecting most human models (corpses + combine work, all else fail) cause Model Viewer and Hammer to crash with
 AppName: hlmv.exe	 AppVer:	 ModName: shaderapidx9.dll
 ModVer:	 Offset: 0001f546 02:26, 25 Jun 2006 (PDT)
Mlk 02:27, 25 Jun 2006 (PDT)
  • When there is a wrong model path typed in the entity properties and you press the button to open the browser Hammer crashes.
  • Suggestion: Once the model browser opens the first time, it should make some kind of cache of the models (or at least the relative paths) so it doesn't have to load all of the models every time. --Quanta 05:39, 2 Jun 2007 (PDT)
    • ABSOLUTELY it should!! It's not as if there are memory an experiment I kept track of my system's memory usage while the model browser loaded the model list, and the total memory in use hardly increased at all. I find it just stunning that we need wait about 30 seconds every time we want to add a prop, just to wait for the damn list to load. What are these guys thinking! I am currently in the phase of adding detail to a map, and this is driving me insane. If you add up all the little instances of 30 seconds, as well as the frustration factor, this adds literally hours if not days to development time.

- In summary, anything that you would reasonably expect to be cached, should be cached, at least after first usage.

  • Hammer crashes when entering the Model browser, after the Episode 2 SDK update. Solokiller 12:41, 7 Nov 2007 (PST)

Hammer Autovisgroups

  • Creating a brush with the NODRAW texture selected, then changing the textures, causes the brush to still be listed in the Nodraw autovisgroup. --Beans-v6 15:06, 7 Dec 2005 (PST)
    • This is probably because brushes are assigned to an Autovisgroup when they are created, so changing the texture won't change the Autovisgroup that they're currently in. --Quanta 18:32, 30 Apr 2007 (PDT)
  • Start new map, make a brush, use SKIP texture on all side, Hammer Auto VisGroup don't recognize this first brush, put HINT on one side, that's not update.

Duplicate it, now autovisgroup work, but only work the duplicated brush. Put the BlockLight texture on all side of duplicated Brush. Now uncheck Skip or Hint autovisgroup, Your BlockLight brush turn hidden. That's like previous point Gectou4

  • Expand visgroup make a gray area without group (on Vista), I have to unpand and expand it again to display visgroup correctly.
  • On Vista sometimes, when a visgroup use more than 128 objects, it's can be lost some of them. the object of this group may appear later on another grid location.

Hammer Autosave

  • Not really a bug, but the use of autosave should be optional...
Change 'number of map iterations to save' to zero. Could certainly be a little clearer! --TomEdwards 09:50, 5 Dec 2005 (PST)
Hammer already allows for the option of autosave. --Quanta 05:40, 2 Jun 2007 (PDT)

Hammer - Misc

  • As I documented the prefabs, I found a couple of default prefabs that didn't work properly, or at all. I've listed fixes for them on their pages. Here is a link to a list of them: Category:Prefabs --Andreasen 17:29, 31 Aug 2006 (PDT)
  • A possible way to change the texture quality in the 3D view would be oh so nice.
    • Thats done by mip-maps in-game... or make the texture
      • -quality before converting it into a vtf
      • I also desperately need a way to change the texture quality in Hammer. DX7 puts normal Hammer textures to high quality, but beta Hammer textures to low quality, and that is far too low for me to align accurately, as well as making identifying entities by looks impossible.
  • Would it be possible to have the default texture (selected when Hammer is started) as nodraw? It would encourage better mapping.--DrBob 04:37, 4 Dec 2005 (PST)
  • Could you make it easier to import something from Hammer into 3DS Max? For example, the only way at the moment is to export to .DXF, and that generally loses information. Perhaps an export to .Max, or an importer plugin for Max?
    • Workaround: XSI has a great map import feature. You could base a plugin off that or possibly import to XSI then save your file and import it into MAX.--Skidz 15:55, 23 Nov 2005 (PST)
  • Nothing has yet been said for when we are going to see a lighting preview option, but could you perhaps add the option to change the lighting in the shaded 3d view? So we can change it like in the model viewer and get a general idea of how certain types of lighting will look like in-game.
  • After using Source SDK then restarting steam, DoD:Source, HL2, and HL2:Deathmatch update at 233 bytes and source sdk updates at 70% at a rate of 70 kb/s
    • You need to run Steam with the -beta sdk option every time you start it, otherwise Steam has to re-download the non-beta version. --Nailed 23:38, 24 Nov 2005 (PST)
      • I always run it with -beta sdk..but it keeps doing it
        • If you have steam to load with windows, you will also have to edit the reg key HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run to look like "d:\program files\valve\steam\steam.exe" -silent -beta sdk
  • Suggestion: After using Maya and other 3D-applications, it would be great to see a Hotkey-feature in Hammer! For example, map the Textures-window to M , Block-tool to B instead of Shift+B, etc etc. Hotkeys gives a much better workflow.
    • The hotkeys there already are fine (Shift-A for surface props, Shift-B for brushes, Shift-C for camera and so on), and I don't see a reason to change them, especially since so many of us use them and have them engraved into our heads now! What additional hotkeys are you thinking of? --johnsto 02:02, 4 Dec 2005 (PST)
      • Thinking of being able to remap the current hotkeys for your likings, and add more hotkeys for things like the Texture Browser. Even hotkeys for Rotate 15 degrees, Scale +-0.1, etc etc. But this is just an industrial injury of me using Maya too much. --Zyndrome 18:44, 4 Dec 2005 (PST)
  • Insert original prefab button only appears after switching tools & not right away—ts2do 14:00, 6 Feb 2006 (PST)
  • On map load, or new map start, hammer shuts down automatically; there is no warning or error notice.
Does this happen with the Beta SDK, or when running the non-Beta version of Hammer? --JeffLane 14:15, 9 Jan 2006 (PST)
  • I tried loading a large vmf file (5.51 mb) onto Hammer, which loaded quite well in versions before this beta, and the program crashed with a non-specific windows error saying "hammer.exe has generated errors and will be closed by Windows." --Jojoboy
  • When you enter an invalid wall width (ie 0.5) in the arch creation dialog, you get into an infinite series of "please enter an integer value" dialogs.
  • When you create a prefab category (Prefab Factory) or create a prefab hammer will crash. --BloodShed 22 July 2006
  • The 'SetSpeed' output appears twice on 'func_door' entities. It looks like only the second one actually do something. (I don't know if this problem also occurs with other entities) --NykO18 21:08, 18 Aug 2006 (PDT)
  • On 'trigger_multiple' entities the 'OnStartTouch' and 'OnEndTouch' outputs are both ignoring the 'Delay before reset' option of the trigger. The 'OnTrigger' output works correctly. (I don't know if this problem also occurs with other entities) --NykO18 21:08, 18 Aug 2006 (PDT)
  • On 'func_button' entities, the flag 'Not Solid' seems to have disappeared (as long as I can remember, there was one). Also, the 'Toggle' input has also disappeared. It seems now impossible to 'unpress' a button via an output when it has been pressed. --NykO18 21:18, 18 Aug 2006 (PDT)
  • All or the most of the 'item_xxx' entities are broken in HL2DM. I made a test map with displacements, props 'n stuff and I tried to put ammos and weapons on everything (on tables, on shelves, on displacements, on brushes). Although none of the items are touching something, half of them are respawning badly after being picked up once.. On the 80 items I placed, only 40 are respawning correctly, the others are respawning at the origin of the map (coords 0,0,0).. I was thinking of a minor collision box problem, so I put them at least 40 units away from any obstacle, and I ran the test again, but with no success.. It's really a pain in the *** to make a HL2DM map with this sort of problem, I'm forced to stop mapping because of that. So maybe I made something wrong, but I don't think so.. just take a look at this picture. These two item_ammo_crossbow are respawning at the origin of the map and I don't think it's normal. --NykO18
  • In relation with the above problem, a large number of 'item_xxx' entities are replaced by a big red 'ERROR' model in Hammer, like item_ammo_ar2 or item_ammo_pistol_large. But in-game they seems to be OK, it's just REALLY difficult to place them correctly with this huge error model. --NykO18
  • On env_sprites, if you browse to and select a sprite name, it will fill it in for you without the .spr/.vmt extension. While this works fine for the Hammer 3D preview, this prevents the engine from finding it in-game.


  • When a func_breakable has the 'playerclip' texture applied (or perhaps other tool textures, haven't tested any others), HL2 will crash as soon as the map is run. The compile log makes no note of this, nor does Alt+P.
  • When I was experimenting around with phys_hinges, func_physboxes and phys_constraintsystems, I created a phys_hinge but couldn't move it. Each time I tried to drag it into a new position with the mouse, which I couldn't, when I let go of the mouse button, the entity moved OUTSIDE the entire map, judging by the line, with its "blue ball" in the origin of the map. I saved the map and restarted Hammer and Steam, but still I was unable to move the phys_hinge. This bug disappeared when I manually typed in new coordinates for the entities "blue ball" in the Hinge Axis keyvalue field. --Andreasen 06:21, 23 Mar 2006 (PST)
    • I can verify this as well. It's happened to me many times. The only fix was using brackets to increase the grid scaling, and THEN moving it, but if I tried to move it on a lower grid scale again, it screwed up. The only solution I had was to move it using the transform tool.MichaelLipik--
      • This happened again, and after some tampering I concluded that if you try to move a phys_hinge (and possibly other entities too - didn't try that) while the grid scale is set to 1, this bug will happen. Setting the grid scale to 2 or bigger, will make the bug disappear, but it is easily reproducible by just decreasing the scale to 1 again. --Andreasen 15:48, 30 Mar 2006 (PST)
        • I did some testing and it seems to only happen when an ent is defined with halfgridsnap...without it (such as phys_ragdollmagnet) it works marvelously—ts2do 16:25, 30 Mar 2006 (PST)
        • I have reported this to Valve directly, and they will be releasing a fix for this in the next SDK update.—ts2do 21:35, 30 Mar 2006 (PST)

WORKAROUND: If the phys_hinge(s) are selected simultaneously with normal entities (func_detail, Weapon_smg1...) they should move just fine. Bit Mage 4:44, 6 Jun 2006 (EST)

  • Hammer <-> HL2 compatibility (able to run both simultaneously without any problems)
    • On this line of thought - Fix up the wc_ commands and developer environment in-game for HL2 <-> Hammer compatibility?
  • Long file names can't be seen in Face Edit dialog.
  • Face Edit dialog loses focus when cursor moves off the dialog. -User:Unknown
    • I have also had this problem. But it also causes my view to scroll in one direction, it kind of acts like I am holding one of the directional keys down.If I try to counter the movement it halts the screen as suspected, but if I try to recreate the bug to reverse it, it doesn't seem to work. Thus making any further editing during this session impossible. Requiring me to restart hammer to continue. A Possible origin of this bug is in the quick window switching code. and the addition of me shifting my view while using the mouse. - Tandem Fixation 01:25, 26 Apr 2006 (PDT)
    • This is also hindering editing certain settings efficiently, Meaning I have to actually stop and position my mouse so that it is not off screen to edit certain properties - Tandem Fixation 01:25, 26 Apr 2006 (PDT)
      • I consider the lose-focus event to be a feature. It allows changing the 3d view to select different faces without closing/reopening the editor. — BJ 12 May 2006
        • I think its because hammer renames the window to match whatever view the cursor is in. Doing so brings the Face Edit window out of focus. --Quanta 14:36, 2 Jun 2007 (PDT)
  • Hammer crashes if you startup a game without minimizing it and then reopening it before the game opens.
  • Point At... button for angle keyvalues only set "angles" keyvalue.
  • Occasionally the editor closes without warning or error.
  • Editor becomes unstable and/or crashes on a fairly regular basis, often when adjusting overlays, deleting or working with move or keyframe ropes, when moving large amounts of brushes or entities, or doing large amounts of displacement modification.
  • 3D view black models issue fix (failing to draw model textures because of video card limitations)
    • I've noticed this only happens on Mx440's or whatnot, very low-end cards. --RabidMonkey 00:33, 16 Oct 2005 (PDT)
      • I managed to have it happen on a Radeon 9600, but it wasn't a reproducible bug. --Spektre1 08:32, 16 Oct 2005 (PDT)
        • I just had this happen after a "steam update" that occurred today with a geforce4 TI 4400. Texture was working yesterday, it's just black today, and my other textures are fine. I had it scaled quite small to show good granularity, I'm trying to find a fix.--Mrobben 20:22, 5 May 2006 (PDT)

  • Painting alpha values across multiple terrain brushes sometimes will not paint one of the selected brushes even though the points are lined up and sewn.
  • Nudging objects with the arrow keys only moves one unit at a time, even when a larger grid is selected.
  • Face Edit Sheet, Lightmap Scale only has space for 2 visible digits (128 shows up as 12 or 28.)
  • Ctrl + E should still center on the selected object, even when in brush creation mode.
  • Texture scaling lock rotates not-scaled faces (sometimes). See attached picture.
  • After the Day of Defeat: Source SDK update (or the 2D rendered models?) Hammer has begun to break up the 2D grid lines in triangles.
  • Hammer crashes after wake up from screen saver

I have encountered a bug in hammer, running under XP Pro. I am using the "Windows XP" screen saver. And I have "Fast User switching" and "Use Welcome Screen" turned on. With my account that is password protected as well as guest account turned on. (Guest account is not logged in)

    • 1: First run Hammer and open up a map.
    • 2: Leave hammer running in the foreground. Wait for screen saver to start.
    • 3: Wait a minute after screen saver starts, and use mouse mouse to wake up computer from screen saver.
    • 4: Type in user password to re-enter windows and the standard windows error dialog is displayed asking to submit error report to microsoft or not fallowed by a memory error message box.

This is not always reproducible. But it has happened to me 3 times today so I am posting it here. If I find a way to reliably reproduce the error I will post the info here. Be sure to save your work before leaving your computer with hammer running!

  • Suggestion: Currently when moving a texture on a brush by clicking the up/down arrows in the texture window, every move is a new undo level. If you hold the mouse and move the texture many units this can result in dozens of undo levels wasted with a simple texture adjustment. Every texture adjustment change on a face should be one undo level until you de-select it.
  • It is not possible to rotate brushwork & overlays simultaneously. Doing so results in the overlay no longer working. Fixing the problem of "unused key, angles" in the check for problems dialog doesn't do anything to fix this. I make a lot of symmetrical maps (CTF etc) so this is a total pain because it means I have to redo all the overlays for the second base... I've tried numerous approaches (including rotating, flipping on the x and y axis instead) and stuff, but I've not found anything that works yet. I've got 340 overlays to redo for the blue base now and I'm not best pleased! -- Defrag 11:29, 9 Sep 2006 (PDT)
  • This isn't exactly hammer, but I don't see a VBSP bug page: If you have too many surfaces emitting detail props and end up with more than USHORT_MAX (65535) detail props, VBSP will have two behaviors: First, if none of the remaining props are detail sprites, it will finish building the BSP and says "Error! Too many detail props on this map. {0} were not emitted!", where {0} is the number of detail models over. On the other hand, if you have so much as one detail sprite after the maximum, it errors out without saying how many over, and doesn't finish. I've fixed this to just the one behavior for myself, but might as well report it for all. --Kateye 18:37, 11 Oct 2006 (PDT)
  • The compile tools consider func_ladder a world brush, despite being tied to an entity. I've contacted the creator of CST, but he doesn't works on it anymore. Solokiller 10:04, 4 Mar 2007 (PST)
    • Workaround: use the tools/toolsinvisibleladder texture on ladders and make the ladder brush(es) func_detail or another entity (func_detail, unless you want to toggle the ladder or do some effect with it) Solokiller 09:37, 18 Jul 2007 (PDT)

  • every time after a few minutes (can be 1 ore 15) hammer crashes and i get this error:

An unhandled win32 exception occurred in hammer.exe [4400].

  • Make a an entity A parented to an entity B this one parented to A (like camera with func_rotating) make a game crash of course, but hasn't in ALT+P error, if you delete A or B and use cltr+Z Hammer will crash on next commands or in next seconds. Gectou4

Reports confirmed fixed or dismissed

General Hammer issues

  • Cursors don't always do what they're representing i.e. a drag cursor appears over a button or a text box.
    • Cursors appear to not update properly when they're hovered from one object type to another. i.e., When a brush is selected, and the Object Properties dialog overlaps the selected brush; if the user moves the icon over the Object Properties dialog, the cursor is still a 4-way arrow.
Should be fixed by today's update. --David Speyrer 19:48, 16 Jan 2006 (PST)
  • Creating an arch (mine was size 704x356, 180 degrees, wall thickness was 400 (full)) causes invalid solids when you save and reload the map. Also, the front faces of the solids are not drawn (probably due to the invalid solid part) even before saving. I tried this with 32, 64, and 128 face arches, all had the error. Also happened on a 3072x2048 arch, 180 degrees, 3072 wall thickness. Also, vertices end up half-way across the map when an arch is Clipped. --Beans-v6 15:06, 7 Dec 2005 (PST)
Not an SDK Beta bug.
  • I know we shouldn't use the Carve tool (and I'm not using it) but I was carving for a tutorial when a bug occurred. Try to carve a 128 units depth bloc with another 128 unit depth bloc and the carved bloc will be resized to several times the size of the whole grid in Hammer.. like infinite. --NykO18 09:45, 30 Dec 2005 (PST)
    • It seems to not happen anymore since the last updates. --NykO18 03:50, 20 Jan 2006 (PST)
  • All ents with the same model are set to the same sequence when the sequence is changed through the Model tab of the Object Properties page.—ts2do
    • This is a duplication of the bug explained 5 paragraphs higher

Hammer 2D and 3D Views

  • While drawing a brush in the 2D-View, and clicking accidentally outside the brush, the whole former brush disappears.
Could be fixed through decreasing sensitivity of new brush drawing.
Fixed by today's update. --David Speyrer 19:44, 16 Jan 2006 (PST)
  • In morph mode I can't use directional arrows to move in 2d wievports. It's a bit annoying to use sliders every time when I want to carefully manipulate bigger brushes.
Fixed by today's update. --David Speyrer 19:44, 16 Jan 2006 (PST)
  • Grouping Objects while 'ig' (Ignore groups) is on fails to group the selected objects.
Not reproducible. The objects are grouped, but you can't select them as a group until Ignore Groups is disabled. --JeffLane 14:59, 9 Jan 2006 (PST)
  • Displacement textures appear to be the exact opposite of what appears in-game—ts2do
    • Duplication of a bug explained in the previous section.

Hammer VGUI Model Browser

I noticed a couple of days ago when i tried to change one of my models, i clicked on the browse button to open up the VGUI Model Browser, hammer freezes up and does nothing, does the VGUI Model Browser not work anymore? (September 21, 2007)

Ok.. so i deleted the registry files for the VGUI Model Browser, and the VGUI Model Browser finally showed up in hammer, the only problem was, that there was just a gray window and a black box in the top left hand corner in that window, so what i did was stretch the window out, and for some reason the VGUI Model Browser corrected itself, pretty weird if you ask me. I think the reason why this may of happened, was because of my dual monitor setup, but i could be wrong, a theory that when i open up the VGUI Model Browser, i had ATI Hydravision installed, which saves your program/window positions on a monitor, so your program/window opens up on a specific monitor, i had the VGUI Model Browser set to come up on my second monitor, but when i switched to using my main monitor, hammer probably still recognizes that I still have a second monitor on so when i click on the button to open up the VGUI Model Browser, nothing shows up on my main monitor, thus resulting that it's trying to open it on the second monitor, which could of happened I'm not really sure. (September 28, 2007)

Hammer Autovisgroups

Hammer Autosave

  • Hammer tries to save to removable media, when it’s read only, same with read only folder rights. (This might not be a good idea for those working on source mods as final projects at Universities, or schools)
Fixed by today's update. Choose a different autosave directory in Options->General.--David Speyrer 19:50, 16 Jan 2006 (PST)

Hammer - Misc

Community bugs

Bugs found after the August, 2006 SDK update.


  • No access to Episode One assets from the tools. Mossman and Alyx can only be viewed in their HL2 versions, and Zombine, the core ball and other such new assets including textures and sounds

aren't visible at all. Occurs with the SDK set to both SDK Base and Ep1 itself.

  • When launching the tools via the new -run<tool> switches, |gameinfo_path|. is not searched. This hides all custom mod content when launching from a shortcut. Launching from the SDK menu is not affected.
  • When creating a new singleplayer mod, or setting the appid from 220 to 215 for a singleplayer mod makes the game crash during startup after the valve logo with the error: Error could not load library client. While changing the appid back to 220 makes it work again.--Bluestrike 04:24, 5 Aug 2006 (PDT)
This is because you have the wrong SearchPaths. See Talk:Source SDK Base#SearchPaths. --TomEdwards 04:26, 5 Aug 2006 (PDT)
Ah thx, but they still need to fix it for when creating a new singleplayer mod since its using the new appid but not the updated seachpaths. Also I don't get the "new game" button this way and would like to get rid of the stress test.--Bluestrike 04:37, 5 Aug 2006 (PDT)
See on this page. --TomEdwards 05:20, 5 Aug 2006 (PDT)
Don't see the relevance :), when creating a singleplayer mod the gameinfo has the updated appid, but not the updated searchpath, so I'm just saying that should be fixed so new people creating a singleplayer mod get something that works :)--Bluestrike 14:31, 6 Aug 2006 (PDT)
  • There is no link to vconfig.
  • vconfig crashes on launch with a steam.dll error.
  • There is no mapsrc for episodic or sourcetest. Equally, all of the sample maps are extracted to the hl2 folder.
They haven't released any sourcefiles for episode one by by knowledge so there is should not be any sourcefolders for it either.--Bluestrike 04:14, 6 Aug 2006 (PDT)
  • We now can build hdr maps and have the hdr code, but still need the splitter tool required to makde hdr skyboxes.--Bluestrike 04:14, 6 Aug 2006 (PDT)
  • I get this error: Attempted to create unknown entity type env_tonemap_controller! Can't init env_tonemap_controller or should I post this at #Source_SDK_Base Hdr is working, just not the custom values I want because the tonemap entity isn't recognized--Bluestrike 14:31, 6 Aug 2006 (PDT)
Same issue here. It isn't even recognised when I run the Source SDK base. The background map loads but I get the same message in the console -- Defrag 17:02, 10 Aug 2006 (PDT)
  • When typing in the console, possible commands appear on a dropdown window, but clicking on the one you need with the mouse no longer works, instead you have to type the whole command now. --Bluestrike 14:34, 6 Aug 2006 (PDT)
You can use the arrow and return keys to use the list until this problem is fixed. --TomEdwards 14:36, 6 Aug 2006 (PDT)
  • Short period of "Copying files" dialog on each load
  • The launcher frequently deletes custom game configs.
    • I got this as well. For the first time ever, it was this morning at 2am (EST). --the_hat 02:05, 26 Aug 2006 (PDT)
  • Height2normal.exe no longer works --Bluestrike 15:18, 11 Aug 2006 (PDT)
  • The current XSI Mod Tool link is outdated and unusable. Should link here.
  • All mods built after update include only single player animation sequences by default and requires multiplayer aniamations to be copied over from resources if they are to be found and used.
  • Singleplay mods using appid 215/searchpath sourcetest don't have access to the hl2 content.gcf so they can't use HL2 vcd's.
Workaround by copying the vcd's you use to your mod folder. --Bluestrike 10:25, 1 Sep 2006 (PDT)
You can also mount the GCF manually via the code --dutchmega 15:41, 1 Sep 2006 (PDT)
  • I try to run the map but failed to load the launcher DLL and the Compile process window shows that I can't load the skybox. Due to this I can't create mods or maps for Deatthmatch. Why can't I load the Launcher DLL or any skyboxes?

Source SDK Base

  • The menu system is not currently working as it should. Using Source SDK Base gives the Video Stress Test/Options/Exit menu, which isn't very helpful. Modders have to copy over various script files to get a functional menu, and even that isn't enough sometimes. A system that reads type from gameinfo.txt and displays the appropriate menu would be great.
  • There is no way to hide the commentary option in the New Game dialog without hacking it to appear outside the dialog's borders. Seeing as it's fair to say that most modders won't be using commentary, this is a fairly large issue. Could Source not check for the existence of *_commentary.txt before showing the option?
    • When you do use commentary, the background texture for the checkbox and label is missing.



Refresh sdk content.
Militia now loads but there is nothing to see but 4 black screens. I can place entity's in it. --Bluestrike 03:46, 14 Aug 2006 (PDT)
  • Displacements now let ragdolls and all physics objects clip straight through them, rather annoying --gingerlord 14:19, 6 Aug 2006 (BST)
Have to place a camera in the map, unsure if this is permanent or a future fix.
I have this problem too - what do you mean place a camera in the map? A point_camera?
  • Displacements in hammer depth fight with transparent brushes in 3d view.--vecima
  • Textures from .svn (of course you need to be using TortoiseSVN for this) folders now show up in Texture Browser, had this problem occasionally before SDK update, now showing up constantly. --gingerlord 14:24, 6 Aug 2006 (BST)
SVN working copy versions of props and sounds also show up in the respective browsers. Very annoying. -- Defrag
Yeah very annoying, I guess hammer finds the stuff in the hidden svn folders, I think making hammer unable to read hidden files could fix this? --Bluestrike 03:32, 14 Aug 2006 (PDT)
  • Turning Scaling Texture Lock off, while works, still displays stretching textures whilst resizing brushes. Once the mouse button is depressed, the scale snaps back to its original setting, but the effect of it stretching whilst resizing makes it cumbersome to effectively line up the edge of a brush with part of a texture. The same is also true of the texture lock - textures stay 'fixed' to the brush as its moved about, instead of being fixed to the world.


  • The new View menu option 3D Lighting Preview apparently doesn't work, instead filling the camera view with the black and pink checkers.
We are not supposed to have that option yet.
  • When changing from the logic view to a 3d view the screen stays black, Have to select a object and use ctrl+shift+e to be able to view the map.--Bluestrike 05:58, 5 Aug 2006 (PDT)
It appears there is no longer a default camera for the 3D window. One must be created (or ctrl-shift-e must be used) before anything appears in a 3D window. —BJ(talk) 10:46, 5 Aug 2006 (PDT)
Confirmed. I tried slicing the entire map up with huge brushes, and they didn't register in the camera view, so it's not just simply moved to somewhere else in the map, which was my first thought. --Andreasen 02:40, 7 Aug 2006 (PDT)
The camera defaults to looking straight up at the center of the map. Try creating a 256x256 brush that's 512 units above 0 and you'll see. --Aserp 22:21, 15 Aug 2007 (PDT)
Place a camera in the map.
  • 'Use Visgroup colors for object lines' option is nonfunctional. Objects are always shown with their default colours.
  • Viewport label does not appear until mouseover. Gets confusing when you are trying to manipulate them sometimes.
  • The hammer model browser has the option to select a specific mod now, but you can't select any option with the mouse (using the up and down keys works).--Bluestrike 04:20, 7 Aug 2006 (PDT)
    • This may just be me being insane, but I can't bring the Logical View back up at all. It appeared the very first time I started the SDK, and hasn't been seen since. --PiMuRho 14:59, 12 Aug 2006 (PDT)
yeah I haven't seen it anymore, not that it seemed that useful to me, but I would expect it to be in the camera dropdown menu where we can also select the lighmapsview but there is no option for it.
  • Sound Browser does not play custom soundscript entries. It plays the raw files fine.


  • Hammer has difficulty running games post-compile. It returns an error about being unable to load filesystem_steam.dll when I try with SDK Base, and loads Ep1 with HL2's script files.
  • Hammer game-launch option (apparently) no longer functions. Simply crashes (i.e., closes without indicated error). Restarting Hammer reports previous incorrect closure - asks if to reload last map. EDIT: problems appear to be resolved by restarting windows. —BJ(talk) 11:14, 5 Aug 2006 (PDT)
  • Texture lighting appears to be broken for me. vrad picks up lights.rad correctly and also reports that it has parsed the correct number of texlights, but the texture lights do not affect the lightmaps. Strangely enough, the viewmodel IS illuminated, so something is going awry related to lightmapping during rad. I've had a friend test this and the result was the same. -- Defrag 16:05, 10 Aug 2006 (PDT)
Update - this is.. bizarre. I've got the same texture light in two places and in one place it affects the lightmaps, but in the other it doesn't. The only difference is that one light is smaller than the other. I'll try and investigate more -- Defrag 18:16, 11 Aug 2006 (PDT)
It may not be a problem, just more a technical issue. The texture lights brightness alters the density of the lights put in front of the face during the compile, the lights snap to a grid and if your face is too small with a too dull brightness no light gets put there for world lighting during rad. Its something I've noticed and was planning on adding to the Glowing Textures article I'd written. --Angry Beaver 22:31, 11 Aug 2006 (PDT)
Haven't experienced any problems yet, are the texturelights perhaps inside a model? If that is the case you can try disabling shadows for the model.
No, they're just standard texture lights. They're not behind other geometry or enclosed by props or other geometry. Beaver: The lights are large and bright; curiously the behaviour is at odds what what you observed: The large lights don't emit while the same texture on a smaller brush in another area does emit. -- Defrag 10:12, 12 Aug 2006 (PDT)
Why not upload the relevant bits of the VMF somewhere? --TomEdwards 10:27, 12 Aug 2006 (PDT)
I've found the problem: the brush that was textured with a light was a func_detail. However, this should NOT cause texture lighting to bug on when it comes to creating the appropriate lightmaps during rad. To reiterate, the bug is that the lightmaps are not generated, but the light will still illuminate models such as the viewmodel. I also tried applying the texture light to a func_brush and it worked as normal, so something is causing lights on func_detail brushes to glitch. I've uploaded the files here as I couldn't figure out how to make thumbnails & image links without just posting a huge image by accident: Screenshots, .vmf and .rad files -- Defrag 12:04, 12 Aug 2006 (PDT)
Actually that glitch doesn't surprise me in the slightest. func_details work by being isolated from the map during the compile process, the lights are probably created by the process in the isolated space. I would of though that with func_Details ways of blocking light they'd still be in the same lighting hull but apparently not, and as they're not there the lights that are created are physically not where the other brushes are to generate the lightmaps then the brushes and lights get moved back into the regular world to light models. Or at least thats my best guess from what i know of the compile process. --Angry Beaver 12:52, 12 Aug 2006 (PDT)


  • Crash when maximising Hammer after a period of minimised inactivity.
  • Hammer crashes always when closing it (after long sessions)--Bluestrike 04:14, 6 Aug 2006 (PDT)
okay now hammer just 'disappeared' for the 2nd time in a hour without any messages. --Bluestrike 05:33, 7 Aug 2006 (PDT)
I've also encountered the magical disappearing Hammer today. It closed itself with no warning or errors. -- Defrag
Hammer crashes when opened from being minimised to task bar, happens every time for me. -- gingerLord
OK here's a reproducible one (at least for me). Select multiple brushes and go into vertex mode. Drag select around a line of handles and merge some vertices (merging multiple vertices on multiple brushes simultaneously) then exit vertex mode. It will bomb out every time without an error. -- Defrag 14:31, 9 Aug 2006 (PDT)
  • Update -- I've only crashed once as of the latest (11th August) update, so I'd say this one has been largely fixed. -- Defrag 23:43, 15 Aug 2006 (PDT)
  • if the 'world model' field is typed wrong when typing into the field of a prop_static, a big red error shows, if you then click 'browse' to select the model, hammer crashes (for me at least). -- vecima 24 Aug 2006


  • Func_door_rotating act as func_rotating in-game (object doesn't stop spinning)--Bluestrike 05:58, 5 Aug 2006 (PDT)
  • The buggy now starts without its weapon attached (any workarounds?)--Bluestrike 05:58, 5 Aug 2006 (PDT)
  • New npc_citizen entities default to Alyx's model and are armed with Alyx's gun.
  • env_tonemap_controller is a checkerboard sprite --Bluestrike 04:38, 6 Aug 2006 (PDT)
The entity is also not recognized in sourcesdk base (see general/laucnher at the top of the page)
  • Cubemap resolution has been upgraded, but the FGD still reports the old values in env_cubmap. 512x512 is actually 1024x1024, etc.
  • Using custom detailsprite textures in the worldspawn does no longer work. --Bluestrike 11:00, 10 Aug 2006 (PDT)


  • Wireframe covers the model in the 'missing texture' checkerbox instead of showing wireframe.
  • According to the combo box, the default view is BoneWeights. It isn't, of course.
  • Normal mapping is off by default, on my system. Very annoying.
Some are able to get normal mapping up by double clicking and for others again it just works (i have one of each systems, bot have Nvidia gpu 5950U and 8800GTS respectively) --Wolf 07:48, 4 Oct 2007 (PDT)
  • Selecting a submodel group causes that group to display the second submodel --Wolf 07:48, 4 Oct 2007 (PDT)


  • Faceposer crashes when I try to extract a wav in the phoneme editor, displaying a windows error. --Bluestrike 05:58, 5 Aug 2006 (PDT)
Confirmed. Perhaps it now uses a more recent speech API? --TomEdwards 13:06, 5 Aug 2006 (PDT)
  • Faceposer does not appear on the taskbar until it receives focus.
  • Faceposer's interface can lose all of its icons. This happened some time ago for me and I've never been able to get them back.
It has been suggested that this is due to Face Poser looking in the wrong directory for these .GIF graphics. --Katana314 19:53, 6 Feb 2008 (PST)
  • Expressions: head tilt, head updown and head forwardback are not applied until a the sliders is moved by hand. This will show up if you select an Expression using one or more of those sliders immediately after starting Faceposer.
  • The global Event Tags and the gesture-only Timing Tags look identical.
  • Expression thumbnails are created without removing the 3D View's gestures/sequences. This can result in obscured images if the animation places limbs in front of the face.
    • Same problem when there are multiple actors in the 3D View.
  • The Animations dialog lets you refresh all thumbnails. This is dangerous and will hang Faceposer and Steam if used on a model will lots of animations (e.g. Alyx). Should be removed or require confirmation.
  • When creating an Expressions event, expressions are duplicated two or three times each in the lower combo box.
  • Help > Goto Homepage still links to VERC. Should link to Category:Choreography, or another VDC page.
  • When pressing play while the scene is already playing, speech events from the first playthrough will continue, overlapping the second playthrough.
  • Clicking 'Edit <event> in <tool>' does not open the tool if it is closed.
  • Critical: Special characters not escaped in event, channel or actor names. Add an " anywhere and FacePoser will crash when trying to load the scene! { and } are not affected.
  • I've just noticed that each of the speak events that I've done custom phonemes for has had the exact same emphasis pattern inserted without any action on my part.

SDK Code

  • Unable to compile shaderlib.lib, due to missing header IShaderSystem.h. A quick search shows that this file isn't anywhere in the available code. This applies specifically to the 9/14 update, since the project for shaderlib didn't exist in the SDK prior to that date. I've already filed a report on the SDK bug tracker. Hopefully, Valve can quickly toss out the missing file, meanwhile, I'm thinking I might try to cobble together a header, based on the functions used in the code... --The Equalizer 00:44, 2 Oct 2006 (PDT) This was fixed in the 10/31 beta, and is now a part of the official SDK. --The Equalizer 13:58, 20 Nov 2006 (PST)



  • Changing the SteamAppId to 215 in our mod seems to enable the new engine (version 7, build 2803) but HDR is not functional. building cubemaps you can see that there is no tonemapping going on and I have noticed that certain HDR related console commands are missing (eg tonemap control and mat_forcebloom)
If your mod is using their own client.dll file its still using the old engine and the mods coders need to do their magic on it but I'm not a specialist on that matter tough :) but the hdr testmap worked fine in my sp mod --Bluestrike 07:06, 5 Aug 2006 (PDT)
You must merge the new SDK source code into your mod's DLLs to expose the game hooks. Maps must be compiled with HDR too, but I'll assume you're already doing that. ;-) --TomEdwards 07:08, 5 Aug 2006 (PDT)
Thanks for the help, im sure our coder is going to be very pleased about having to do that :P


The shortcut fix doesn't work for me. Hammer loads and everything appears to be fine, but all of my mod's materials aren't displayed properly. HL2 resources are displayed as normal. Edited, this is now working fine for me. -- Defrag 12:23, 12 Aug 2006 (PDT)

What game is the SDK set to? --TomEdwards 07:58, 5 Aug 2006 (PDT)
This Hammer shortcut method still works for me, for each game mode. --wisemx 08:06, 5 Aug 2006 (PDT)
Doesn't work here. I get the "steam.dll not found" error message that occurs when using a standard shortcut; that is, right-clicking on hammer.exe -> create shortcut. --RDB 14:41, 5 Aug 2006 (PDT)
OK, I've hit the problem and it's a bug when launching the tools with the new shortcut switches. I've added it as a bug. You'll have to launch through the GUI menu for now, or use wisemx's solution. --TomEdwards 08:26, 5 Aug 2006 (PDT)
  • Can't find this page using the search box, are talk pages ignored by it? In that case should we make a dedicated page for all these bugs?
    • At the bottom of the search results, uncheck main and check talk instead. --Pizzahut 09:57, 14 Aug 2006 (PDT)
Creating maps and running them is failing from the launcher DLL not being found. Why can I not run maps anymore for any games?

New mods crashing when starting from steam menu

As suggested, I have tried to add -allowdebug and -dev to the launch options, but it still crashes out with a "ding" sound and without any error box. But running the mod from run_mod.bat or from the shortcut created after pressing "Create Desktop shortcut" it start properly and doesn't throw any error.