HDR Skybox Creation

From Valve Developer Community
Jump to: navigation, search
English (en)русский (ru)
Edit
HDR skyboxes (left) benefit from a wider range of brightness values.

Unlike most textures in a game, a skybox typically represents a collection of very large and very bright objects. This makes the need for high dynamic range imaging far more pressing.

VTF textures used for HDR skyboxes store their colors either lightly compressed in 16-bit floating point (RGBA16161616f) or heavily compressed as 8-bit integer values (BGRA8888). In either case, they are created by VTEX from uncompressed 32-bit floating point Portable Float Map (.pfm) files.

Tip.pngTip:Uncompressed HDR VTFs can be converted back PFMs by vtf2tga (despite the name).
Compressed HDR VTFs can be decompressed to EXRs by no_vtf.
Blank image.pngTodo: Create Source 2 version of this page's information

Creating PFMs

Creating Proper PFMs With Photoshop

Creating HDR PFMs is very easy, but the way of doing this is not stated anywhere:

  1. Obtain a common format HDR file, like .hdr or .exr (the most popular one). It could have any bit-depth you like: both 16 and 32 bit should work fine.
  2. Import it to Photoshop (Adobe srgb 1998 or REC709 should work fine) and make sure that the Photoshop file is set to 32/16 bit-depth (Image --> Mode --> 32 Bits/Channel OR 16 Bits/Channel).
  3. Go to File --> Save As or Press ctrl + shift + s (or alt + ctrl + s).
  4. From the dropdown of available formats choose "Portable Bit Map", change the .pbm in the file name to .pfm and click "Save". You now have a proper .pfm file for further use with VTEX.
Warning.pngWarning:There's a thing called "Endianess" or "Byte order", for VTEX to properly convert your 16/32 bit HDR files it has to be set to little endian, not big endian. (This doesn't seem to apply to 8 bit non-hdr files, like .png, .jpg, .tga and so on).
Tip.pngTip:To set the endianness when converting using ImageMagick, use the -endian LSB parameter.


Tip.pngTip:
Half the size, all of the (actually visible) image
Since the lower halves of skybox sides generally aren't seen, it's often wise to cut away that area. For this trick to work, you must compile the side VTFs with these extra commands:
clamps 1
clampt 1

And add this command to the materials:

$basetexturetransform "center 0 0 scale 1 2 rotate 0 translate 0 0"

See #Creating the materials for details on how to use the commands.

Additionally, an unseen bottom skybox face can be made a single color and a small resolution, such as 4x4.

Skies at different exposures

Before creating a HDR skybox we need to know what the sky looks like at different exposures:

Photos of the sky at various exposures.

As you can see, the captured image changes as the exposure is altered. A single 8-bit image could never be used to create those effects: at 8-bit white is white, and the sun would only stand out if it was literally a different colour from the rest of the sky.

Create a Base Skybox

First you need to create a basic skybox cube, as you would for an LDR skybox. See Skybox (2D).

With your images ready, arrange them in one large file as seen below. This step is required only if you are using the splitskybox tool. If you aren't then you are quite free to handle each texture separately.

Recommended skybox layout (labelled)

Save this assembled image as a TGA file. If you are prompted, do not use RLE compression and do place the origin at the bottom left.

Adding HDR Data

The following will demonstrate the basic steps for painting a "sun" effect into the different exposures and saving the file as a PFM. We'll use https://vgl.ict.usc.edu/HDRShop HDR Shop] for this demonstration.

Warning.pngWarning:HDR Shop is free for non-commercial use, but commercial usage requires a pricey license. You will have to search the internet for the freeware version.

After it is installed, launch the application, and then open the above TGA you created above. When this window appears leave the default settings and Select OK'.

Hdrshop curvedialog.png

The skybox after the response curve has been adjusted in HDR Shop. Click to enlarge.

HDR Shop works by taking files created by other image editors for different exposures and merging them together at 32-bit floating point. To paint the "sun" into the skybox you must first choose an exposure to edit. The + and - keys are used to adjust the image exposure up and down. The lower right hand corner of the screen indicates the exposure level, +0.00 stops indicates the base exposure level that was imported into HDR Shop. Adjust the exposure level so it reads -3.00 stops Then, go to the menu: File -> Edit in Image Editor. The image-editing program you have associated with BMP format will automatically open up this file as a 24-bit 🖿HDRShopTEMP.bmp. Now paint the sun into this file.

When finished save the image and return to HDR Shop.

After clicking OK in this dialog, the current exposure level will be updated with the image that was just painted with the image-editing program.

Hdrshop OKdialog.png

Hdrshop saveas.png

Try adjusting the exposure up and down in HDR Shop with the + and - keys and you'll see that the sun is now integrated into the other exposures. Continue editing the different exposures until the desired result is achieved. It will be a good idea to spend some time emulating the blown-out effects around the sun and the highlights on the clouds as seen in the photographic reference.

When finished go to the File menu and choose Save as… and Select Portable Floatmap (.PFM) Save this file into your 🖿materialsrc content directory (e.g. 🖿steamapps\common\Day of Defeat Source\dod\materialsrc\skybox).

Note.pngNote:There is a more detailed tutorial available on HDR Shop's website.

sdk_sky_exampleup

sdk_sky_exampleup

Let's do this with 🖿sourcesdk_content\dod\materialsrc\skybox\sdk_sky_exampleup.tga. Open it up and adjust the exposure to -3 stops, then edit the image externally. Now paint in a sun.

After returning to HDR Shop and OKing the dialogue, the current exposure level will be updated with the image that you just painted.

Try adjusting the exposure up and down and you'll see that the sun is now integrated into the other exposures as well. Continue editing the different exposures until the desired result is achieved. It will be a good idea to spend some time emulating the blown-out effects around the sun and the highlights on the clouds as seen in the photographic reference.

Split the Skybox

If you created your skyboxes in a single file as in the above image, you will need to use splitskybox.exe to split it into six. Just drag the PFM onto it.

Note.pngNote:splitskybox Ep1 does not currently function. However, the OB version will work with either version of the engine.
Note.pngNote:In Left 4 Dead 2 Left 4 Dead 2, Splitskybox is not a required step. And in fact will not work without lots of retyping of suffixes of multiple files. Left 4 Dead 2's iteration of VTEX is able to take your "T" image array (both tga into LDR and pfm into HDR) and process it directly into the proper <name_bk>vtf format. In order to do this, create your "T" array as above. Recommended simply for the sake of sanity to get proper orientation for the top (and bottom if needed) images in your custom skybox. Create your txt file as normal and drag it onto Left 4 Dead 2's Vtex. Create materials and use in game as normal. A caveat here is, although the vtf files are compiled properly for LDR, if you are opting out of an HDR skybox and plan to use a LDR skybox only, the supplied LDR material template in the Skybox (2D) tutorial does not work. You will get the checkerboard pattern. If you are trying to import an HDR skybox (meaning, if you rendered out a set of skybox textures in your external software, and then used HDRShop to create the hdr data) of a night sky, you will experience extreme banding in the darker areas which resemble dx compression. This banding is actually a result of the way HDRShop handles color information and can be observed directly in HDRShop if you adjust down the exposure and inspect your image.

Creating the Materials

At this stage you should have six files:

  • 🖿[skyname]_hdrft.pfm
  • 🖿[skyname]_hdrlf.pfm
  • 🖿[skyname]_hdrbk.pfm
  • 🖿[skyname]_hdrrt.pfm
  • 🖿[skyname]_hdrup.pfm
  • 🖿[skyname]_hdrdn.pfm

Make sure they are under 🖿your_mod\materialsrc\skybox\. You now need to create six corresponding TXT files (e.g. 🖿<skyname>_hdrft.txt) alongside them, in order to compile to VTF. Each must contain:

pfm 1 // tells vtex to load a a .pfm file instead of a .tga file
pfmscale 1 // brightness multiplier
nonice 1 // prevent seams appearing at low texture detail
skybox 1 // alternative to nonice, if NICE filtering is desired
nocompress 1 // optional; removing halves file size, but causes color banding under close inspection
pointsample 1 // needed for compressed HDR skies, otherwise there will be harsh pixelation artifacts in-game. Don't use for uncompressed HDR

Drag these text files onto VTEX and it will compile them (unfortunately VTFEdit doesn't import PFMs, nor properly handle other formats when HDR). The VTFs will appear in the corresponding materials subfolder (e.g., 🖿your_mod\materials\skybox\).

Now you just need to create six VMTs named 🖿<skyname>_hdr<face>.vmt. These should read:

Sky
{
	// if you compiled with nocompress:
	$hdrbasetexture		"skybox/sdk_sky_example_hdrft"

	// if you didn't:
	$hdrcompressedtexture	"skybox/sdk_sky_example_hdrft"

	// LDR fallback
	$basetexture		"skybox/sdk_sky_exampleft"
}
Confirm:If the source image for the skybox texture isn't HDR, is it possible to use an LDR texture for $hdrbasetexture?

Creating LDR Fallbacks

Tip.pngTip:(in all games since Counter-Strike: Global Offensive)(also in Left 4 Dead 2) LDR fallbacks aren't necessary for games that are normally HDR-only.

You must also create standard dynamic range VTFs (LDR fallbacks) for users who do not play in HDR. Compile with these settings:

nonice 1
dxt5 1 // or nocompress
Clarify: Why is DXT5 necessary? Skyboxes aren't translucent, so shouldn't DXT1 be sufficient? The LDR skyboxes in Half-Life: Source are BGR888, with no alpha channel. The "hint DXT5" flag may be sufficient, if that even does anything.

These are ordinary textures, so you can use VTFEdit if you prefer. There is no need to create new materials for LDR users; they will load the _hdr ones.

Additional creation notes

Icon-Important.pngImportant:To avoid seams appearing at the edges of skies, open the resulting VTFs in VTFEdit VTFEdit, then add the Clamp S + Clamp T flags and/or the "no mipmaps" flag. For compressed LDR skyboxes, use the "hint DXT5" flag.
Tip.pngTip:If an LDR fallback is present, the HDR skybox is compressed, and mipmaps are disabled, then open the compressed HDR skybox in VTFEdit, export as TGA, and reimport the exported images back into VTFEdit with mipmaps disabled. This will remove mipmaps from the file, saving a significant amount of space.
Note.pngNote:This does not work properly for uncompressed HDR, as VTFLib doesn't properly handle import and export of HDR formats. Additionally, mipmaps should be left in the LDR fallback, so that the skybox materials display correctly in Hammer's texture browser.

Usage

In Hammer Hammer 4.x, go to Main Menu > Map > Map Properties > Skybox Texture Name and type the name of your skybox, relative to 🖿materials\skybox\ and without any of the face suffixes. (e.g., mysky_hdr if the VMTs are 🖿materials\skybox\mysky_hdrXX.vmt.)

If there is an underscore before the face names, then these must be included as well (ex: mysky_hdr_ if the VMTs are 🖿materials\skybox\mysky_hdr_XX.vmt.)

Note.pngNote:Skybox selection is based on the VMT names, not the VTF names. Multiple faces of the same skybox can share a VTF, provided they have separate VMTs, and multiple skyboxes can use the same VTFs.
Icon-Bug.pngBug:Skyboxes may fail to load if placed in a subfolder of 🖿materials\skybox\; use a prefix if organization is necessary.

See also

Environment articles:
Skies and environment maps Skybox (2D)Skybox (3D)HDR SkiesSkybox with TerragenSkybox with Terragen - AdvancedList of skies
Terrain and displacement mapping DisplacementsCreating Holes in DisplacementsDigital Elevation ModelsCreating custom terrain with Worldmachine