Hammer: меню Вид

From Valve Developer Community
< Ru
Jump to navigation Jump to search
English (en)Deutsch (de)Русский (ru)Translate (Translate)
Меню Вид.

Назначение функций в этом меню - управление тем, что должно показываться в 3D/2D видовых экранах(en) редактора Hammer. Более подробную настройку внешнего вида смотрите в параметрах Hammer Tools > Options... (Инструменты > Параметры) на закладках Основные, 2D виды, 3D виды.

Screen Elements (Панели)

Это подменю используется для выбора панелей инструментов, которые отображаются в интерфейсе редактора. Снятие выбора пункта удаляет его из интерфейса редактора, выбор снова - возвращает его обратно.

Icon-Bug.pngБаг:Панель отмены/повтора отсутствует в этом списке. Если эта панель закрыта (это можно сделать, вытащив её из панели инструментов и нажав на кнопку закрытия окна), её можно будет вернуть только с помощью редактирования настроек Hammer в реестре Windows.  [нужно проверить в ?]
Icon silk wrench green fix.pngРешение:В редакторе реестра Windows удалите параметр clear из ..\SOFTWARE\Valve\Hammer\Barstate-Bar1
Note.pngПримечание: В Hammer для GoldSrc GoldSrc создаёт параметры в директории Valve Hammer Editor

Hammer viewsubmenu.png

Autosize 4 views <Ctrl+A> (Авторазмер 4-х видовых экранов)

Восстановит расположение всех 4 видовых экрана(en) по умолчанию, если их размер был изменен - будет четыре секции равного размера.

Note.pngПримечание: Эта команда не работает если включен параметр "Use independent window configurations (Независимые параметры окон)(en)".

2D Window Options (предустановки 2D вида)

По умолчанию рабочая область редактора разделена на 4 отдельных видовых экрана(en). Три из них используется для 2D вида. Четвёртое окно показывает содержимое карты в 3D.

Чтобы выбрать с какого вида будет проекция в 2D окне - 2D (верх) X/Y, 2D (анфас) Y/Z, и 2D (профиль) X/Z, наведитесь на верхний левый угол 2D окна и нажмите на слово которое высветится, это слово означает какой вид сейчас включён на данный момент. По умолчанию окна в редакторе настроены на каждый из доступных видов по очереди.

Tip.pngСовет: X/Y это вид сверху, Y/Z это вид спереди, а X/Z вид сбоку.

3D Window Options (предустановки 3D вида)

Доступны шесть пунктов предустановок для 3D вида - 3D Wireframe (Рёбра), 3D Filled Polygons (Пустые полигоны), 3D Textured Polygons (Текстурированные полигоны) and 3D Shaded Textured Polygons (Оттенение текстур), а также недавно добавленные - 3D lighting preview (Просмотр освещения) и 3D raytrace preview (Рентген).

Icon-Bug.pngБаг:3D lighting preview и 3D raytrace preview работают некорректно.
Куб, визуализированный первыми 3-мя способами отображения. (3D Рёбра, 3D Пустые полигоны, 3D Текстурированные полигоны)

Center Views on Selection <Ctrl+E> (Центрировать на 2D видах)

Эта функция перемещает 2D-вид к центру выделенных объектов.

Center 3D Views on Selection <Ctrl+⇧ Shift+E> (Центрировать на 3D виде)

Эта функция перемещает 3D-вид к центру выделенных объектов.

Go to Coordinates... (Перейти к координатам)

Перемещает 3D и 2D-виды на видовых экранах в координаты, указанные в поле диалогового окна Go to Coordinates (Перейти к координатам)(en).

Go to Brush Number... <Ctrl+⇧ Shift+G> (Перейти к элементу)

Перемещает 3D и 2D-виды на видовых экранах к элементу, номер id которого указан в поле диалогового окна Go to Brush Number (Перейти к элементу)(en).

DotA Camera (Камера сверху)

(только в Portal 2) В версиях Hammer для Portal 2 есть возможность использовать камеру вида сверху Dota 2. Вероятно, это связано с тем, что Dota 2 (предшествующая Reborn версия) была создана на основе ветви Portal 2 engine branch, и Valve случайно или каким-то образом перенесла эту функцию обратно в Portal 2 Hammer, либо Valve просто обновила Hammer для Portal 2, чтобы использовать эту функцию при создании карт для Dota 2, используя обновленную версию Portal 2 Hammer с функцией камеры DotA.

Show Connections (Показать связи)

Сущность и её цель с включенным показом соединений.

Включение этого параметра будет показывать связи между объектами по значения ключ-параметров target(en) и targetname(en).

Note.pngПримечание: Эта функция фактически устарела с введением в Source системы ввода вывода(en) объектов.

Show Helpers (Показать метки объектов)

Несколько выделенных объектов с включёнными метками.

Включает и выключает показ некоторых параметров выделенных объектов в 2D окне. Работает только если сущность выделена.

Например:

  • Формы распространения света и параметры point_spotlight(en).
  • Дистанции начала исчезновения и полного исчезновения объекта prop_static(en).
  • Начальная и конечная точки оси шарнира phys_hinge(en).
  • Метки точек отсчёта объектов у которых они существуют. (Подробнее см.в Координаты(en))
Tip.pngСовет: При включении даёт возможность управлять этими параметрами из 2D окна.

Show Models in 2D (Показывать модели в 2D)

Эта функция включает показ моделей в 2D-видах. Если выделить модельный объект, то его модель будет показана полностью с текстурами, при снятии выделения - как сеточный каркас.

Hide Items (Скрыть модели)

Выбор пункта Hide Items (Скрыть модели) скроет все точечные объекты на видовых экранах, повторный выбор пункта - покажет их обратно.

Note.pngПримечание: Нельзя включить показ объектов с помощью окна VisGroup, только снова выбрав эту команду в меню.

Hide Entity Names (Скрыть имена объектов)

Включает и отключает показ имён всех объектов в 2D-видах.

QuickHide Objects <H> (Скрыть выделенное)

Эта команда скрывает выделенные объекты карты.

QuickHide Unselected Objects <Ctrl+H> (Скрыть невыделенное)

Эта команда скрывает все НЕ выделенные объекты карты.

Unhide QuickHide Objects <U> (Показать скрытые объекты)

Эта команда показывает все скрытые объекты карты.

Convert QuickHide objects to VisGroup (Скрытое в группу)

Эта команда позволяет объединить скрытые объекты карты в новую видовую группу(en).

Note.pngПримечание: Созданная группа будет называться "_FromQuickHide<количество скрытых объектов>"

Move Selection to VisGroup (Переместить в группу)

Открывает диалоговое окно Move To Visgroup(en) в котором можно создать и/или переместить выделенные объекты в видовую группу.

Draw Materials Opaque (Не отображать прозрачность)

Отключает прозрачность у всех материалов в 3D-виде.

Note.pngПримечание: Если в 3D-виде выбран способ визуализации 3D Textured (Текстурированные полигоны), то при включении этой функции всё станет чёрным, чтобы исправить это - сделайте какое-нибудь действие, например выберите Selection Tool нажатием клавиш ⇧ Shift+S.

HDR (Широкий диапазаон)

Подсказка при наведении курсора на этот пункт отображала "Change the window size (Изменить размер окна)". Этот пункт не работает и неисправен. Он был удалён в Hammer++ Hammer++.