Portal 2 with Alien Swarm Authoring Tools:jp

From Valve Developer Community
Jump to: navigation, search
English Русский

Portal 2用のSDKは現在リリースされていません。 しかし、Alien Swarm SDKに含まれているValve Hammer Editorを使えば、Portal 2で利用出来るマップを編集、コンパイルすることができます。

ノート:以下にあるパスの起点は全てSteamのメインフォルダになります。 (例えば C:\Program Files\Steam\)

チュートリアル

  1. Alien Swarm SDKをインストール。
  2. Alien Swarm SDKを起動。
  3. Portal 2用に設定を追加。
    1. Edit Game Configurationsを選択、Addをクリック。
    2. Name欄に設定名を入力。
      Portal 2
    3. Directory欄にPortal 2のgameinfo.txtのあるパスを入力。
      ...\steamapps\common\portal 2\portal2
    4. OKをクリック。
  4. gameinfo.txtを編集。
    1. テキストエディタでPortal 2のgameinfo.txtファイルを開く。
      ...\steamapps\common\portal 2\portal2\gameinfo.txt
    2. SearchPathsの部分が下記になるように行を追加。
      SearchPaths
      {
      Game |gameinfo_path|.
      "Game" "platform"
      }
    3. gameinfo.txtを保存して閉じる。
  5. SDKを再起動する。
  6. SDKのCurrent Game欄を選択。
    Portal 2
  7. Hammer World Editorを起動。
  8. Hammerの設定を変更。
    1. Game Configurationsを編集。
      Tools > Options - Game Configurationsを選択。
      1. Configurationを選択。
        Portal 2
      2. 非公式のPortal 2 FGDファイルをインストール。
        1. Remove swarm.fgd under Game Data files.
        2. portal2.fgdをダウンロード。
          非公式FGDファイルリストを参照。
        3. Move portal2.fgd to an appropriate directory.
          ...\steamapps\common\portal 2\portal2
        4. Add portal2.fgd
          ...\steamapps\common\portal 2\portal2\portal2.fgd
      3. Game Executable Directoryを変更。
      4. Game Directoryを変更。
      5. Hammer VMF Directoryを変更。
      6. Prefab Directoryを変更。
        Warning: If this directory does not exist, Hammer will silently crash on start.
      7. OKをクリック。
    2. Build Programsを編集。
      Tools > Options - Build Programsを選択。
      1. Configurationを選択。
        Portal 2
      2. Game executableを変更 (Alien SwarmではPortal 2のマップは実行できないため).
        $SteamUserDir\portal 2\portal2.exe
      3. Compiled Maps Directoryを変更。
      4. OKをクリック。
    3. コンパイラオプションを変更。
      1. Run map [[advanced]] ダイアログを開く。
        File > Run map - Expert...
      2. $bsp_exe のパラメータを変更する。
        "-alldetail"を削除。
      3. Closeをクリック。
  9. Hammerを再起動。

非公式FGDファイルリスト