Portal 2 с Alien Swarm Authoring Tools

From Valve Developer Community
Jump to: navigation, search
English 日本語

SDK для Portal 2 пока недоступен. Однако Hammer для Alien Swarm SDK можно настроить для редактирования и компиляции карт, которые будут работать для Portal 2.

Примечание:Все папки перечислены для моей версии (т.е. C:\Games\Portal2\)

Инструкция

  1. Установите Alien Swarm SDK.
  2. Запустите SDK.
  3. Добавьте в настройки Portal 2.
    1. В Ultilities выберите Edit Game Configurations, затем нажмите Add.
    2. Введите название.
      Portal 2
    3. В директории введите путь к файлу gameinfo.txt игры Portal 2.
      Пример: "C:\Games\Portal2\portal2"
    4. OK.
  4. Модифицируем файл gameinfo.txt в папке с игрой.
    1. Открываем gameinfo.txt (для Portal 2) через любой текстовый редактор.
      Пример: "C:\Games\Portal2\portal2\gameinfo.txt"
    2. Находим и заменяем SearchPaths для Alien Swarm.
      SearchPaths
      {
      Game |gameinfo_path|.
      "Game" "platform"
      }
    3. Сохраняем и закрываем gameinfo.txt.
  5. Перезапускаем SDK.
  6. Выбираем в Current Game, в SDK.
    Portal 2
  7. Запускаем Hammer.
  8. Настраиваем Hammer.
    1. Изменяем Game Configurations.
      Tools > Options - Game Configurations
      1. Выбираем Configuration.
        Portal 2
      2. Устанавливаем неофициальные файлы Portal 2 FGD file.
        1. Remove (Удаляем) swarm.fgd под Game Data files.
        2. Загружаем portal2.fgd
          Смотрите #List of Unofficial FGD Files.
        3. Перемещаем portal2.fgd в любую для вас удобную папку.
        4. Пример: "C:\Games\Portal2\SDK\"
        5. Нажимаем Add (Добавляем) portal2.fgd
          Пример: "C:\Games\Portal2\SDK\portal2.fgd"
      3. Изменяем Game Executable Directory (папка с исполняемыми файлами).
        1. Пример: "C:\Games\Portal2\"
      4. Изменяем Game Directory (папка с дополнением).
        1. Пример: "C:\Games\Portal2\portal2"
      5. Изменяем Hammer VMF Directory (папка с картами для Hammer).
        1. Пример: "C:\Hammer Maps\"
      6. Изменяем Prefab Directory (папка с доп. файлами игры).
        1. Пример: "C:\Games\Portal2\portal2\maps\prefabs"
        Внимание: Если вы не укажете папку, то Hammer будет выдавать ошибку при старте.
      7. OK.
    2. Редактируем Build Programs.
      Tools > Options - Build Programs
      1. В Configuration выбираем.
        Portal 2
      2. Изменяем Game executable (так Alien Swarm не будет пытаться открыть Portal 2 maps).
        Пример:"C:\Games\Portal2\RUN_P2.exe"
      3. Изменяем Compiled Maps Directory (куда будут сохраняться карты).
      4. OK.
    3. Изменяем настройки компилятора.
      1. Создаём новый файл
        File > New.
      2. Называем файл как угодно.
        Пример: "test.vmf"
      3. Нажимаем File > Run map диалог.
        File > Run map - Expert...
      4. Редактируем $bsp_exe "parameters" (параметры).
        Убираем "-alldetail"
      5. Close (Закрываем).
  9. Перезапускаете или выходите из Hammer.

Лист неофициальных FGD файлов