Source SDK SE2 Bugs

From Valve Developer Community
Jump to: navigation, search
Note:Now there is a GitHub repository where bugs and features requests can be submitted (it's specified that it's for Linux versions)

This page is for reporting bugs in the current (beta) version of the Source SDK, currently known as the 2010 beta.

This page has been cleared to accept new reports for the May 2010 release of the SDK. For older bug reports, see:
December 2007 Community Buglist
January 2008 Community Buglist


Source SDK Update 05/11/2010

Note: The new version of the SDK is a beta and therefore is not the final version!


Please report any issues you find in Bugzilla(Link is Broken!).

General Source SDK Issues

Hammer Issues

General

  • Still getting blank viewports on Hammer. I believe this is a major problem. Tried to find a solution but didn't found any and I don't want to use 3rd party patches. I know there are a lot of users like me that have the same problem. Already reinstalled the SDK and have the lastest driver for my video card (GTX 460). Please tell us when are you planning to solve this because I really want to keep working on my mod. (Sorry if this is not the place to post this and if there is something that isn't really clear but I think that we all are aware of this issue). -medl 2:45AM, 27 January 2012
You mean there's no grid showing up? —Mattshu 22:38, 26 January 2012 (PST)
No grid in any viewport. I can use the brush and create; but blinded (can't see anything; no gridlines, no brush). I see the result in the Camera View but nothing in the other three. --medl 06:44, 27 January 2012 (PST)
Try pressing Shift+R, you may have the default grid system toggled off. --Pichubolt090 02:52, 12 May 2012 (PDT)
I have the same problem, and I tried pressing Shift+R, and it still has a black screen on all viewports with no grid. I am trying to make maps for my source mod for Portal, and with any other game I can see the grids and everything. --darkdarts214 11:15 AM 8 June, 2012 (GMT-5)
Try going into gammeinfo.txt (steam/steamapps/sourcemods/<your mod name>) and changing the appid to 218. That worked for me. --yoyodaman234 17:48, 22 June 2012 (PDT)
I have tried that solution, as well as copying the special 'editor' materials/models/etc from the SDK's GCF, but I still have blank viewports, as well as 3D objects becoming a solid black most of the time. HiveLordLusa 22:23, 13 July 2012 (PDT)
  • If you right-click an entity with a model parameter (like prop_static) and open the model selection dialog, closing the model selection dialog and reopening it without closing the entity properties dialog first will cause the model selection dialog to be unresponsive to clicks. Flarn2006 02:59, 30 January 2011 (UTC)
A quick solution is to close the unresponsive model viewer, deselect the entity, then reselect the entity, then reopen the model viewer. -Mattshu 05:54, 30 January 2011 (UTC)
  • A Cascade Loop is created in the Torus Creation tool when the user deletes the value in a Required Field and refreshes the Preview. With no value a popup returns stating to put a value in the field, exiting the popup returns the same popup.I.E. Removing the Rotation height value. Suggested fixed Set to 0 if no value is found. - -Badger- 2:11 AM Tuesday, February 01, 2011 (UTC) ***update*** This is found with most Fields in the Torus Creation tool, suggestion stands to set default as minimum Value accepted in the event a value is either not found or the value is lower than the minimum. - -Badger- 9:09PM Monday, February 07, 2011 (UTC)
  • (Build 5004) CSS: FUNC_CONVEYOR inputs are showing 2 "SetSpeed" options, neither of which works when referenced. User: Worm 00:07, 18 July 2010
  • BUG: "env_embers" "Parent" option needs a fix as it don't work at all (Parent option is broken). Option for "env_embers" to have a working "enable" and "disable" on trigger. (As they can't be turned off and on)
  • If the Steam user name is an email address, or has an '@' symbol in it, Hammer will always save the map in steamapps with the user name as the file name. This might also occur with other symbols. Solokiller 08:54, 29 January 2012 (PST)
  • Pasting func_instance entity keyvalues only affect the first selected entity if multiple selected.
  • The Particle System Browser in CSGO Hammer doesn't read from the vpk, making it necessary to extract the files.
  • "animatedTextureFrameRate" below 1 causes issues.
  • Moving brush entities with groups ignored doens't move the entity origin. Feature or bug?
  • Adding a info_player_start entity in a custom Hammer map for Episode Two that DOES NOT have any leaks in it causes Hammer to crash no matter what.

Displacements

  • If multiple displacements of different powers are being subdivided, displacements sometimes distort themselves in a certain direction on random vertices. --Mattshu 04:29, 1 February 2011 (UTC)

Viewport issues

Sidebar Menus

2009 version

Face edit dialog

  • The arrow keys now alter the alignment of the currently selected textures. In previous versions of Hammer the arrow keys moved the camera angles. Can an option be added to toggle this behavior? Solokiller 09:53, 13 June 2010 (UTC)
  • The random X and Y buttons sometimes forget what axis they are and have to be reminded by changing the number manually. Might stem from Copy Face function (ALT + Right Click).

Face edit sheet

  • Rotate a texture and select a different one. Now if you want to go back to the first texture and change the rotation from, for example, -35 to -36 and use the up or down button to do so, it will automaticly jump to -359. You'll have to enter -35 again and start over. This has been around for over 10 years, but I thought I might finally report it. Hezus 7 October 2010

Compile Tools

VBSP bugs

VRAD bugs

Randomly causes corrupt lightmaps that look like "ink spills".

See also