December 2007 Community Buglist

From Valve Developer Community
Jump to: navigation, search
Note.png Note: After the new Nov 8th SDK has been updated, it's very important to Reset Game Configuration before the Episode Two hammer can be launched. This is caused by the gameconfig.txt pointing to folders/files that are now outdated/move/changed.
Note.png Note: The Episode One compile tools/hammer works again now. In order to use the Episode One tools follow these steps.
  1. Add -engine ep1 to the Source SDK launch options.
  2. Launch Source SDK and Reset Game Configuration
  3. Launch Hammer, it should work now. You may want to change the compile executables under Tools->Options to the Ep1 tools, in order to successfully compile.
Warning.png Warning: Sadly, a note was earlier made to asking you to delete the SourceSDK_Content folder. Do NOT do this, you'll lose your custom maps, which I'm sure many people will regret! In case you already have done this, go to your recycling bin and hope your files are there. Otherwise, decompiling your files would be recommended.
  • A few issues were fixed in the Nov. 8th update. If any issues are still present and only lies within the Nov. 7th section, please move them to the newest section.
  • This page has been cleared to accept new reports for the November 2007 release of the SDK. For older bug reports, see August 2006 Community Buglist.

SE2, Source SDK Update Nov 14th


  • Overlays: Hammer does not appear to handle copy/pasting of overlays between maps (or as part of prefabs) very well. When making a prefab out of the big button in Portal's testchamber 5, the 4 edge overlays became unrotated (and one was reported in as "info_overlay does not recognize the keyvalue:angles" or whatnot when doing "Check map for problems."). Furthermore, when inserting the newly created prefab into a map (after fixing the overlays), the overlays did not show. --Dewin 11:51, 31 Dec 2007 (PST)
Try re-selecting the brush faces in the overlay properties. That should fix the "overlays did not show" problem, especially for cut/paste/prefabs (as the brush faces get new id numbers when you make copies of them). Also, just re-rotate the overlays and ignore the "does not recognise keyvalue: angles" problem in the "Check For Problems" box. --Darthkillyou 12:37, 31 Dec 2007 (PST)
That is a workaround, but still a bug nonetheless, and not really acceptable when I'm trying to produce a set of community-usable Portal prefabs that are implemented as cleanly as possible and "Just Work" (unlike other prefab sets I've found...). Also seems to be related to Bug #18 --Dewin 14:00, 1 Jan 2008 (PST)
Bug 18 is for rotating brushes. This is about prefabs, right? Anyway, the thing is, whenever you create a new version of a brush in any way, (for example, making a prefab or cut/paste) each new brush face gets assigned a new ID number that is different from the original face ID. However, the information in the copied overlay entity is kept the same, and so it will still refer to the old brush face ID. Therefore, the new ID and the ID that the overlay uses won't match. Maybe you could inform people about this problem if you post up the prefab somewhere. --Darthkillyou 19:00, 2 Jan 2008 (PST)
It's about brushes with overlays being used in prefabs. Bug #18 also involves operations on brushes with overlays (a copy/paste and rotation not being followed, for instance.). --Dewin 13:20, 3 Jan 2008 (PST)

Hammer frequently crashes for me when alt-tabbing between Portal and Hammer directly. (Observed on Windows XP Professional & DX9). My guess is that it involves a DirectX9-related race condition, since if I minimize Hammer before switching into Portal and when alt-tabbing out switch to another program first, Hammer does not crash. --Dewin 11:51, 31 Dec 2007 (PST)

My advice: don't use alt-tab or minimize hammer unless you have a really good, super-fast computer (or at least a better one than the thing I'm using right now.) --Darthkillyou 12:37, 31 Dec 2007 (PST)
Minimizing Hammer (and making sure I alt-tab back into another program and THEN hammer) is the one thing that actually avoids the crash. And it is a fairly superfast computer, just recently upgraded -- Core2 Duo E6750 processor for starters ;). I'm going to try configuring Portal to run in non-full-screen mode, as I think that's part of the issue. My theory is that since Portal is running fullscreen it has exclusive access to (some) DirectX calls, and Hammer sometimes tries to resume its normal operations before Portal starts playing nice hence the crash. Windowed Portal would stop that, if that is the case. --Dewin 14:00, 1 Jan 2008 (PST)
Haha, funny thing is, most software that VALVe makes loves to go "ka-screwedupinsomeway" on me, mostly while alt-tabbing. No matter the computer. --Darthkillyou 19:00, 2 Jan 2008 (PST)
Running Portal in Windowed mode does seem to make Hammer more stable, but not 100% --Dewin 13:20, 3 Jan 2008 (PST)


  • Whenever I try to do anything with Counter-Strike: Source as the active game in the Source SDK (ex. create a brush, create an entity), it simply crashes. This does not happen for v.EP2 games. Any ideas? --Baliame (talk) 04:00, 22 Dec 2007 (PST)
Tried Verifying Sauce SDK's cache? Tried deleting the bin folder, and refreshing it's content? --Frostbite 08:25, 22 Dec 2007 (PST)

Hammer's Hammered Again

I opened up Hammer today to find that the ability to make Portal maps had been added (yay!). HOWEVER, when I set the "current game" to "Half-Life 2 Episode 2" (the only other option), I found that I could no longer open (small) HL2:EP2 maps that I had been working on with no issues literally the day before. Hammer opens the map momentarily, and then the whole program crashes. If I set the "current game" to Portal, I can make Portal maps (yay 2!), and if I start a NEW map for HL2:EP2 it will open and close with no problems. But it seems Hammer has, in effect, thrown away all my previous work. It won't even open very simple test maps that I made with only a few objects in them without going down. Urgh!

Sometimes I think that Hammer was the inspiration for GlaDOS. The cake isn't a lie. It's just awfully hard to get to, and if you do find it, it's liable to include some odd ingredients.

I have refreshed the SDK content, reset the settings, and played all available games before starting Hammer, to no avail.

By the way, the Portal maps have a critical fault as well: YOU are the only thing that can go through a portal. You can't shoot through them, as you can in Portal itself (the rocket turret), and you can't throw or drop things through them. Bummer. I was looking forward to putting a few zombies into looping flights and listening to them scream.

Any ideas? sagesource, 15:40, January 7 2008.

I'm having a similar issue with Hammer crashing immediately on load of any saved map, but for me I'm crashing when opening Portal maps. Same troubleshooting methods to no avail: I've refreshed SDK content, reset the settings, launched Portal, even fully removed/reinstalled the SDK. Even a very simple map causes a crash (by simple I'm talking about 8 brushes w/ dev textures and 6 entities as it was a quick test to see what the engine would do in a given set of circumstances.) --Dewin 18:56, 7 Jan 2008 (PST) UPDATE: It seems to be an issue with the tools textures, for me at least. Applying tools/toolsnodraw to any surface with Hammer set to render nodraw textures = instant crash. And all levels make judicious use of nodraw. --Dewin 20:53, 7 Jan 2008 (PST)

Thanks. That makes sense. I opened up the super-simple map I had created in HL2:EP2 after these crashes began and tried to add a brush textured in nodraw. Hammer crashed instantly. I re-opened it and tried to add a brush textured in a Trigger texture. Hammer didn't crash at once, but did go down when I tried to re-center the 3D window on the new brush. sagesource, 21:51, 7 Jan 2008 (PST).

See also: Bug #203--Dewin 20:56, 7 Jan 2008 (PST)

SE2, Nov 8th Update

Work Arounds

Any work arounds to fix issues with the SE2 Nov 8th release of the SDK should be added to this section. Bug reports should be added to the report section.

Running the game after compile

You may encounter an error mentioning filesystem_steam.dll when trying to run your map with Episode 1 after a compile. The solution is quite common: Start Episode 1 in the normal way, exit again, and the error should be gone. --Andreasen 11:47, 18 Nov 2007 (PST)

Mod Enabling Workaround via Fake Search Paths

Note.png Note: After the Episode One tools works again, you don't need this method. Advanced users may use this workaround if they know what's going on, and can decide if they need it or not. Standard users should just use the Episode One tools by adding -engine ep1</code to the SDK Launch options.
Note.png Note: This is MOD-Only, however the same methods can easily be used for the games, see the Discussion/Helpdesk below for quickly written instructions. If you have no idea what's happening here and can't get it working, please use any other workaround instead. Or ask for better instructions, please.

Many crashes with Mods and Episode Two hammer is related to hammer requires mounted content from the Episode Two GCF'S ( Game Cache File ).

If you're making a mod, you can create a fake gameinfo.txt for use within Hammer. You can't do this with the normal gameinfo.txt because Episode Two doesn't support custom client.dll and server.dll binaries yet.

Follow the below steps to stabilize Hammer when working on Mods.

  1. If you haven't Reset Game Configuration yet, you must do it now in order to ensure things are like they should be.
  2. Launch Hammer in a working version, not using the Ep1 launch option. Episode Two should be working.
  3. In Hammer, go to Tools -> Options.
  4. Select [Your Modname here] as Configuration under Game Configuration under Options.
  5. Near the button, change Game Directory from
 $SteamDir\SteamApps\SourceMods\[Your Mod Folder Here]\
 $SteamDir\SteamApps\SourceMods\[Your Mod Folder Here]\SDK2007
  1. Open your Mod Folder and create a new subfolder named SDK2007.
  2. Insert a copy of your normal gameinfo.txt, located within [Steam]/SteamApps/SourceMods/[Mod Folder Name]/ and copy it into the new SDK2007 folder.
  3. Open the gameinfo.txt within SDK2007 and alter SteamAppId to SteamAppId 420 in order to use Ep2 content for hammer.
  4. Most importantly change |gameinfo_path|. to "..\..\..\..\SourceMods\[Your Mod Folder Name Here]"
  5. Ensure you did the above correctly, otherwise you can't use custom content.
  6. This search path is based relatively to the Orange Box Bin folder within sourcesdk/bin/. You can't use |gameinfo_path|. because it points to the folder which this fake gameinfo.txt lies within, and thus contains no data. Neither is .. possible since Source prevents escaping the root folder using ...
  7. Lastly launch hammer, with your set as Current Game in Source SDK Launcher, Hammer will now load the fake gameinfo.txt and work, and your Steam Client/Your Mod should use the correct one.
  8. This workaround should enable the Hammer VGUI Model Viewer, the 3D views and the 2D views and all the new Ep2 features (Hammer Only) without your mod being ported to Episode Two at all.
Note.png Note: Compiling is only possible via the Episode Two tools. These tools seem to be unable to compile Static Props in VRAD without it crashes when you load the game in Episode Two. See a below report for more information.

(Written by Sortie 08:46, 8 Nov 2007 (PST), updated by Sortie 07:33, 12 Nov 2007 (PST))

Work Around Dicussion/Helpdesk

The first step mentions getting into a working state of Ep2 Hammer, but doesn't seem to give much indication on how to do this. I've tried the mentioned Reset Game Configurations and Refresh SDK Content, but running Source SDK from Steam without '-engine ep1' has very little happen. The app appears to start then immediately exit. 12:28, 9 Nov 2007 (PST)

Hi, I updated the work around so it is more clear. Please reread it, and ask if you need any help or information about the behavior of the Work Around. Sortie 07:33, 12 Nov 2007 (PST)

Same problem I'm afraid - there must be something else I need to do inbetween your steps 1 and 2. In order to 'Reset Game Configurations' I need to run Source SDK in ep1 mode, because the SDK window does not appear at all if I run it without. Any ideas? 09:39, 12 Nov 2007 (PST)

You can't use Episode One Engine SDK, as I said in the instructions, back up your Source SDK folder, then rename it, and try launch Source SDK again, then you should get a fresh start. If nothing still happens, you got quite some bug beyond my powers. If so, say it here, and try Steam Support. Sortie 10:21, 12 Nov 2007 (PST)

This is way above my head. Even the paths don't match to anything like mine. I don't have a [Mod Folder] within SourceMods. My own folder is in a different place. Is it possible to link to some screens of what I have so I may get some help. I don't really like messing around with folders that were done automatically when I installed HL2. Is there another workaround or an update that will stop all of this nonsense? I am beginning to lose my rag with Steam or Valve (whoever caused this problem) and may just throw the lot away if they can't solve the problem that they have caused. Tonester 21:13, 12 Nov 2007 (GMT)

Hey Tonester, I suppose you're not making a mod at all, [Mod Folder] refers to whatever your mods folder is called, if you're making one. If you're not, here's quick how to do with with the game. Instead of using Steam/SteamApps/SourceMods/[Mod Folder], use Steam/SteamApps/[Your Account Name Here]/[The Game You Want To Edit]/[Short Name Of That Game. Eg. Hl2, Episodic, Ep2, etc. ]/. An example would be Steam\SteamApps\sortie\counter-strike source\cstrike in my case.

I hope that helped. :D Sortie 13:43, 12 Nov 2007 (PST)

World Model crashes Hammer

  • Caused by Reference memory failure with the model viewer.
  • Go to Edit->Options->General and untick "Use VGUI model browser" Solokiller 11:31, 10 Nov 2007 (PST)
    • That is a good (albeit slow) work around, however, has anyone come across a fix yet? There is mention of two potential fixes above, but if neither are working, then what? --Dave M 12:17, 10 Nov 2007 (PST)
    • How has this helped? I can't do a browser search. I have to look in each folder to look for a model. Why do Valve release bug ridden updates? Nov 7th, I was happily working on a map. Nov 8th, updated Hammer and now it doesn't work properly! Is there a way of reversing updates? Tonester 13:49, 11 Nov 2007 (GMT)
    • It don't crash, that's a help. The crash is caused by hammer trying to read unmounted data. Use the search path work around, for mods if you really want the VGUI browser.Sortie 07:33, 12 Nov 2007 (PST)
  • Problem fixed in the 11/14 update. Mdurand 14:00, 14 Nov 2007 (PST)
  • Problem does not appear to be actually fixed, in spite of patch notes. Still crashes when I launch VGUI model browser in Ep1 Hammer. --Randy Wallace 06:04, 16 Nov 2007 (PST)
  • Try Reset Game Configuration after each updated release. It works for me now, at least in connection with the Search Path Work Around described above. --Sortie 15:13, 16 Nov 2007 (PST)
  • Anyone got a solution of this problem, I'm going to commit suicide if I still have no solution :P


Any issues with the SE2 release of the SDK should be addressed here. If there's a working work around, add it to the work around section.

Critical Engine Faults

Missing Episode One support for Episode Two maps ( Static Props Skin Related Crash )

Episode One mods crash if they launch a map compiled by the Episode Two compile tools. Every time it tries to read the very same memory at 0x0e3ca1a0. Many experiments have showed it's related to Static Props, and further has shown the following criteria for the crashes:

  • If only VBSP is run, then crash.
  • If VBSP and VVIS is run, then it works.
  • If VSP, VVIS and VRAD is run then:
    • If the level contains Static Props, the level crashes if:
      • If certain props are in the level, tests has shown that multiskinned props (e.g. pipes) crash the game.
    • Any other models have lighting problems, tests has shown that props facing certain angles are lit wrongly.
    • Cubemaps can't be built in an Ep2 compiled map, without the game crashes with a message about some BSP Lump that couldn't be read.

Written by Sortie 07:33, 12 Nov 2007 (PST)

You can't play the maps because they are newer versions, containing newer info than the episode 1 engine supports. Solokiller 05:57, 11 Nov 2007 (PST)
Yes I can! Everything works but static props crash the game, and other props are lit wrong, and cubemaps.
We (Valve) are not going to make this work. That's why we distributed the Ep1 version of the tools. Mdurand 15:37, 14 Nov 2007 (PST)
Hi Mike, the main problem is that The Episode One compile tools doesn't work at all. VBSP claims to be lacking either MaterialSystem.dll or SteamFileSystem.dll and the others does complain similarly. The Episode One hammer is now pretty unstable last time I tried, and thus leaves me to use the Episode Two tools. The episode two tools leads me to this same Static Prop related bug.
That's pretty annoying for me trying to get a release out soon, when I'm unable to playtest the maps. It seems like you know what's causing this bug, or am I wrong?
I suggest making a beta of the SDK next time, if that's possible. :P Sortie 04:24, 15 Nov 2007 (PST)
The ep1 tools work fine for me. Jupix 04:47, 15 Nov 2007 (PST)
Oh you're right, they got working in the newest SDK update. But I still have some problems with the compile tools, but that's probably me messing around with the SDK binaries! I just reset my game configuration, so let's see if Ep1 compile tools works now, both outside the game, and in-game. :D --Sortie 08:59, 15 Nov 2007 (PST)
Great! I got compiling working with the old tools, while I suddenly notice they're also compiled at Nov 8. Hehe. Anyways, this is great, I got the model lighting bug away, and now I'm going to test the static props. Props to you Mike and your team at Valve! :D --Sortie 09:28, 15 Nov 2007 (PST)
Good to hear you got it working. I had to point the compile tools' locations in the gameconfig to the /bin/ep1/bin directory to get maps in my mod to compile. I assume you had the same problem. Anyway, the reason I posted; please use indentations on talk pages, it makes posts less of a headache to read... thanks! Jupix 11:54, 15 Nov 2007 (PST)

Compile Tools

VRAD crash

Since even the ep1 SE1, VRAD constantly crashes, and this is also very random. It doesn't matter what the map contains, as it even crashes on a simple square room. This also happens randomly at times, where sometimes it crashes in the LDR stage, but mainly it crashes in the HDR stage most of the time.--Gear 06:53, 9 Nov 2007 (PST) It has always done that, I got Visual Studio, so I get an error about an Unhandled Exception. If you get the same as I, please ignore the crash message, VRAD is still running and you just need to wait for it to finish, before you press OK. Sortie 07:04, 12 Nov 2007 (PST)

Well you ruined that, was hoping they would fix it.--Gear 01:54, 4 Jan 2008 (PST)


This error comes up when trying to compile Ep1 models with the new Ep1 studiomdl.exe application. Same SMDs, Batch files, and .QC files worked fine before the update but now the compile makes it past the collision model line and then gives the above error message. The compile actually does generate a .MDL file but it seems to be corrupted as it causes both Model Viewer and Hammer to crash when it is loaded. A solution, work-around, or fix is desperately needed for this reoccurring error. Nov. 12th, 2007 benmears

I also have noticed this issue. It will build a physics model, claim to build the reference model and then throw the exception. The reference model it leaves is just an empty file. --TheDistur 11:17, 13 Nov 2007 (PST)


Any Hammer related bugs should be posted here.

Missing Rotate Cursor

  • The rotate cursor is missing when the mouse is above one of the rotate vertices when rotating a brush in the 2D view. Sortie 09:15, 8 Nov 2007 (PST)

Missing Zoom Cursor

Like the above error, but only the zoom cursor disappears. Solokiller 09:58, 9 Nov 2007 (PST)

Low Resolution Textures in 3D views

For some reason Hammer draws all things, including entity's, at a very low texture setting. As if it was a game and the settings had texture resolution set to very, very low.--Gear 14:31, 7 Nov 2007 (PST)

Yeah, I have the same problem. It seems linked to the problem of the resetting of the Very High texture setting to low, in all Source 2007 games. It's really annoying, and it seems like I can't find any fix within the Windows Registry. Going to look at some launch options right now and see if there's any fixes there. I imagine something like -DXLevel 81 should make an impact. Sortie 08:46, 8 Nov 2007 (PST)

Yeah it is horrible, mainly when it comes to sizing textures and aligning them correctly.--Gear 12:30, 8 Nov 2007 (PST)

Well, aligning is piece of cake, just remember to use the Left, Right, Top, Bottom, Center, Fit tools. Well that was a lie. :P. Sizing is another problem that always has been within the SDK, better support for scales with more than two decimals, which is, really really useful within the 3D skybox. Uh, and try to keep the === subcatagories, so we can arrange this article before it goes crazy. Uh, and if any Valve guys read this, mind to increase the Overlay limit? I'm running a little low here. ;-) Sortie 12:42, 8 Nov 2007 (PST)

Overlay limit FTL, we need a better one.--Gear 12:46, 8 Nov 2007 (PST)

3D Shaded Texture Polygons bug

  • When 3d Shaded Textured Polygons is selected, all textures are rendered fullbright except for textures which are solid colour, e.g. all the white texture lights and the orange glow from Portal. Only these textures are shaded. Got Lag? 19:58, 7 Nov 2007 (PST)

Custom Hammer compile profiles not saved

Custom compile profiles aren't stored. They can be used during the session you created them in, but when you next load Hammer you'll need to enter everything all over again! --TomEdwards 04:05, 10 Nov 2007 (PST)

Workaround: Use Batch compiles, if you do Hammer wont eat up memory that actually could speed up VRAD. Oh, I forgot to sign this, and I also got this bug too in 'Expert' mode. Luckily we got batch compilers, <3 Sortie 15:17, 16 Nov 2007 (PST)

Textures Not Supported in 3D View, even with Textures Selected

Ok, after the Nov. 8th update I decided to remove the "-engine ep1" command from the launch options. It appears it was a bad idea. A little while after I did this I had compiling issues where it said I had a leak (still not fixed) and when the textures would not show in the 3D view. I put the "engine ep1" command back in and my textures were restored. I thought the Nov. 8th update fixed this issue?--MrQ 17:12, 16 Nov 2007 (PST)

The leak message is probably your fault. Use the Map->Load Pointfile to see what's casuing the leak. --Sortie 05:34, 17 Nov 2007 (PST)

Ok thanks, but still the issue with the textures not supported without the workaround? I forgot to mention it was Day of Defeat Source. This is kinda frustrating. I also tried using the pointfile and it points to outside the skybox. Whats with that? And then when I completely cover the outside of the box with nodraw it still says **leaked** but now no coordinates.--MrQ 06:48, 19 Nov 2007 (PST)

Any lacking textures comes is caused by hammer not loading them. Please ensure that you really are running DoD:S inside Source SDK Launcher, otherwise try to Reset Game Configuration to ensure everything is like it should be. If you still have problems with the textures, please try to run DoD:S and then ensure the game configuration points to the correct gameinfo.txt.

As for the leak, a leak occurs when VBSP can find a way from an entity to the void. If you placed any entities outside the map, simple delete/move them. The pointfile will create a red line from the entity to the void, if there's nothing at the end, you probably followed it the wrong way. Follow it the other way and see if you find an entity outside the map, or finds a hole in the game geometry. I recommend using the auto visgroups to disable: Func_Details, displacements, props, brush entities and similear nonsolid objects, then try to repeat the above. When you're done you can simply turn them on again. --Sortie 10:09, 19 Nov 2007 (PST)

Ok sortie I got you to point, but I have been working here for a while on this and I have already tried removing the entities. Still no luck. I don't know whether the answer is right in front of my eyes or what. Would it be better if I sent you the .vmf to look at if you have time? I dunno what the deal would be but I know something is screwed up.--MrQ 14:01, 19 Nov 2007 (PST)

Feel free to upload the file to a source, or email me it at SourceSDK [ at] --Sortie 14:50, 22 Nov 2007 (PST)

Hammer VGUI Model Viewer crashes Hammer

Please see the workaround section for a workaround to disable the new VGUI model viewer.

Whenever I do a fresh reinstall of the SDK, this problem happens. It goes away as long as I've used the old folder view at least once, and then the new GUI starts working. --Spektre1 21:58, 7 Jan 2008 (PST)

Tie To Entity Info Lost

If you are having this problem, then you probably don't know enough about the Group, Object, Solid tool. Please check that you haven't selected Solid by accident, if you have, switch back to either Group or Object. In the case this is a real bug, please add more in-depth information about it below.

  • After tying an entity to a brush, when you click off of the brush then back onto it, you lose the entity properties box. It still shows any I/O used at the bottom. But it only shows up as the VisGroup view box. --Third Eye 14:13, 10 Nov 2007 (PST)
  • Edit: This problem seems to have gone away after closing and opening Hammer --Third Eye 15:50, 10 Nov 2007 (PST)
  • This randomly occurs to me. The reason is that the select mode randomly gets changed to solids and if you tie to entity it works, but you cant exit and then double click again to change it again because it reads it as a brush again. To fix: change the select mode back to groups. --PortalsApprentice 17:28, 10 Nov 2007 (PST)

Light Preview Issues

  • My 3D light preview makes things black, #d raycast seems to freeze hammer and has the same effect as 3d light preview. My cpu is barely doing anything. --Bluestrike 14:03, 7 Nov 2007 (PST)
Note.png Note: The 3D Light Preview is only experimental and isn't release publicly. This will be addressed in the next SDK release.

Hammer Crash on map load

I still not able to work on Hammer, when I use File -> New File -> Load, Hammer freeze when viewport come in and I have to kill it in process. I have reset game config and source sdk content.

Cause : Light preview was keep when I closed Hammer before SE2, Why refresh sdk haven't reset viewport configuration?

Question: Hammer crash shouldn't make a mdmp file?

--Gectou4 11:28, 15 Nov 2007 (PST)

Hammer performance is very choppy/frozen

When navigating in the 3D viewer, or even when scrolling the 2D views, the movement is very jerky, sometimes pausing for several seconds and "freezing" momentarily when I exit 3D mouselook or finish scrolling in 2D. This seems to coincide with heavy disk access; the hard drive lights up solidly whenever either 3D or 2D movement takes place, even in extremely simple (box) test maps. It doesn't seem to be swapping; I have more than 1G free memory and Orange Box games play fine with minimal or no stuttering. It happens regardless of the 3D view type; even on wireframe or 2D top/side/front. By the way, I also seem to have the low-res textures issue, and "3d shaded textured polygons" mode looks identical to plain "textured" mode. Between these 3 bugs Hammer is essentially unusable. All of this is new behavior that did not appear in the Episode 1 version of the SDK. -- Plasmadyne 13:00, 21 Nov 2007 (PST)

Pretty odd. Try update your drives, run the Episode One version of the tools to see if there's an improvement and post the result here. --Sortie 14:50, 22 Nov 2007 (PST)

Map Run Issue

Cooldude: While I was trying to run my map, I get this Launcher Error saying : Failed to load the launcher DLL:

The specified module could not be found.

Thats an Issue with the Game itself and not Hammer, however, I'll see if i can find the reason to why its happening for you.--Gear 21:53, 23 Jan 2008 (PST)

Level Design FAQ Found some stuff.--Gear 21:56, 23 Jan 2008 (PST)

SE2 Update Nov 7th

Note.png Note: This section may not be completely updated anymore. Please discard any information from below if mentioned otherwise above.

Work Arounds

Any work arounds to fix issues with the SE2 Nov 7th release of the SDK should be added to this section. Bug reports should be added to the report section.


Any issues with the SE2 release of the SDK should be addressed here. If there's a working work around, add it to the work around section.

Hammer Material Browser

I just started getting this one. Clicking "Browse..." causes Hammer to lock up, and become unresponsive to any input. I have to kill it with Task Manager. --Spektre1 00:38, 9 Nov 2007 (PST)

I'm not having this bug myself, everything seems so far to be working as it did yesterday. Sortie 06:48, 9 Nov 2007 (PST)

I ended up "fixing" this one by reinstalling Windows. Very depressing. --Spektre1 22:00, 7 Jan 2008 (PST)

Hammer VGUI Model Browser

  • Hammer crashes when entering the Model browser, after the Episode 2 SDK update. Solokiller 13:18, 7 Nov 2007 (PST)
Fix: Extract Advisor.jpg from Source Models.gcf (it's under hl2/models) and

place it in "Half-Life 2 Episode Two/ep2/models"

  • And that should fix the crashing with hlmv. --Frostbite 14:27, 7 Nov 2007 (PST)

Note: This and other errors are caused by hammer requiring content from the Episode Two GCF's. Use the searchpath workaround to mount this content.

  • Attempted the searchpath workaround from above, but kept getting the crash error. What is the path to the models folder? Is it "Program Files\Steam\steamapps\username\half-life 2 episode two\ep2\models"? IF it is, it didn't exist on two machines, and the fix suggested with the Advisor.jpg didn't work by adding in the \models folder. --Dave M 00:34, 9 Nov 2007 (PST)
  • I tried creating the model path given just above from scratch, with the "Advisor.jpg" in the suggested folder at the end, and it didn't do a bit of good. My VGUI Model Browser has been totally fried since the update. It brings Hammer down every time I try to use it. sagesource, 01:59, 11 Nov 2007 (PST)
  • Under CS:S ep1 engine I can't use any models/textures. Everything is generic gray and models are ERROR. How do you extract Advisor.jpg? Thanks. Stormfury 13:02, 9 Nov 2007 (PST)
  • On a fresh install on a new computer, using the ep1 tag for SourceSDK still results in the Memory could not be written error when trying to open the model viewer in Hammer. Dave M 12:06, 29 Nov 2007 (PST)

Fixed issues

Model Viewer


  • When opening the Model Viewer with my custom mod configuration for the Source SDK, the program doesn't load up the model browser when clicking on File - Load Model.... There was no error report generated. --Jurgen Knops 06:41, 8 Nov 2007 (PST)
  • Within the new update (8 Nov) the Model Viewer works correct. But it fails with opening the model browser window when the Episode Two SDK configuration is applied: The instruction at 0xxx3f018b referenced memory at 0x903f4009. The memory could not be "written". When re-opening the Model Viewer via the SDK window the SDK generates a fatal error: EnumerateApp( 211 ) failed: SteamEnummetaApp(211,0x1287fd34,0x1287fd78) failed with error 1: The registry is in use by another process, timeout expired. When closing the error window, and re-opening the Model Viewer again, it fails with the same error. When opening Hammer and the closing it directly when it's opened, I'd re-opened the Model Viewer again. Now it's opening normal, but fails again with the first error: Memory could not be written.
    Note.png Note: Opening models from the File - Recent Models menu the Model Viewer works correctly without errors when opening them. Also: the errors above occurs only within the SDK's Episode Two configuration. The Team Fortress 2 and Portal configurations work fine.
    --Jurgen Knops 06:43, 9 Nov 2007 (PST)
  • I am able to duplicate this issue and will investigate. Also added it to known issues in release notes. Mdurand 15:40. 14 Nov 2007 (PST)
  • The last update (14 Nov) probably fixes the issue when re-opening the Model Viewer after it crashes with the memory could not be "written" error. (See striked-out section above for details) --Jurgen Knops 08:14, 16 Nov 2007 (PST)


Episode One SDK Issues

  • Now it is different. I get no errors in the orangebox but my map 3d view has infinite lines, and the 2d views as well. I am missing all materials. In the Ep1 version i have no materials either. All models are lines stretching to the origin. This is not fixed for me yet. -Raider666
    • Raider666 i am pretty sure that is an Nov. 8 Update error.Stalker 13:02, 15 Nov 2007 (PST)
  • Valve/Steam seem to have solved this issue although others have taken it's place, remove the <-s>Strikeout<-/s> if the error is persistent for you.
  • I'm getting a "Missing material 'editor/flatnocull'" error. It only happens when I insert a custom mod into the gameconfig.txt. I'm wondering if all my paths are correct. Gonna check and report back if I can fix it.--Spektre1 13:14, 7 Nov 2007 (PST)
    • I'm also getting "Can't load FileSystemOpenDialog.dll" when Hammer first opens, when running a custom mod. --Spektre1 13:21, 7 Nov 2007 (PST)
    • Definitely seems to be an issue with the ep2 Hammer. If I switch over to Ep1, it runs everything fine. We're gonna need a list of what changes are necessary to upgrade our content and mod to Ep2. I'd want to do that if for nothing else than the new hammer stuff like turning off Nodraw faces. I LOVE that feature. --Spektre1 15:27, 7 Nov 2007 (PST)
    • I get the same "Missing material 'editor/flatnocull'" for custom mods, maybe we are suposed to use Ep1 until mods also got updated? --Bluestrike 14:03, 7 Nov 2007 (PST)
    • I don't think it's just with the mod's when i try and open hammer it give me that same "Can't load FileSystemOpenDialog.dll" but when i ignore it and continue i get the "Missing material 'editor/flatnocull'" error, and the hammer flashes that like 7 times and then freezes and shuts down. Whatever the problem Valve/Steam needs to fix it soon. I am in the middle of making a map.--Stalker 19:26, 7 Nov 2007 (PST)--
      • Exact same problem here. Adding -engine ep1 to the launch options seems to have fixed both errors.A newbie
    • I am having even stranger issues. When I open hammer in orangebox i get the usual "Can't load FileSystemOpenDialog.dll" error, but if I switch over to the episode one, all of my materials in my map are gone and the models render as weird infinite lines in the 3D view. The map doesn't even open in the orangebox side. I don't know what valve did but this is really frustrating. I am in the middle of a map as well. -Raider666
      • Well hi. The Episode One version doesn't work at all as you pointed out. In order to fix the Episode Two hammer, click the Reset Game Configuration in Source SDK Launcher. Then it should work, eventually try my work above above.
    • Fatal error.JPG
    • Can\'tLoad.JPG

Hammer Object Selection Crash

  • When objects are selected in hammer or created, on either the 2D screen or the 3D screen. Hammer freezes and crashes although that may be in part to a missing FGD file that still would not explain why objects that have no entities freeze as well. A work around or Fix would be nice soon. --Stalker 21:11, 10 Nov 2007 (PST)
    • Please, are you using the crashy and buggy Episode One hammer? The Episode Two hammer should be working well, are your FGD's fucked up? Sortie 07:33, 12 Nov 2007 (PST)
      • ha haa >.<* FGD away. i forgot they were deleted somehow ?? and yes the ep1 engine works fine for me.<(s>

This isn't a bug it seems, please consider removing this if it's unlikely anybody else would reproduce this fault. --Sortie 05:44, 16 Nov 2007 (PST)

Missing support for Ep1 Compile Tools

  • Seems as I can't use the Episode One compile tools while running the Episode Two hammer (which is the only one who actually works good), vbsp can't load MaterialSystem.dll
 Valve Software - vbsp.exe (Dec 11 2006)
 1 threads
 Can't load MaterialSystem.dll
  • As I said above, I need to use the Episode One compile tools in order to play the maps within the game, so a quick fix/work around for this would be pretty appreciated. Sortie 13:00, 8 Nov 2007 (PST)

Fixed in Source SDK Nov 14 Update.


  • Point_spotlight model is "ERROR" in Portal (not tested in any other games). --Baliame 14:23, 7 Nov 2007 (PST)
    • It does this for all Source Games :( --Frostbite 14:28, 7 Nov 2007 (PST)
      • This bug has been fixed in The Orange games, but the new point_spotlight model has no texture in the old games. --Spirit55555 08:04, 12 Nov 2007 (PST)

Texture Keywords Lockup

  • Hammer seems to lock up for me after I enter a keyword in the texture browser (filter works fine). Bug? --Baliame 13:20, 7 Nov 2007 (PST)
    • It's always done this. Leave it for long enough and it'll complete the operation, and be instant next time you try. --TomEdwards 07:53, 8 Nov 2007 (PST)

See also