Source SDK Bugs

From Valve Developer Community
Jump to: navigation, search

For basic information and installation of the Source SDK Beta, read this page first!

See SDK Beta Changelist for a current list of changes and known issues.

To report bugs happening in-game, see Source Bug Reports.

Note:Be sure to run the game you wish to edit before running the SDK, to make sure you have the latest updates.


SDK General Issues/Bugs

Issues with the Source SDK launcher or items that don't fit under other categories.

  • Day of Defeat Source: When using custom objective icons for the new "objective mode," the white icon causes most players to crash out of the server. Tested bug by extracting official icons, renaming them and adding them as "custom" icons. They still crashed the game!
  • If you are receiving the "Unable to load C:\<SteamFolder>\counter-strike source\bin\filesystem_steam.dll" run the game you are trying to play so its content can be refreshed. This will normally fix the problem.--Skidz 15:57, 23 Nov 2005 (PST)
  • Since the beta started, Steam forgets the last tab I had open on the main screen, and defaults to Store.
  • If Source can't find the textures used in a map, it will apparently halt the loading and display a dialog box. The only trouble is that it doesn't switch out of the HL2 loading screen, and you can't Alt+Tab out either, so all you hear is an error sound and the loading freezes, and if you don't press Return then, trying to Alt+Tab, it will look like your entire computer has frozen. I think it's the textures, but it might be the example itself. ( http://twhl.co.za/mapvault_map.php?id=1857 ) The error went away when I fixed the textures. Still, it would be nice to at least be able to Alt+Tab at the loading screen, or have the program do that automatically if it creates some kind of error dialog box. --Andreasen 19:11, 31 Jan 2006 (PST)
I have been receiving more of these errors, and can now say that they are indeed texture related. Textures that may start causing this bug are "lights/white", "lights/white001", but not "lights/white001_nochop", so that "_nochop" might be a key to understanding what causes this bug. I've caught a few glimpses of the dialog box as HL2 closes, and it says something about "memory cannot be "read".", which I believe is a common error today. Once these errors start to occur, they will continue to occur until you use other textures, and restarting Steam will not help. --Andreasen 17:37, 8 Feb 2006 (PST)
  • I don't know if it's a bug or the expected behavior, but I've noticed that if you compile your code in "Debug HL2" mode instead of "Release HL2", HDR won't work. -uoz 07:53, 16 Sep 2006 (PDT)
  • If you specify SteamAppID 215 in your gameinfo.txt file, and launch your mod from the Steam interface with -console and -novid options, they don't work anymore. You'll get the video and no console at startup. -uoz 07:53, 16 Sep 2006 (PDT)
    • I run into the same issue under Windows Vista, but also AppId 220 (HL2) does not work with this. -novideo has no effect at all. - Len 08:19, 22 May 2007 (PDT)

SDK Launcher doesn't launch

I am having a problem where the SDK launcher will not launch at all. Telling it to launch results in the computer thinking hard about it, it updating if it needs to, but eventually - when the computer is done chugging away and making noise - I still don't have the SDK launcher. I completely deleted the tool and had steam re-install it, but it's still doing this. Earlier, Hammer would freeze when as soon as I started to create a brush (dragging the rectangle for the size/location) in any 2D window. Now the SDK won't launch at all. I do not have Episode 1 or 2, so I can't imagine that changing the "-engine" should have an effect, right? Anybody have a suggestion? Hectate 13:58, 16 Nov 2007 (PST)

Same issue. Original HL2; 32-bit Windows XP; cache verified and all the files are in the right place; yet the command to launch the SDK simply does not execute. No additional tasks appear in the Windows Task Manager. Steam Support told me to take a hike. I posted the issue in greater detail on this article's discussion page. I hope this bug is fixed ASAP, since I need the SDK for professional reasons (Hammer makes a pretty good interactive design/architectural tool, and it's free with HL2, which I already have). --Terminator484 16:17, 12 Feb 2008 (PST)

Just call me stupid. I didn't realize that "ep1" was the engine that HL2, CSS, and etc. are all using right now. I figured that since I didn't have Episode 1 those fixes wouldn't apply to me. Don't mind me over here... Hectate 14:03, 16 Nov 2007 (PST)


No one seems to know what wrong with the SDK, At first I though the SDK required other games installed, I have gotten advice from Steam about the SDK, at first they told me to 'Go away', Then they gave me tutorial links, After I got a few solutions. I have tried EVERY solution that I can find with failure:

  1. Delete SDK folder under <userName>\ SDK....
  2. Delete ClientRegistry.blob, steamclient.dll, Steam.dll
  3. Remove and reinstall Source SDK and steam
  4. setting launch options as "-engine ep1"

I load the SDK through tools then acts if I click cancel SDK luancher loads in taskmanager then closes as if its been canceled There has been no solution to date, Although doubts if valve cares about this issue due to its rarity

I have HL2 DM, SDK Beta, SDK Base, SDK Base orange and dedicated server HL2 is pre-installed and CSS is partially install due to a 3 day trial that passed -digimbyte aka DIGI_Byte

The correct parameter is -engine ep1, with a dash at the front. You'd be better-off in general using the SDK Beta though.
"I have the ati steam offer version, never got the offer it seems to of been a lie"
You have the offer, but you never got the offer? --TomEdwards 03:37, 19 Mar 2008 (PDT)
Yes, It appears to have been just a marketing technique for more people to join Steam. --digimbyte aka DIGI_Byte 09:26, 20 Mar 2008 (PDT)
That is exactly what it is. The offer only gives you HL2DM and Lost Coast, and since you already owned them...anyway, it's not important. What is important is that you don't alter comments made by other people and avoid changing the meaning of your own when they aren't brand new. Since you removed my answer to your launch param issue, I'll assume that it worked. :-p --TomEdwards 17:11, 19 Mar 2008 (PDT)
Firstly I edited the posts before yours AND mine to clean up this section and to correct any information after I corrected my post your comment became redundent,I mean no disrespect but I hope you will be able to understand why I chose to edit these areas. BTW, I did not own any steam games previous to downloading the steam ATI offer, I was simply 'uming' and 'aring' to get steam beforehand and this offer was a nudge for me to get it, I searched to claim the free offer but couldn't find anything, Since I now had steam I went to download the SDK, I purchased HL2 DM for about $10 US dollars to get the SDK. How ever it has never been able to execute.--digimbyte aka DIGI_Byte 12:34, 21 Mar 2008 (PDT)

"Steam Validation Rejected"

Note:Please see Current Known Issues for a temporary workaround for this issue. --JeffLane 13:14, 11 Jan 2006 (PST)
  • Steam validation rejected error message when trying to launch maps from console in main menu, I think there was a betasdk update today causing this. [Bluestrike 24 dec]
    • I also have this error. I have tried 3 of my own mods and i couldn't make a server. The only mod i could make a server on was sourceforts, but i couldn't see any servers available to connect to. I also tried to go back to the non beta sdk and it didn't solve anything. Bob 14:28, 26 Dec 2005 (PST)
    • I have this error as well, only occurs on load of a map in any Steam run game. I moved the posted fix here to the point above as it was not a fix for this issue, but for the appID thing. Hopefully there is a fix for this soon as it's put a halt on any in-game testing.
    • That's weird my maps only crash if launched from hammer i get "Steam validation rejected" then it returns to console, type in map <mapname> and it loads. - Pir4t
    • I can confirm this, maps will not launch by either console or by creating a server. Despite suggestions of setting sv_lan to 1 and sv_secure to 0 neither work or are practical solutions. -Brisck1
    • I have this problem but only if I load the map directly from the SDK or if I type "map <mapname>" into console. When i create my own server it works though - GNXDan

SDK Launcher

  • Tools > Source SDK > Links > SoftImage|XSI Mod Tool.... link is broken!
    • This link leads to an error page. --Steamfraiser 12:53, 29 May 2006 (PDT)

http://www.softimage.com/products/Mod/v4/

  • Day of Defeat: Source game configuration lost when refreshing SDK content.
    • Is this solved with the latest DoD:S Update? If not, run DoD:S and then try again. --King2500 14:05, 22 Nov 2005 (PST)
  • No Configuration appears after running DoD:S.
    • This can be fixed by extracting a new GameInfo.txt from the DOD:S GCF file using nem's GCFScape tool. --Skidz 15:50, 23 Nov 2005 (PST)
      • You should never have to manually extract files to fix a problem. Simply clicking "Reset Game Configuration" should fix this issue. If it doesn't, make sure you're actually running the SDK Beta instead of the standard SDK. You can check this by running Hammer and choosing About from the help menu. The version should be "4.1 SDK", and "4.0" is the non-Beta SDK. --JeffLane 10:12, 31 Dec 2005 (PST)
  • When I try to open Hammer in the sdk launcher after downloading the beta It wont open and it tells me "The system cannot find the file specified" - X23
    • Please look above for a fix.
  • I get the 'copying files' dialog briefly every time I launch the SDK
Fixed with today's update. --David Speyrer 19:42, 16 Jan 2006 (PST)
  • It still uses the old Steam skin!
    • The Beta doesn't use the new Steam skin, maybe Valve will give the SDK the new skin but i think as long as the SDK works it isn't really necessary to have a new skin, indeed it's looking better with it.
  • delay in changing "current game" of 6 seconds
  • Clicking on close while copying source code will crash the launcher, but the copy will complete even once the launcher has been cleared from the application list in task manager
  • It is possible to launch the Source SDK several times. In addition you can start hammer several times too.
  • After launching beta SDK no game configurations appear at all. Refreshing Content and fall back to non-beta SDK doesn't work.
  • The SDK launcher/something has reset my GameConfig file at least 3 times in the past fortnight, by itself and without me asking it to. --Giles 03:08, 30 May 2006 (PDT)
  • Source SDK gets stuck in copying files, please wait.... , mail me an answer (dunanjay@gmail.com)
  • The SDK Launcher crashes when I try to launch it. -AnthonyCSS
^^^ Same issue here: SDK will not start at all. (details, under "More information"). --Terminator484 16:27, 12 Feb 2008 (PST)
  • GameConfig.txt is empty for engine's old versions, you have to manually edit it to make it work.

Hammer Editor

Main article: Source SDK Bugs/Hammer bugs

FacePoser

  • Options -> Make Screenshot fails to create a screenshot.
  • Options -> Background Color and Options -> Ground Color are non-functional
  • Popping sounds when playing .wav files in the Phoneme Editor. (Scrubbing through audio is painful on the ears.)
  • The gesture_updown and gesture_rightleft flexes appear to do nothing.
  • On Windows Vista the Phoneme Extractor always returns "Last Extraction Result: An Error occurred during extraction" (If anyone knows how to solve this problem please tell me)

-> This is happening for me too but I'm on xp... -> Happening on Win7 (mdipaola)

Model Viewer

  • The gesture_updown and gesture_rightleft flexes appear to do nothing.

On Windows Vista the Phoneme Extractor always returns "Last Extraction Result: An Error occurred during extraction" (If anyone knows how to solve this problem please tell me) -> This is happening for me too but I'm on xp...

Compile tools and other SDK tools

Put bugs with the compile tools (vbsp.exe, vvis.exe, vrad.exe, studiomdl.exe, bspzip.exe etc.) under here.

  • Possible bug which I can't recreate. Sometimes when I have a map compile launch the game after it's done, it instead launches a second copy of an application. I'll notice a second copy of FacePoser for example in my toolbar. I don't know for sure it's really doing this (maybe me half asleep), but it does seem to be occurring once in a while. Anyone else? --Holtt 01:50, 20 Jan 2006 (PST)
  • Hammer compiles Xbox map information. Why? How do we disable this?
Fixed by today's update.--David Speyrer 19:56, 16 Jan 2006 (PST)
  • vvis.exe doesn't run. Getting the Sorry for the inconvenience crash message
  • vrad.exe doesn't run. Getting the Sorry for the inconvenience crash message --Plaguebearer 13:47, 11 Sep 2006 (CST)
    • I've tried reinstalling steam from scratch, and reinstalled XP from scratch... no luck, still get the grey window of dooooom
  • vrad.exe crashes when I try to compile any map, on any platform (hl2, cs, hl2dm), even a hollow box with a info_player_start, and vrad.exe starts to complain about Kernel32.dll. I think it was an access violation or something like that. Running on Windows XP. If it helps tracking down the bug, I used to run SourceSDK/Source on last July´s updates until this year thanks to no access to internet. After updating the whole thing around this new year, vrad stopped working immediately.
  • vrad.exe crashes when I run it. I don't know if this is related to beta SDK or not, the map I ran it on is huge 30720 in. * 30720 in. * 20480 in. (x,y,z).
I ran vrad.exe on a smaller map 4097 in. 4097 in. 844 in. (x,y,z) and it ran perfectly (The smaller map is about 5x as complex then the bigger one).
  • The compile tools don't close when you stop the Hammer.exe process.
    • I don't think this is necessarily a bad thing. This way a crashed Hammer won't kill your map compile. Nailed 23:27, 22 Nov 2005 (PST)
  • All Expert Compile configurations are gone.
    • If you roll back from the beta they will get restored.
Workaround in Beta: Delete cmdseq.wc in sourcesdk/bin directory, then choose Refresh SDK Content to fix. See Known Issues. --JeffLane 15:33, 9 Jan 2006 (PST)
  • I have a large map with a lot of displacements, previous to the Beta SDK I managed to get my map to 16mb (down from 27Mb) by removing some, after the Beta SDK compile with no changes my Linux specific data is over 400% and my map is now 37Mb. Computer 3.2Ghz P4B, 200GB Sata, 1GB DDR-400, FX5900 128MB AGP, XP Pro SP2. Many thanks
    • If you are working on a singleplayer map then you can compile with -nolinuxdata. This stops the Compile tools from storing the needed data for Linux servers. Therefore if you are making a multiplayer map you cannot omit this data as then Linux servers will not be able to run your map correctly.
      • Sadly its a multiplayer map, I just thought something might be wrong as I hadn't changed the map between compiles of the old and beta Hammer and its gone up over 20Mb
        • Did you compile it with HDR support? That uses much dataspace. Right now only DoD:S and Lost Coast support HDR so for now you can deactivate the HDR option, if you activated it.
          • No it was a fast compile on VIS and RAD with no HDR option.
            • I took the map over to one of my other PC's with the custom dod FGD setup and ran the vmf and the map is 10MB big, I have put all the files here Non Beta Map, I have also put all the files from a compile on my main PC running the Beta SDK where the map is 37Mb, Beta Map, I've also put the compile txt files for the beta here and non beta here if there is anything else I can do just ask. James
  • Valve please contact me for the source to CST cstvis, I cant be assed at the moment supporting the tools any more, and would like to see my hard work put into the official stuff - amckern@yahoo.com +61 0417-650-440 (Mobile Phone only) --Amckern 16:28, 23 Nov 2005 (PST)
  • Enable HDR support for HL2: Deathmatch and HL2 single player.
  • I had a similar problem with vrad producing illegal operations. It turned out to be some invalid solids that Hammer never caught. Oops. --Campaignjunkie (talk) 17:20, 30 Dec 2005 (PST)
    • I spoke too soon. My brushes are perfectly valid, and when exported to a test map, compile correctly. But somehow, it's the combination of all of these brushes that crash vrad. I don't know why. --Campaignjunkie (talk) 11:45, 31 Dec 2005 (PST)
    • I get the same problem. I tried refreshing the SDK content and also tried completely re-installing the SDK, but neither worked.--Loco 03:43, 29 Mar 2006 (PST)
  • build_sample_shaders and build_advanced_shaders are both b0rked, it throws an exception with a missing steam.dll and when you put it in with the compileshaders.exe it will complain about no steam user info.
  • When adding custom sounds to your map. they are unusable. you can add the files via bspzip or pakrat, and the map will run fine on local game, but when map is running on a server, it errors "Failed to load sound "example/example.wav", file probably missing from disk/repository" --Wickit 14:14, 1 Jan 2006 (PST)
  • The only way I could get custom sounds to work was using them with a custom env_soundscape. --User:Ultranewb 19:04, 16 Jan 2006 (EST)
  • Not directly a compile issue with hammer. Using the impulse 81 command to check the cubemap compiling in-game doesn't work. I get the error messages: "Error reading weapon data file for: weapon_cubemap". If i drop the gun i get infinite errors of: "Bad pstudiohdr in GetSequenceLinearMotion()!" --Olavenspire 20 Jan 2006
  • vrad.exe does nothing while compiling. it starts it then goes directly to copy file. I have uninstalled and reinstalled the sdk already The log says:
    • Executing...
    • Command: "bla\vrad.exe"
    • Parameters: -game "bla\hl2mp" "bla\mymap"
    • Executing...
    • Command: Copy File


  • Windows Vista detects VVIS/VRAD as having stopped responding and forces you to close the application before the compile finishes.
    • This is an annoying bug, I have no information at all about the compilation progress when it is detected as "Not Responding"--Gilly54 07:13, 12 Sep 2007 (PDT)#
      • I can confirm this also happens with windows 7, very annoying
        • I've found that simply not touching ANYTHING while compiling prevents this. I recommend having a book or something sitting nearby if you have a slow computer or a big map. HiveLordLusa 04:55, 30 September 2012 (PDT)
  • If you try to compile a map when Steam crashes unnoticed, vvis and vrad come up with an error of not finding Steam.dll and are skipped, but vbsp just freezes. --Quanta 05:19, 2 Jun 2007 (PDT)
    • EDIT: This seems to occur when you exit from a game, but hl2.exe doesn't terminate. If this happens, none of the processes running from steam (including steam itself) will terminate, even if the application was closed. --Quanta 08:35, 16 Jun 2007 (PDT)
  • The shader compiler when running fxc.exe with the directx SDKs that include directx 10 support require the /LD flag to be set among the other flags in order to compile shaders properly for directx9 --CheetahShrk 21 Jun 2007
  • vrad.exe just crashes always. vrad crashes with the example prison map, with a minimalistic box map, with hammer 4.1, with batch compiling, no matter what. The compile log just stops when vrad should begin and any start of vrad gives a meaningless windows error message, vaguely pointing towards vrad.dll . reinstalling does nothing --Ollj 12:04, 1 Jul 2007 (PDT)
  • Hammer doesn't save (new) custom compile configurations. For example: When creating a custom compile configuration to run a map in GLView it doesn't save to reuse next time Hammer is opened. -- Swift
    • Confirmed, new or edited does not save configuration in expert compile mode. -- murte
  • studiomdl under Linux is not included (if it exists to begin with) in Source SDK 2013 nor any other Valve games made by Source. -- linuxgnuru 29 Dec 2013

Create a Mod

The Half-life 2 Singleplayer option is disabled when making a mod for Source 2009. I have Portal and Half-life 2, both fully up to date. Creating a mod for HL2 in the '06 SDK uses the Source Base content and code. While this is not nessisarily a bug, it is misleading, as it is the only way to make a mod for Singelplayer HL2 that currently works. --JeffMOD 18:03, 23 July 2010 (UTC)

Have you tried using the 2007 engine option? Seems to work for me. I didn't think you could mod 2009 yet, as there is no 2009 SDK Base --Welsh Mullet 13:35, 24 July 2010 (UTC)