Talk:Source SDK will not launch

From Valve Developer Community
(Redirected from Talk:Loading problem)
Jump to: navigation, search

Source SDK doesn´t work for about 80% of the time

Everytime I tried to launch it, it just launched what seemed like the Lost Coast main menu screen, except for the lack of the "Start game" and "Load game" buttons. After trying to launch it again, searching the internet for a solution, swearing vigoriously at the monitor and getting rid of some frustration with GTA, I decided to try one last time before giving up. Finally, it worked. I got the correct Source SDK screen, and none of that Lost Coast bullshit. After screwing around in Hammer editor for a while and struggling with realising the TF2 map I´ve had in my head for a while, I turned it off and had some dinner. When I came back and tried to launch SDK again, I got the Goddamn Lost Coast-lookalike again. So what´s causing this? I have the orange box, every game on it runs smoothly, so I shouldn´t have any problem, right? But I am having problems. Help would be greatly appreciated, just send it to erikgullback@hotmail.com Thanks in advance. --Biowon

Are you sure you're launching the Source SDK, and not the Source SDK base or Source SDKbase - orange box? Solokiller 20:31, 9 November 2009 (UTC)
God, I feel so stupid. The solution is always right in my face, and yet I keep missing it. Indeed, I just checked and launching only the Source SDK without any suffix resulted in 100% succesful launch of the three times I tried. Thank you, kind Solokiller.

--Biowon

Users with problems loading the Source SDK

Ok Well, I Got Source SDK. I Reset The Game Configurations And Reset The Oh S*** Anyways I Reset The Configurations And The One Above Or Under It I Cant Remember Anyways. NOW I Load Source SDK But But It Doesn't Appear. So I Downloaded It, Installed It Still Nothing I Restarted Steam AND My Computer Still Doesn't Work!!! How Do I Fix This???? Please Email Me If You Know T he Answer At ****** bfairless@hotmail.com ****** PLEASE! Unsigned comment added by Falcon123 (talkcontribs). Please use four tildes (~~~~) to sign your username.

I have the same issue. I have tried everything from reinstalling to compensating for a 64bit machine but the thing just won't open. - Siolis
The same thing is happening here .. I really need to keep working on a map that I was making but can't continue with that problem occurring ( I've already done everything to try to solve it ) - XBlackFuryX ( rekops@hotmail.com )
I Have the same problem...I have installed and reinstalled and still nothing pops up when i want to run it.I use a 32 bit system so it should have no problem. But if anyone knows how to fix this problem email me at hickorynut@sbcglobal.net i would really appreciate it. Unsigned comment added by Hicks16 (talkcontribs). Please use four tildes (~~~~) to sign your username.

Yeah got the same problem it's very stupid, i want to create some maps but i cant launch, i tried everything but the screen does not popup and i watch in task manager and there is no process.

SOMEBODY HELP!!!!

We probably need more information to be able to help you out. There's a vast majority of people that can use the SDK with no problems, so this is either a very specific issue, or it's simply something you're doing wrong (wrong configurations, perhaps?). See the list below for information that you should gather. --Etset 05:07, 13 Feb 2008 (PST)
I am having this exact same issue. It worked all week... then I just see a circle around my arrow telling me it's loading, yet no screen pops up.
  • Double click, or right click RUN in steam, or the shortcut, both are not working* I hit ctrl + alt + del and not one process for the sdk started up at all. I've tried restarting, re-installing...

verifying the cache... nothing is working. - DarkArmorZero 3:52 pm, 2/23 2011 (EST)

Provide more information!

Information that could help us help you:

  1. What games did you buy that granted you the ability to use the Source SDK? (It's probably one of these)
  2. Have you checked to see if the file ...\Steam\Steamapps\sourcesdk.gcf exists, and checked its size (the current non-beta version filesize is ~830MB and the beta is ~950MB)?
  3. Have you tried verifying the integrity of your cache file (specifically, sourcesdk.gcf)?
  4. If all the above steps seem to be alright, could you be more specific about what happens when you double-click "Source SDK" from the Tools menu in Steam?
    1. Does the Source SDK Launcher launch and crash immediately, or does it never even appear?
    2. Have you monitored the "Task Manager" to see if a process pops-up and then disappears (or stays there, like it has hanged)?
    3. Have you had strange issues with other applications? (It might be a hardware-related problem, or otherwise a conflict between other installed software)
    4. Did you ever (successfully) launch the Source SDK in the past? (If you have then a folder named ...\Steam\Steamapps\<your_user_name>\sourcesdk (at least) should exist, check if it exists, all of the tools exist there).
  5. Have you tried to (log into your Steam account and) launch the Source SDK on a different computer? (this would show that the problem is related to hardware/software incompatibilities on the "offending" computer, which is probably 100% of the cases).
  6. Have you tried deleting the ...\Steam\Steamapps\<your_user_name>\sourcesdk and ...\Steam\Steamapps\<your_user_name>\sourcesdk_content folders before attempting to launch the Source SDK again?
  7. Did you try completely uninstalling and reinstalling Steam?
  8. Lastly, you should try contacting Steam Support and hope that they can help you out. Apparently not.
If anyone wishes to add to this "list", please feel free to do so! --Etset 05:07, 13 Feb 2008 (PST)

More information

As a veteran of Steam and mapping in Worldcraft and then Hammer for many years, perhaps I can shed some additional light on the issue at hand.

I have the same problem, and am NOT running a 64-bit system. I have good, old-fashioned 32-bit Windows XP Home. Source SDK used to work just fine on my old computer (in offline mode, since Steam always made things FUBAR when it tried to update). With my new computer, Steam has reverted to the crashing temper tantrums, and the SDK simply refuses to launch at all. (It makes me want to strangle whoever designed Steam!)

To answer your questions:

  1. I have been a licensed owner of Half-Life 2, Lost Coast, and CS:Source for several years now.
  2. The file ...\Steam\Steamapps\sourcesdk.gcf does indeed exist, and it is 830 MB, just as it should be.
  3. My cache files passed verification, several times.

When I order Source SDK to launch, the little dialog box appears that says "Launching Source SDK..." After a few seconds, it disappears, and Steam seems to completely forget that I ever issued the command. No additional processes begin in the Windows Task Manager.

Interestingly, my ...\Steam\Steamapps\<your_user_name>\sourcesdk folder DOES indeed exist, though I have yet to see the SDK actually start.

All the files seem to be in order, and yet the darn thing simply will not initialize! It beats the snot out of me why...


I just contacted Steam Support two days ago and asked about this issue, and today I got an email that said:

Unfortunately, we do not offer support for the free development tools available with games registered in Steam.

And then they suggested that I go read the FAQ here.

I couldn't believe it! They blew me off! So much for customer service... My dim view of the guys at Steam Support just became pitch black.

I am chewing the guy out for such a cold and vague response. --Terminator484 16:03, 12 Feb 2008 (PST)

Steam SDK not running on 32bit XP

I have the exact same symptoms as above

I have just installed a fresh copy of steam along with Half Life 2 and the SDK (And SDK Base).

Both Half Life 2 and the SDK Base run fine, but the SDK app just gives me a window saying loading, before disappearing, I can do this over and over with the same results. I've tried rebooting the PC and re-downloading the steam.dll ClientRegistry.blob and SteamUI.dll

Seems that the problem isn't isolated. Unsigned comment added by Roskelld (talkcontribs). Please use four tildes (~~~~) to sign your username.

Potential Solution

I have found a post on a website which worked for me.

"With the new SDK update that happened recently, you have to reconfigure it. Right click Source SDK in steam and go to preferences, Set Launch Options (or something along those lines) the type in "-engine ep1" (without the ") then once opened, go to tools>options. go to the second tab over and toggle the "Use VGUI Model Browser (or somethin like that) Then you should be set."

I hope this is of help to people Unsigned comment added by Eurisko2k2 (talkcontribs). Please use four tildes (~~~~) to sign your username.

I can confirm this solved this issue for me. Though I couldn't find the tools->options menu in the sdk launcher, adding -engine ep1 to the launch options seemed to be enough. Joeedh 10:50, 17 Feb 2008 (PST)
This also worked for me. I found the same information earlier on the Wikipedia article for Hammer. The apparent reason some of us can't open the SDK is that an update for the Orange Box released late last year isn't fully compatible with pre-Orange Box games like CS:S and DOD:S. Anyway, thanks a lot for the help I'm anxious to start creating maps! Unsigned comment added by DrH (talkcontribs). Please use four tildes (~~~~) to sign your username.
I think this problem just happens if you don't own an OB game and you try to start the SDK in OB mode, but since there is now a mandatory update to Steam which allows you to set the engine in the SDK window itself, this problem should not happen again. Solokiller 13:11, 17 Feb 2008 (PST)
It's not mandatory as of yet, since it's still a beta version. But it probably does help with this issue, so people should try it out! --Etset 13:25, 17 Feb 2008 (PST)

I can confirm that just adding -engine ep1 to the launch properties fixed the problem. Thanks for the help Eurisko2k2. Unsigned comment added by Roskelld (talkcontribs). Please use four tildes (~~~~) to sign your username.

When i try to load the program up

When i try to load the program up it just does not work, nothing happens, the screen doesnt even change. The games i have installed are HL1, HL2, HL2DM, HL2LC and HL2Ep1.

The-mighty-kinkle 09:18, 21 Feb 2008 (PST)

Nothing happens, no matter what

I have tried every single solution I could find on the internet, on steam's website, and with customer support! Source SDK still refuses to start (I have tried it on my friends computer which cost $1500! and it still didn't work!)I will lose a great deal of faith in Valve if they can't get this fixed. Unsigned comment added by Orion952 (talkcontribs). Please use four tildes (~~~~) to sign your username.

Launcher Crashes on 64bit Windows Xp

Ok, I have tried the -engine ep1 and the -32bit launch option. But still no joy. I own the following games. Dark Messiah single and multi, Half-Life2 original & ep 1 & 2 and garrys mod. I have added the -32bit command to all of their launch options, opened the game, got to main menu, or in the case of garrys mod, I actually went into the game and then left. (I noticed that on some of my games, it came up with some sort of node out of date warning, but then it said it was updating, then it was fine.). As it stands, when I start the sdk up, it will show the source sdk tab at bottom of screen, then it instantly stops responding, it loads about 20mb of data into the process, then crashes, waiting does absolutly nothing, and the only way to get rid, is to end the process. Does anyone know of a way to open the sdk, or hammer specifically without this problem? Computer Specs are 3.2ghz amd x2 6400, 512mb 8500gt geeforce, 4 gb ram, operating on 64bit windows, but since the 64bit solution still doesnt work for me, I will assume its not 64bit related. Baaleos 04:27, 27 Jul 2008 (PDT)


I'll jump on this XP64 bandwagon. I've gotten it to open a few times on this machine, but it's unreliable and it won't open at all now. Installed games: L4D, TF2, GM, CS:S, DOD:S, HL2 (and EP1-2), Portal System: Intel 3.0 Duocore, 4Gb Ram on WinXP64 Steam Client: Built Jan 5 2009 18:08, API:v007, 969Mb installed file size according to properties I have defragged and verified the tool cache. (The first time I defragged the cache, it seemed to help, but not anymore)

The symptoms match Baaleos's, the SDK Launcher pretends to launch, and appears in the Task Manager, it loads 27,700K (+- 150K) and hangs. There is a button visible on my taskbar, but it is unresponsive. A few times the entire steam client has hung, but it's not consistent.

Hovis 22:33, 10 Jan 2009 (PST)


I also am unable to load Source SDK . Specs for my mechine 3.08 ghz 1.5 gb ram 512 video card nvidea vista basic os have tried ununstalling reinstalling seting options adding -engine ep1 still fails to load states problem with sdklauncher unable to load. What is going on


same here i have tried everyting the -32bit commands and -engine ep1 i even bought episode one to see if it would fix and no solution, have tried deleting and re-installing and still no joy my stats are / Processor: Core 2 Duo E6600 / Graphics: ATI Radeon X1950XTX / Ram: 2x Corsair DDR2 833Mhz 2gb Kits (total 4gb) / Mobo: P5N32E sli plus /OS: Windows XP x64 Professional

Steam games: HL / HL2 / HL:EP1 / CS / CS:S / TF2 Unsigned comment added by Azwraith (talkcontribs). Please use four tildes (~~~~) to sign your username. 4:20pm, 03 Oct 2008 (AWST)


anybody know a fix for this i have the same problem as well AMD Athlon x64 x2 6000+ Windows XP Pro 64 bit It used to work, but hasent since about 12/1/08


Same problem. AMD 64 X2 5000+, 4 GB RAM (have chips for up to 6 GB), Windows XP 64 bit Corporate Edition. Launching the SDK with any and all launch options results in a Source SDK taskbar item, the process itself hangs 30,800K +/- 1000K. I have verified the chache repeatedly, restarted Steam, restarted the computer, and redownloaded. File size is 969 MB on the drive, Steam informs me that the download is 977 MB (neither of which match up to this article). I own the Orange Box (Portal and Half Life 2 are not currently installed--I finished them and so removed their content) and Left 4 Dead. I have the Source SDK Base and the Source SDK - Orange Base also installed. --Draco18s 06:46, 14 March 2009 (UTC)


Same problem for me and Garrys Mod. I had it for a day before this stuff started to happen. I worked fine and now all that happens is that it maybe will launch the game and work for 2 minutes, give or take 1 minute. The game freezes, my moniter goes blank, and then it returns to the game for a about 2 seconds and freezes again, repeating this process over and over. After I successfully exit the game, I end up with the problems you guys have and can't start any game on Steam at all. The only time Gmod will work is right after I turn on my computer, and the same thing I just describes happens anyway. Any known solutions? I own CS:S and Garry's Mod. I've tried redownloading also, which like all you guys gives me the same result. Machine specs are AMD Athlon 64 Processor 3800+, 2.41 GHz, 2GB of RAM, and your average NVidia GForce graphics card, also use Windows XP. July 20, 2009


Workaround

Download [| Microsoft Virtual PC] and install a Virtual Machine with Windows XP (32 bit) and on the VM install (drivers, ethernet connection) Steam, Game Of Choice, and the SDK. Things should work. --Draco18s 00:05, 15 March 2009 (UTC)


Basdej: I know the simple solution!!!

you can let your screen popup when you typ at set launch options -engine EP1


What kind of an FAQ is this??? This really should be cleaned up and shipped off to the Help Desk. --Darthkillyou 05:16, 21 Nov 2007 (PST)

Agreed. Maybe this should be a redirect to 64-bit mode with Source SDK, since Source SDK won't start also redirects there. Opinions? --Etset 16:29, 18 Jan 2008 (PST)
I moved all of the posts under this discussion page, until this issue can be properly addressed and a correct article can be written about it. --Etset 14:28, 29 Jan 2008 (PST)

It worked when i downloaded...

ibo_00011: I installed Source SDK, Source SDK Base 2006, Source SDK Base 2007, Source SDK Base 2013 Singleplayer, Source SDK Base 2013 Multiplayer and Team Fortress 2 from Steam. It worked.