From Valve Developer Community
Jump to: navigation, search

I'd still like to know how to use it, please. I'm just curious about a single vtf, and downloading alternatives would probably just be a waste of time. --Andreasen 13:09, 15 Nov 2006 (PST)

Drag and drop?—ts2do 20:03, 15 Nov 2006 (PST)
Nope. I tried dragging it from /sourcesdk_content/hl2/materialsrc/, and it only flickers an empty DOS window and produces no result. --Andreasen 06:29, 16 Nov 2006 (PST)
Simply getting it to respond in any way, would be considered a progress. I tried calling it from DOS too, and it doesn't respond in any way. I'm starting to wonder if this program still works. --Andreasen 06:36, 16 Nov 2006 (PST)
I thought the command was like: "vtf2tga.exe vtffilename tgafilename" but now I can't get it work anymore. --n-neko 07:40, 16 Nov 2006 (PST)
I tried that without any success. TomEdwards was the one who in this article stated that it worked somewhat, so I've asked him about this. If he can't get it to work anymore either, it's certainly dead. --Andreasen 09:46, 16 Nov 2006 (PST)
You said you don't want any alternatives, but if you can't get it to work, my VTFCmd (binary archive) is a command line application that needs no installation or special runtimes. Just drag your .vtf onto VTFCmd.exe and it'll create a .tga in its place.--Nem 16:41, 16 Nov 2006 (PST)
Nem is hax; now im using VTFCmd and Lib lol --Theowningone 12:02, 2 Aug 2008 (PDT)

Reading some forum posts, it looks like this tool ceased to work around the 29th of December 2004. Before this you had to have it in the same directory as the file to convert, and it worked along the simple format of vtf2tga <VTFfiletoconvert> <resultingTGAfile>. --Andreasen 10:09, 16 Nov 2006 (PST)

Didn't this tool come from the leaked Source originally? I assume that's why it's no longer supported. --Wunderboy 12:06, 16 Nov 2006 (PST)

Nope, this tool has come from the released Source, or else I wouldn't have it. --Andreasen 12:16, 16 Nov 2006 (PST)

Here's how it worked: vtf2tga -i "FILE", and created a tga in the same folder—ts2do 17:38, 16 Nov 2006 (PST)