Talk:Source SDK Release Notes/Archive 1

From Valve Developer Community
Jump to: navigation, search

This page needs {{otherlang:en}} {{otherlang:es|Source SDK Release Notes:es}} added to the bottom. This links to the Spanish translation. —Maven (talk) 07:50, 4 Oct 2005 (PDT)

FileSystemOpenDialog.dll-Still bad?

I tried renaming the folders for Source SDK and Steam reinstalled the files. When I try to open Hammer, it still gives me the error, and renaming shortcuts doesn't work. So far, this is the one place on the whole web with people who know enough about SDK to figure out fixes. Urrrgh.

Also, after I kill that error message, when I try to load a map, I get "Missing material 'editor/flatnocull'". I'm deleting everything related to SDK and doing a fresh reinstall now, I'll edit later what happens.. Stormfury 17:56, 7 Nov 2007 (PST)

I already tried extracting the files and adding them. The problem is that a newly created mod (or an existing one) isn't mounting the ep2 gcfs, which is where it's storing the new editor materials. As far as the DLL problem... I've no idea yet. Still trying to figure that one out. If you do extract the materials, nothing in the views render correctly for some reason. Still trying to figure this one out.--Spektre1 18:22, 7 Nov 2007 (PST)

Beta SDK?

This sounds like the official release of the former beta sdk features. Does that mean I should disable the "-beta" command for steam now? Or are there... "new" betas now?

This issue is now clarified on the SDK Beta page. The bottom line: the -beta sdk currently has no effect, and all users are now running the release SDK. Removal of the command-line parameter is optional, though it may be used in a future SDK Beta release. --JeffLane 12:52, 18 Jan 2006 (PST)
Thanks for clarifying, Jeff. It would be helpful to mention this together with the release notes. The beta SDK was quite popular among mappers from what I hear in the forums. I can't think of a way of putting this on the page in an elegant way, though. Reaper47 15:45, 18 Jan 2006 (PST)
New beta, new parameter: -beta sdk1031 --Bluestrike 14:10, 3 Nov 2006 (PST)

HL2MV sequence lists

When making a new mod SDK from HL2DM (or possibly others), HL2MV disregards what game you are using and lists only HL2SP sequences.

Is this a known issue? New issue? Mflux 07:38, 19 Jan 2006 (PST)

Can other tools see your content? --TomEdwards 01:40, 7 Aug 2006 (PDT)
All the tools can see my content, so for example, HLMV will load my model, but its animations listed in the sequence box will be those of HL2SP. Same with all other multiplayer models. --Mflux 07:38, 19 Jan 2006 (PST)
Let me rephrase that. This is quite a serious issue. You can try this too. Start a new mod based off of HL2DM. Then use the HLMV from the mod and load up humans/group03/male09. Notice how all sequences (animations) are single player animations, not multiplayer ones. HLMV now can no longer view animations on all mods created after the recent update. --Mflux 20:33, 10 Aug 2006 (PDT)

demoinfo.exe gets AppID error

When running demoinfo.exe:

Extra App ID set to 211, but no SteamAppId.

'Nuff said. --TomEdwards 07:38, 19 Jan 2006 (PST)

Clarification on HDR

It says DOD:S, CS:S, and Lost Coast currently support HDR, what about the creation of a mod from scratch? I assume from scratch all the fundematal basics of the mod are based on HL2 and thus no HDR support as of yet, but could someone please confirm?

This is true—ts2do 18:04, 29 Jan 2006 (PST)
Uh, are you sure? Isn't this new Source SDK base supposed to work for modmakers so they can apply HDR in any mod etc? This is from the Source SDK changes list: "Mod makers should always use its SteamAppId (215) (=Source SDK Base) in their single player and multi-player mods." And this AppID includes all the new Source engine features... Right? skdr 02:08, 5 Aug 2006 (PDT)
He said that in January. ;-) --TomEdwards 02:13, 5 Aug 2006 (PDT)
Haha wow, I suck :) skdr 02:30, 5 Aug 2006 (PDT)

Texture thumbnails

With the most recent hammer release, I've noticed that custom textures don't have thumbnails or show up as checker boxes. Is there a way to resolve this? It's a pain mapping for a mod and all you see is purple and black. ElliottB

Just checked my sys, custom materials in mods and Source apps are all working properly. --wisemx 17:28, 4 Aug 2006 (PDT)

DoD Source fgd updates in sdk

I noticed there's no listing in the release notes but Matt Boone added dod_team_wall (allows you to setup an invisible wall that one team (or both) cannot pass through (used for spawn protection). He also added options to the dod_control_point entity to handle the new objective system. --FuzzDad 00:59, 5 Aug 2006 (PDT)

Source SDK Base.fgd / Halflife2.fgd Updates

Noticed 2 new npc entities in the updated Forge Game Data file for Halflife2 including npc_fisherman, which actually refers to the Barney.mdl and npc_ministrider. Actually both entities are available in Hammer v4.1 (if all scripts, sounds, textures, models, animations belonging to the entities are linked correctly), but disappear with the error message: "Attempted to create unknown entity type npc_...!" while testing the map.

As far as the Wiki entry "Authoring a Logical Entity" goes new entities require a recompiled server.dll file to be available in the game. I would like to know if there will be an update of the required files, so we can use the new entities for mapping. Dieb 12:50, 5 Aug 2006 (PDT)

Still not fixed?

Has valve fixed the most annoying bug that chainges brush shape when you have vertex edited an arch or anything as complex as that?

SteamAppID confusions

If the Mod you are currently working on gets listed on the Steam notification with the content: "The SteamAppID values for the following mods should be changed from 220 to 215: MyMod, garrysmod, metastasis, ..." please do not change the SteamAppIDs in any of the following GameInfo.txt files in these Steam directories:

\Steam\SteamApps\MyAccount\sourcesdk\bin\vconfig\GameInfo.txt \Steam\SteamApps\MyAccount\sourcesdk\launcher\GameInfo.txt \Steam\SteamApps\MyAccount\half-life 2\hl2\GameInfo.txt \Steam\SteamApps\SourceMods\MyMod\GameInfo.txt

All these still require the SteamAppID 220 and Steam will only replace the Sourcesdk-GameInfo.txt files with the originals in case they have been changed whenever the Source SDK gets startet but not the others. If you have changed the GameInfo.txt files from HL2 and/or the modification you are currently working on (eg. "MyMod") then you will get this error in Valve Hammer v4.1, when trying to run your compiled map.

"MountAppFilesystem() failed: SteamMountAppFilesystem(215,19, 9x11d6fd74) failed with error 21: A different version of this FS is already in use"

To fix that please write the changed SteamAppIDs back to 220. The SteamAppID Update notification does seem to concern only on complete build Mods, not on Mods you are currently working on. That's why don't be confused if the Modification you're editing with Hammer is shown up in that list. Dieb 09:26, 7 Aug 2006 (PDT)

SiN:Episodes SDK

After the 04 Aug 2006 SDK update Hammer no longer works for the SiN:E SDK

Will crash on File Open or File New.
Does not display path info upon opening. --wisemx 12:41, 9 Aug 2006 (PDT)

interaction with -beta srcds0407?

can i install both betas by adding both "-beta" or does one disable the other? Leopard84 11:52, 12 Jun 2007 (PDT)

the srcds0407 beta isn't running any longer, because they released the "final" update now --King2500 14:46, 12 Jun 2007 (PDT)

Well, that wasn't much

Heh, by taking a quick look at the the fixes, it seems as nothing much as done for the hammer guys. :P Well, the F12 is a great idea, but why don't the Valve guys just add a tab to bind that key under keyboard options. It takes 5 minutes to do. --Sortie 00:34, 14 Jun 2007 (PDT)


vconfig.exe is very important to me. Is it working properly now? Is there any work arounds for it? Jaredward 17:49, 8 Aug 2007 (PDT)

F12 console

This also fix the issue for maney non-US QWERTY keyboards. Although you could change the configfile manulay to workaround the issue befor. --Wolf 06:49, 4 Oct 2007 (PDT)

Vista shortcut?

If you try to add the -beta sdk0611 line after steam.exe in Vista you run into a problem since the shortcut does not have that line anymore. If I try to make a new shortcut the line is present but when I add -beta sdk0611. it says that it will not do. This seems to be a classic case of microsoft trying to fix things that aren't broken. Or maybe I'm just not getting something. My Vista version is in Finnish. And I could not enter this error in Bugzilla because Steam is not available to submit a bug about, which makes the following statement pointless and obsolete "Please report any issues you find in Bugzilla."--Deadity 18:09, 1 Nov 2007 (PDT)

Please Update

Please update this site some more often.

Whoa buddy, we do all that we can at a pace, so chill, and take it easy. If you want it very badly, you can always edit things and keep things up to date.--Gear 12:36, 7 Nov 2007 (PST)

Actually, no we can't. The page is locked. Hopefully Mike will get around to it pretty soon. As for right now, I'm gonna start compiling a bug list cause I'm already getting error dialogs. --Spektre1 12:37, 7 Nov 2007 (PST)

Speaking of which, I think hes doing that just as we speak.--Gear 12:38, 7 Nov 2007 (PST)

"You must...."

"You must add this to the launch options for the Source SDK in order to edit games that run using the Ep1 version of the Source engine..."

How? Where? sagesource, 00:41, 8 Nov 2007 (PST)

Right Clicking on source sdk and choosing launch options.--Gear 04:38, 8 Nov 2007 (PST)

Thanks for your prompt response. And I don't want to be always complaining, but it took me a bit of time to understand your advice, since it was way too cryptic. My first reaction to "click on source sdk" was to try the shortcut on my desktop, which of course doesn't work. It doesn't work if you follow the shortcut back to its source and try right-clicking that, either. What must have seemed obvious to you, but isn't to those of us who just use your software as a valued tool, is that you meant to say "Right-click on the source sdk icon under the Tools tab in your Steam account and select Launch Options from under the General tab under Properties." sagesource, 11:03, 8 Nov 2007 (PST)

Ah well sure its obvious, but anyone would know you can only change propertieswithin steam, its very basic. But i do apologize for not being more detailed, i was slightly in a hurry at that time, and quickly edited your question, so sorry bout' that.--Gear 12:32, 8 Nov 2007 (PST)

s'okay, i have a specialty far removed from video game engines and sometimes do that to people too. The "basic" is a highly contextual concept... <g>

Now on to the next problem.... your solution takes care of the immediate problem, and now the maps I was working on will open properly and run in Hammer.... but if I try to call up the model browser, for instance to get a new model for a prop_static, BLAM! nearly instant crash. The model browser only shows up as a gray rectangle -- I never actually see anything in it before everything goes down, usually with one of those "sorry Hammer has to close" popups. All the other editing functions seem to be working. Any thoughts? My machine has a gigabyte of RAM and a 1.8 mh processor -- maybe too little? sagesource, 12:54, 8 Nov 2007 (PST)

turning off the vgui model browser solves this, but then how do I tell what is a static prop, what's a physics prop, and so on and so forth? sagesource, 00:25, 9 Nov 2007 (PST)