Character Setup Overview:jp

From Valve Developer Community
Jump to: navigation, search
English

SOFTIMAGE|XSI Mod Toolを使ってソ-スエンジン向けのキャラクタを準備しコンパイルする方法をステップバイステップで説明します。


モデルの作成

注意: XSI Mod Toolを使用してモデルを作る場合のポリゴン数制限は、スケルトンを持つ、もしくはキャラクタの場合7500三角ポリゴン、スケルトン無しのプロップオブジェクトの場合は4000三角ポリゴンです。

  1. XSIで選択したオブジェクトの三角ポリゴン数を表示するには:
    1. ビュ-ポ-トの目のアイコンをクリックしてメニュ-から可視性オプションを選択する
    2. メインメニュ-から表示>可視性オプション(すべてのカメラ)(View > Visibility Options (All Cameras))を選択する。そうすると可視性オプションプロパティエディタが開きます。
  2. ステ-タス(Stat)タブで、シ-ン選択情報>選択情報の表示を選択します。シ-ン選択情報>選択情報の表示(Selection/Scene Info > Show Selection Info) オプションを選択します。

モデルにテクスチャをつける

XSIでのテクスチャとソ-スエンジンのマテリアルを関連させる方法については、キャラクタテクスチャとマテリアルドキュメントを参照してください。

目の設定

  • 各々の目に別のテクスチャが必要です。例えば、私達は目のテクスチャとして"eyeball_r.tga""eyeball_l.tga"、あるいは"dark_eyeball_r.tga""dark_eyeball_l.tga"を使っています。エンジンは眼球シェ-ダでレンダリングするためにこれらのテクスチャの名前にアクセスします。
  • 眼球のリファレンスとなる球を作り配置します。これらの球にテクスチャをはったり、エンベロ-プ設定は行わず、実際のモデルジオメトリにエクスポ-トしません。

クリックして表示

口の設定

口のジオメトリにも独自のテクスチャが必要です(私達は上下の歯と口内のデ-タをもった "mouth.tga"もしくは"fmouth.tga"を使用しています)。ここでもテクスチャ名はエンジンの口シェ-ダによってアクセスされます。

モデルのフリ-ズ

顔アニメ-ションを作成するまえに、XSIのフリーズ(Freeze)Transform>すべての変換をフリ-ズ(Transform > Freeze All Transforms)を実行してモデルをフリ-ズします。

アニメ-ションクラスタの定義

顔のシェイプキ-(モ-フ)のために2つのクラスタを作成します:

  • 顔の正面の柔軟な部分のクラスタ - 首の下正面から、後ろは耳の前縁、そして上は額の上まで

注意: このクラスタには歯や口内のポリゴンを含まないように気をつけてください。

  • 分離した下の歯のクラスタ

シェイプキ-の初期化

それぞれのアニメ-ションクラスタについて、フレ-ム0から35までのシェイプキ-を初期化します。

これを手早くやるには、それぞれのアニメ-ションクラスタでValveSource> Shape Tools > Init Shape Keysを実行します。スクリプトを実行する前にクラスタが選択されていることを確認してください。これはフレ-ム0のキ-シェイプのコピ-をフレ-ム1から40まで作成します。

シェイプキ-の作成

フレ-ム1から34までのシェイプキ-を作成する必要があります。キ-シェイプの完全なリストは[Character Facial Animation Shapekey Set:jp|キャラクタ顔アニメーションシェイプキー一覧]]にあります。

  • 新しいキ-シェイプを作成するには、ポイントを移動したり、回転したり、スケ-ルしたりしてキ-シェイプを「彫刻」し、正しいクラスタを選択していることを確認してからアニメ-ト>デフォ-ム - シェイプ>シェイプキ-の保存(Animate > Deform > Shape > Save Shape Key)を選択します。
  • シェイプキ-を他のフレ-ムにコピ-するにはValveSource > Shape Tools > Copy Shape Keysスクリプトを使用してください。

対応するシェイプキ-をもつクラスタを選択していることを確かめてから、スクリプトを実行します。すると目的のフレ-ム番号の入力を求められます。 以下手順であるシェイプキ-の一部を他のシェイプキ-にブレンドすることができます:

  1. まず最初に、モデルのクラスタを選択してValveSource > Shape Tools > Blend Shape Keys > Set Clusterを実行します。これでシェイプキ-ブレンドを行うクラスタを定義します。このクラスタの外のポイントは変更されません。
  2. 次に、プロポ-ショナルモデリングをオンにしていることを確かめて、ブレンド元のフレ-ムに移動し、クラスタ内でポイントのプロポ-ショナル選択を行います。これがソ-スフレ-ムとブレンドにおけるウェイトマップを定義します。
  3. 第3のステップはキ-フレ-ムインデックスを動かし(タイムラインで右クリックしてドラッグ)てブレンドの目標のフレ-ムを設定します。目標のフレ-ムには緑のフレ-ム表示が、そしてソ-スフレ-ムには赤い表示がされることになります。
  4. 最後に、ValveSource > Shape Tools > Blend Shape Keys >Blend Shapeを実行します。これはウェイトマップに基づき2つのフレ-ムのシェイプマップをブレンドし、目標のフレ-ムのシェイプキ-を更新します。

クリックして表示

キャラクタリグのインポ-ト

キャラクタリグを取得する必要があります。ValveSource > Characters > Biped Guideを使い、リグのサイズと位置を調整してValveSource > Characters > Create Rigを実行してリグを生成します。

またValveSource > Helper Bone Tool > Default (Male/Female) Rigを実行することでValveの男性・女性のデフォルトValveリグを呼び出すこともできます。

関節、手足のよりよい変形を得るためにリグに補間(ヘルパ-)ボ-ンを追加するには、ValveSource > Helper Bone Tool > Import helper bonesを使用してください。

クリックして表示

キャラクタメッシュのスケルトンへのエンベロ-プ

.smdファイルのエクスポ-ト

.smdファイルはジオメトリ、テクスチャ、エンベロ-プデ-タ、スケルトン構造デ-タを含んでいます。

.smdファイルをエクスポ-トするには:

  1. エンベロ-プされたメッシュとValveBipedブランチ全体を選択します。
  2. ValveSource> Export SMD....からSMD Exportオプションダイアログを開きます。
  3. Model (.SMD)をファイルタイプとして選択します。全てのオプションにチェックして、OKをクリックします。
  4. 出力先の正しいディレクトリを選択し、.smdファイルの名前を入力し、OKをクリックします。

.VTAファイルのエクスポ-ト

.VTAファイルは顔アニメ-ションデ-タを含んでいます。

.VTAファイルをエクスポ-トするには:

  1. エンベロ-プされたメッシュとValveBipedブランチ全体を選択します。
  2. ValveSource> Export SMD....からSMD Exportオプションダイアログを開きます。
  3. Vertex Animation (.VTA)をファイルタイプとして選択します。全てのオプションにチェックして、OKをクリックします。
  4. 出力先の正しいディレクトリを選択し、.VTAファイルの名前を入力し、OKをクリックします。

.qcファイル用のキャラクタの目のデ-タの設定

キャラクタの目の設定方法は2つあります:

  • QCEyesアプレットを使う: QCEyesを実行して、ヘルプ画面とテキストにプロセスを案内してもらう。
  • 手動で行う、これについては目の位置の設定ドキュメントに記述があります。

クリックして表示

.qcファイルの編集

.qcファイルはキャラクタリソ-ス(ジオメトリ、テクスチャ、アニメ-ション等)を実行モデル(.MDL)にコンパイルするためのスクリプトです。 新しい.MDLをコンパイルするには以下のように.qcファイルを編集してください:


  1. 目/顔のデ-タの更新 (目の位置の設定参照)
  2. .qcファイル内のモデルの名前(modelname_reference.smd)とアニメ-ションファイル(modelname_expressions.VTA)をXSIでエクスポ-トしたものと同じ名前に変更。
  3. 実行モデルの名前(modelname.MDL)を自分の作りたいモデルの名前に変更

StudioMDLでのランタイムモデルコンパイル

StudioMDLでのモデルのコンパイル方法についてはモデルコンパイルの基本(C-SEC)を参照してください。

もし更にモデルを修正していく場合は、自作キャラクタモデルの修正(C-SEC)を見てください。