Talk:SteamCMD

From Valve Developer Community
Jump to: navigation, search

I get in my CMD the error the steamCMD cannot connect to internet. I have connection to the internet but I am not able to login into the SteamCMD. I am in centOS and I am not logged in into the normal steam client or site
uname -a Linux vpstyasvrb 2.6.32-220.el6.x86_64 #1 SMP x86_64 x86_64 x86_64 GNU/Linux

http://tinypic.com/view.php?pic=v7fsb8&s=6


steamcmd appupdate glitch

When I try to download a new server it does not put the files in the specified directory, I am not even sure it is installing them at all. How do I fix this? I do:

  • login anonymous
  • force_install_dir C:\Users\Administrator\Desktop\Awesome land updated\garrysmod
  • app_update 4020 validate

What am I doing wrong?

Using steam and steamcmd simultaneous

When it's time to update a server where i need to log in , i need a logout of steam (cannont play a game)

Anything is possible for fix that (starbound)

Exit codes

Is there a list of exit codes & means for steamcmd?

For some reason, if a game is up2date it exits with exit code6

Liv3d @ 08:14, 12 November 2012 (PST)

ia32-libs

On Ubuntu, the Package Group ia32-libs-gtk is now called ia32-libs.

Tomcek November 27, 2012, 21:14 (GMT+1)

Invalid Platform

I seem to be getting: ERROR! Failed to install app '220070' (Invalid Platform)

I'm using Fedora 17. uname -a returns: Linux localhost.localdomain 3.6.10-2.fc17.i686 #1 SMP Tue Dec 11 18:27:35 UTC 2012 i686 i686 i386 GNU/Linux

Other people seem to be getting this error as well, though I'm not too sure what distro they're using. I'll try it again in the morning with Ubuntu.


--Bheesham 00:39, 2 January 2013 (PST)

Poor Documentation Doesn't Help Linux

The documentation here takes some tinkering with to get things working.

And some doesn't even work.

First, to clarify, app ID is the valve app ID for the game. There should be a link to the app ID list somewhere (although they list CSGO in the example.

Second, to automate SteamCMD do xxx.

SteamCMD is not really a command. You can't just run SteamCMD although it makes it look like you should. I guess you have to run steam.sh every time although I'm still vague on this step.

I'll set an update script however, I don't know what command to kick it off with. These instructions should take nothing for granted.

I never thought I'd say this but I miss the hlds tool.

You're absolutely right! I added a link to the Steam AppID list and I clarified the steamcmd / ./steam.sh step in Automating SteamCMD. Lonaowna 06:12, 6 January 2013 (PST)

Supported Games for Anonymous Login

Hesitant to link on the page since it's not an official link (even though pointing to official data), but an always updated list of games that support the new anonymous login can be found at http://cdr.thebronasium.com/sub/apps/17906 (or at any of the other various cdr listing sites)

--Psychonic

Problem

Im not sure. im putting on a new server to Steam and No Steam, i uploaded the "app_update 90 -beta beta validate" (the steamCMD.exe is in a folder in desk, not in Valve) is that correct? should i run the HDLS in the folder that steamCMD downloaded? What i need to do for run the server, please somebody i need really help.

thanks

BugslayerUtil.dll not found!

Hello, before I begin I would just like to point out that I'm new with how Discussion pages work, and so I ask for your patience if I do anything erroneous.

When I attempt to run SteamCMD.exe to update it, I notice that I get the following:


[ 0%] Checking for available updates...

[----] Verifying installation...

Steam_: BugslayerUtil.DLL not found

Steam Console Client (c) Valve Corporation

-- type 'quit' to exit --

Loading Steam3...OK.

Loading Steam2...OK.


Steam>


I would like to know if there is some way to fix this, or if I have done something wrong, or if this is even a problem at all!

--Kytosai 15:58, 16 June 2013 (PDT)

Windows requires Internet settings set to automatic

While doing some fiddling with srcds on Windows 8 I found I had to enable "Automatically detect settings" settings under Internet Properties -=> Connections -> LAN settings, otherwise steamcmd would gripe about not being able to connect (http error 0). Don't have the actual errors off hand.

--Foobar 19:56, 1 July 2013 (PDT)

Warning in steamcmd.sh

I got this with the steamcmd in the package : steamcmd.sh: 16: [: unexpected operator steamcmd.sh: 16: [: unexpected operator

All work correctly but I want to have clear log

Linux example code

Any questions related to the example code of linux, can be directed to me on the Steam community. --Roelof 14:50, 26 July 2013 (PDT)

Validate doesn't work

Since there are no documentation, it's impossible to bug track it, if you use the validate option the game will be downloaded again. The function/routine that check/verify the consistency of every file is unknown, how it generates the hashes? SteamCMD requires an specific filesystem to use its 'validate' function?

--HellMind 11:43, 30 August 2013 (PDT)

ERROR! Failed to install app 'xxxxxx' (No subscription)

i enter my login and passwor it say success but when i enter app_update 258550 i get error

Steamcmd does not update - sits on 0.00 of 0.00 etc.

I have a network server (runs off 1st router), my and other pc's then of that using 2nd router.

Steamcmd was working on server and now does not load updates for games (pretty much since ARK was released). Updating games got really slow and now will not update at all.

I have search forums, set automatic detect settings, reloaded steam, reloaded steamcmd, redone firewalls, routers, main box and to NO change.

My pc I have been able to get one game to update (took about an hour to tick through). I have put another server on 1st router and set that up and same thing. NO UPDATING.

WHAT IS WRONG WITH STEAMCMD? Downloading works ok as program itself updates and loads when 1st setup. Steam downloads ok. BUT NOT BLOODY STEAMCMD!!

Even thou I have set IE auto detect setting I do not use IE as a browser. (The server side also has TCADMIN on it.)

This is driving me mad. Any solutions?

Support Raspbery Pi

Hello.

I think that there is a need to port SteamCmd on ARM-platform, "Raspberian" in particular OSes.

Advantages: Raspberry Pi - a computer of low power consumption (a few watts). It is advantageous to make download games for linux / windows on such a computer, as opposed to personal computers, consuming much more energy.

I also have a NAS (on the x86 platform, the power consumption of about 22 watts), and I can not download anything.

The problem is in the SSL work. SteamCMD presupposes the existence of an installed package "ca-certificates", but I can not install it. NAS have own linux-system, nothing similar to the Debian / Ubuntu. I do not know how to put the package "ca-certificates" on an generic Linux system.

Default App Directory

Recent versions (since around 3/20/2016, give or take) of steamcmd (on CentOS 7) seem to have changed their default app_update behavior and may cause confusion. Has anyone else experienced the following behavior when NOT specifying force_install_dir?

I previously had SteamCMD installed as ~/steamcmd/steamcmd.sh, and apps would install/update to ~/Steam/. I ran app_update yesterday, and it downloaded a whole new copy of an installed app to ~/steamapps/. I created a fresh SteamCMD install as ~/steam-cmd/steamcmd.sh, and apps installed/updated to ~/Steam/. I renamed ~/steam-cmd/ to ~/steamcmd/, and apps began to install/update to ~/steamcmd/. I now have SteamCMD installed to ~/steam-cmd/ to force the old behavior, because I consider it to be a standalone tool -- not part of a Steam installation.

If this can be confirmed, I would like to volunteer (or ask for a seasoned editor) to add a brief section covering default app_update behavior.

(I'm sure this would be better off on an issue tracker somewhere, but there doesn't seem to be one and people on Github get upset when someone talks about SteamCMD on other Valve project trackers. If someone knows of an appropriate channel to report this quirky behavior, I would appreciate a pointer.)

Zyxw (talk) 18:08, 26 March 2016 (UTC)


Network Problems in JailChroot linux

I have problems for initial update run in jailchroot installation under linux (ubuntu 16.04).

"SteamUpdater: Error: Steam needs to be online to update. Please confirm your network connection and try again."

I have posted the strace ./tf2_updater logs in the community forums: http://steamcommunity.com/discussions/forum/14/154643795213616041/

As you can see, the jail has no problems to accessing at internet, since you can execute commands like ping, host, whois, wget, etc. But steamcmd has problems for downloading the initial update that allows to run the TF2 server.

Radical