Talk:SDK Beta Bugs/archive

From Valve Developer Community
Jump to: navigation, search

vvis.exe - Unable To Locate Component (FIXED)

(Posting this in Talk 'cause it may just be I'm an idiot...)

The Beta SDK seems to have broken my cheap and cheerful map compilation batch files - vbsp will run fine, but vvis and vrad come up with 'Unable to Locate Component: This application has failed to start because Steam.dll was not found' error messages.

Here's one of my batch files:

set mapdir=c:\Documents and Settings\Adam Foster\HL2

"%sourcesdk%\bin\vbsp" -low -nolinuxdata "%mapdir%\%1.vmf"
"%sourcesdk%\bin\vvis" -low "%mapdir%\%1.bsp"
"%sourcesdk%\bin\vrad" -low "%mapdir%\%1.bsp"

copy "%mapdir%\%1.bsp" "%vproject%\maps"

I can compile maps through Hammer without problems (beyond the usual "Hammer being an awful front-end for compiling maps" bug and a new "tries copying into a non-existent directory at the end" issue) so I'm a bit puzzled as to what's going on. Am I doing something blatantly wrong here? ;-) --Cargo Cult (info, talk) 14:01, 23 Nov 2005 (PST)

Don't you need either a -ldr, -hdr, or -both option on vvis and/or vrad now? I might have read something like that somewhere. —Maven (talk) 14:09, 23 Nov 2005 (PST)
Added it to vrad (vvis came up with a parameter usage list instead of its error!) but to no effect. Here's what I get when vvis runs, for example:
C:\Documents and Settings\Adam Foster\HL2>"c:\steam\steamapps\BALEETED!\sourcesdk\bin\vvis" -low "c:\Documents and Settings\Adam Foster\HL2\metastasis_2.bsp"
Valve Software - vvis.exe (Sep 7 2005)
Can't load c:\steam\steamapps\DELETED\sourcesdk\bin\filesystem_steam.dll.Can't load c:\steam\steamapps\DELETED\sourcesdk\bin\filesystem_steam.dll.
... Then it exits. Same for vrad. As I said, vbsp runs fine... :-/ --Cargo Cult (info, talk) 14:26, 23 Nov 2005 (PST)
The only other thing I can think of is to run it in Hammer once, then copy the command line it uses. —Maven (talk) 14:34, 23 Nov 2005 (PST)
Tried that - I suspect there's some PATH weirdness or something going on. I've tried running vvis from the sourcesdk\bin directory, but it comes up with the can't-find-Steam.dll error message whenever I start it with some valid parameters...
Hang on, this is new: I now get the following when I try running vbsp:
SteamStartup() failed: SteamStartup(0xf,0x0012E8A8) failed with error 1: The registry is in use by another process, timeout expired - argh!
Make sure you do not have an old steam.dll somewhere in your path and/or Steam directory. This sounds like it's running the incorrect steam.dll.
Neither -hdr or -ldr are required options. There are no required compile options -- if they were required, they wouldn't be options. The default is LDR-only. --JeffLane 16:54, 23 Nov 2005 (PST)
I've just got the one Steam.dll, in C:\Steam, but I do have numerous FileSystem_Steam.dll files. There's one in C:\Steam\bin and another in C:\SteamApps\username\sourcesdk\bin - they're of different sizes (216kB for the former, 204kB for the latter) so my best guess is that these two are conflicting somehow. I tried temporarily replacing the C:\Steam\bin one with the SDK version, but on restarting Steam the system saw what I was up to and downloaded and replaced it with a 'proper' version. Heh! --Cargo Cult (info, talk) 17:09, 23 Nov 2005 (PST)
Multiple Filesystem_steam.dll files is normal. You can also try deleting your /Steam/ClientRegistry.blob and restart Steam. You may have to Reinstall the Source SDK installation. If these don't work you may have to re-install Steam from scratch, though you can attempt to re-install while keeping your current .GCF files.
I've tried deleting the .blob file and the deletion and reinstallation of the Source SDK, but to no effect - I'll try the reinstalling Steam thing at the weekend. I've got Hammer's map compilation thing working properly now (it was a terribly obvious configuration option which was messed up) so it's more of an annoyance than of any urgency now. ;-) —Cargo Cult (info, talk) 13:41, 25 Nov 2005 (PST)
In Hammer's Build Programs tab it now has $SteamUserDir\sourcesdk\bin\*.exe, instead of %sourcesdk%\bin\*.exe. I would put money on that being the problem we're having. --TomEdwards 05:01, 27 Nov 2005 (PST)
Anyone tried the above? Not sure if that is the problem. I call the vbsp, vvis and vrad giving the full path (without using the %sourcesdk% and $SteamUserDir vars) and have the same problem... --DAVLevels
I'm having the same exact problem, and it's a little more than an annoyance for me, because I need to be able to compile several maps at once for nightly builds. Is it possible that since Hammer is executing the compile tools, it's passing some sort of path information to them? I'm not a programmer, so I'm not entirely sure what's happening there. It just strikes me as odd that it works in Hammer, but not from the command line. --Spektre1 13:59, 25 Nov 2005 (PST)

Has anyone found a solution yet? --TomEdwards 02:10, 3 Jan 2006 (PST)

using the CSTools worked for me. with the CST i had the APPID bug but that can be fixed by manipulating the gameinfo.txt --Sa74n
A fix for this is coming very soon. You should not mess with GameInfo.txt files in an attempt to solve the issue. --JeffLane 11:08, 5 Jan 2006 (PST)
now that was quick :) thanks for the fix. --sa74n


I've just started Hammer up again, and it looks ... different. It seems to have re-sprouted lots of white points at brush vertices, and the no-grid-lock-for-vertex-manipulation-midpoints bug seems to have disappeared. Has there been an update? I wasn't really paying attention. :D —Cargo Cult (info, talk) 10:15, 6 Dec 2005 (PST)

cursor disapearing/blurry

The cursor disapearing is really annoying when you are selecting objects from the new object browser. Also the grid lines/vertec points are all blurry on my monitor but nothing else is, why is this? Btw apart from the little bug the new browser is really good! GNXDan

NPC Crash

if use npc_** entity, crash hammer

I don't think that that has ever happened to be. Can you reproduce this bug or is it random? --Andreasen 23:44, 13 Feb 2006 (PST)