Talk:Rain splashes

From Valve Developer Community
Jump to: navigation, search


I get this red cross shit with any particle, no matter if it is custom or native ep2 particles, how should I "precache" it? It is already precached in particles_manifest, and precaching in code (which is not mentioned in article though) does not seem do be helpful. Please, help. 783001 01:52, 9 August 2011 (PDT)

Fix Preache Issue

I had the same error, I fixed it by preaching the particle I were to use by using the "!". Example, I will use the water_impact.pcf then I have to write this in the particles_manifest.txt in Mod/particles if I will use another particle inside that "particle zip file":

    "file"		"!particles/water_impact.pcf"

Then in the code I wrote this:

DispatchParticleEffect( "water_splash_01", trace.endpos,trace.m_pEnt->GetAbsAngles() , NULL ); // water_splash_01 since this is a water impact particle which I found in the water_impact.pcf file. To preache it properly use "!particles/water_impact.pcf"
Note.png Note: If you want to use a different particle you need to run your mod with these parameters in its command line parameter: -tools -nop4. For more information about the Particle Editor check this page: Particle Editor I hope that this will clear up the issues for most people with this issue, cheers!