Talk:Looping a Sound

From Valve Developer Community
(Redirected from Talk:Looping A Sound)
Jump to: navigation, search

Looping MP3s

Since MP3 doesn't save cue information, does this mean that MP3s can never be looped? --Darkhand 15:28, 2 Dec 2008 (PST)

Yes. You can only loop .wav sounds, sadly. --Craziestdan 15:56, 2 Dec 2008 (PST)


You have to buy some separate program just to make looping sounds in Hammer? Personally, I think that's really stupid. Why isn't anything like this included with Hammer? Day32 04:42, 16 February 2009 (UTC)

Man, there's an unlimited demo version of Goldwave.. that should be enough. --NykO18 19:46, 29 April 2009 (UTC)
It's not unlimited, it has a certain amount of clicks until it expires. (I think 500) So don't go pressing crap for fun. --DannyS 23:52, 29 April 2009 (UTC)
Mine doesn't expire, I just have to relaunch it. I must be lucky. --NykO18 18:07, 5 May 2009 (UTC)
I added some information about a free program called Wavosaur. It's kicking some budget-conscious butt. --ThaiGrocer 02:15, 15 February 2010 (UTC)

Cue names (Ending Cue will be ignored)

It turns out that (in Ep1) the name of the cue doesn't matter, and that only the first one has any effect. You certainly can't have one to start the loop and one to end it. --TomEdwards 13:48, 6 April 2009 (UTC)

Same Issue with Source SDK 2013 SP (EP2), is this Engine specific? To loop a sound correctly: Instead of setting an ending Cue in the file, simply let the sound end at this point. --Dobbelle 17:18, 30 May 2015 (UTC)

Possible in Audacity?

Hey I wonder if this is possible with Audacity? --Nathaniel 00:52, 30 September 2010 (UTC)

Audacity has a pretty crappy featureset, I doubt it could do this. Thelonesoldier 01:15, 30 September 2010 (UTC)
Oh. I don't have Audacity yet anyway. Nor do I have Goldwave. (I think I'll install the programs later) --Nathaniel 23:03, 6 October 2010 (UTC)


On Wavosaur, the sound i'm using for portal 2 is not looping. it's a custom sound. how do i fix that?

Wavosaur doesn't work. I just tried a variety of WAVs from different sources, sample rates, bit depths and the loop points from Wavosaur never work. Goldwave on the other hand works every time. Maybe some update of Wavosaur changed how loop points work/are stored and that broke compatibility with the game engine. Or maybe for the ppl that thought of this looping mechanic only Goldwave existed as a sound editor and never bothered with compatibility. This loop point thing is kinda stupid since it's not a standard in any way (although in paper it's a nice feature I guess). Anyway, sail the seven seas for the program and keys, there should be a portable version, no matter how old, that works without a fuss (I'm only using it for the cue points and nothing else).
I'm using GoldSrc btw (and not making maps, just replacing ambience sounds in custom maps like in fy_poolparty). Does anyone give a damn about GoldSrc these days? The way of looping sounds looks the same in both engines though.

TL;DR: Don't bother with Wavosaur, it won't work. Goldwave is the only thing that works for the cue/loop points. -Wololo

I know FL Studio works for Source. Not sure about Goldsource. Since Goldsource is older yeah it might need some different method of inserting the loop point... Pinsplash (talk) 05:45, 1 October 2018 (UTC)

Music not looping correctly

I currently try to make a music mod for Left 4 Dead 2 to replace some of the tracks. I added cues to my track via GoldWave (also tried Wavosaur before) but for some reason some tracks do not loop at all, while others seem to loop but completly ignore my own loop cues. For example my replacement music for "skinonourteeth" seems to randomly loop somewhere from the middle while the actual start_cue is pretty close to the beginning right after the first 3 notes or so. Meanwhile the replacement for charger attacks don't loop at all and tracks like the witch loop but there is a random gap between it playing and the next loop. After that I thought I might need to create the sound.cache thing, but even that didn't work. Any ideas what I'm doing wrong? - TitanKämpfer