Hammer Overview:ru

From Valve Developer Community
Jump to: navigation, search

Большинство элементов редактора Hammer могут быть перемещены или настроены в соответствии с предпочтением пользователя. Основные окна редактирования не могут быть перемещены, но они имеют множество вариантов размещения.

Вид редактора Hammer по умолчанию.


3D Окно просмотра

В этом окне отображается ваша карта в 3D, чтобы узнать как перемещаться в нем прочтите статью Перемещение в пространстве. Большая часть вашей работы будет сделана в этом окне.

Вы можете регулировать освещение в данном окне переключаясь между All Lighting (F6) и Fullbright (F5).

Вид в 3D окне просмотра.


2D Окно просмотра

2D Окно просмотра, позволяет вам увидеть карту с сверху, спереди или сбоку, это полезно, когда вы хотите увидеть объект с определенной точки зрения или работать создавая геометрию карты.

  • Ctrl+Пробел переключение между видом: сверху, спереди, сбоку
  • Ctrl+A+Пробел переключение между видом: сверху, спереди, область будет размещена так, что выделенный объект, будет находиться в её центре.
Вид в 2D окне просмотра.

Кастомизация интерфейса

Кнопки: плавающего вида и закрытия.

Практически любую панель можно перевести в плавающий вид или закрыть, используя маленькие кнопки в правом верхнем углу панели. Небольшую иконку с перекрывающимися окнами можно использовать, что-бы перевести панель в режим плавающего вида. После того как панель переведена в режим плавающего вида, её размер может быть изменен или она может быть вставлена в редактор на свое или же другое место. Так же вы можете закрыть панель, нажав на "X".

Совет:
Если какие-либо панели, обозреваемые далее в статье отсутствую или вы не знаете как востановить закрытое окно/панель, вы можете привести редактор к начальному виду, перейдя по View -> Toolbars -> Default Layout


Инструменты

Covers the various tools for accomplishing tasks in Hammer. When a tool is active, the Tool Properties pane to the right shows its unique properties and commands.

Tools are globally accessible. This means that if you hit the key associated with another tool, e.g. Shift+S for Selection Tool, you will be switched to that tool from whichever one you were in.

Tip:Hammer will display shortcut keys when hovering the mouse over buttons. Most commonly used buttons have shortcut keys associated with them.


Hammer overview icon selection tool.png

Selection Tool (Выделение)

The Selection Tool is the default tool when Hammer is started and is the most basic way to select geometry elements (vertices, edges, faces, meshes), objects, and groups. Once a selection is made it can be manipulated via the various other tools available.

  • Shift+S - Выделить


Hammer overview icon translate tool.png

Translate Tool (Перемещение)

Snap settings; Located bottom right side in Hammer.

The Translate Tool allows movement of a selection along the X, Y, or Z axis. Drag the gizmo's red arrow for X-axis movement, green arrow for Y-axis movement, or blue arrow for Z-axis movement. You can also grab the colored squares to translate the object along two axes at once. Translation distance is dictated by grid size but can be overridden by holding Ctrl while translating the selection.

  • T - Translate
  • Ctrl+LMB - While translating a selection this temporarily disables grid snapping
  • [ and ] - Change grid size in power of two increments
Tip:Grabbing the small purple origin on the Translate Tool will allow movement on any axis but more importantly will snap the selection to the surface of another element. Useful for quick prop placement.


Hammer overview icon rotate tool.png

Rotate Tool (Вращение)

The Rotate Tool allows rotation of models along any axis. The gizmo will change to red, green, and blue circles and dragging any of these will rotate the object along the desired axis. It is possible to rotate along multiple axes by dragging the yellow sphere in the center of the gizmo (hidden until hovering the pointer over it). The angle at which that rotation snaps is determined by the value provided for Angle at the bottom right of Hammer.

  • R - Rotate
  • Ctrl+LMB - While rotating this temporarily disables the angle snap settings
  • Angle - Bottom right of the Hammer window defines snap angle


Hammer overview icon scale tool.png

Scale Tool (Масштабирование)

Масштабирование позволяет изменять масштаб геометрий и модели. Инструмент состоит из манипулятора в сочетаний с красным кубом, зелёным и синим. Перемещение красного куба масштабирует геометрию по оси X, зелёный куб масштабирует по оси Y и синий по оси Z. Вы можете масштабировать по двум осям сразу, перетаскивая их. Так же возможно масштабировать сразу три куба одновременно, двигая пурпурный куб, который является манипулятором всех трёх кубов.

  • E - Scale


Hammer overview icon pivot tool.png

Pivot Tool

The Pivot Tool allows changing of a selection's pivot point. Various tools use the pivot point to determine how to act upon your selection. For example, if rotating a cube around a pivot that's located in the cube's exact center, the cube will spin in place. Moving the pivot to one of the cube's corners will cause it to rotate around that specific corner. Moving an element's pivot point is a temporary setting, unless you use Set Origin To Pivot. Deselecting and re-selecting will reset the pivot point.

  • Insert - Enter/Exit Pivot Tool
  • End - Reset Pivot
  • Set Origin To Pivot - Only applies to meshes but can be used to save the pivot point for future selections


Hammer overview icon entity tool.png

Entity Tool (Сущности)

The Entity Tool allows placement of any type of entity class in your map. These include things like lights, player spawn locations, AI spawn locations, logic relays, props, etc.

  • Shift+E - Entity Tool
  • Alt+ Enter - Opens properties for a placed entity


Hammer overview icon block tool.png

Block Tool (Примитивы)

The Block Tool will create basic meshes. The most commonly used mesh is usually the 'block', hence the name of the tool. The usual workflow is to place basic geometry in the world and then use the more precise geometry editing tools (translate, rotate, scale) to hone in on the desired shape of the geometry.

Some of the other geometric shapes have presets to modify ahead of time to get different shapes. For example, the cylinder can make quick columns, arch can create arched doorways or spiral staircases, and so on.

  • Shift+B - Block Tool
  • Esc - Cancel creation
  • Enter or Space - Confirm creation
Tip:When confirming a shape created by the Block Tool, changing to a mode such as Edges will select all edges on the newly created shape.

Convex Tool

Not supported.


Hammer overview icon clipping tool.png

Clipping Tool (Ножницы)

The Clipping Tool will slice geometry in a variety of ways. Cuts must be made in the 2D viewport and must be confirmed with Enter, otherwise the change is discarded. The Clipping Tool has three different modes that determine whether it keeps the geometry on one side of the cut, the other side of the cut, or both sides of the cut. Cycle through these by repeating the shortcut key.

  • Shift+X - Clipping Tool
  • Enter - Confirm cut


Hammer overview icon mirror tool.png

Mirror Tool (Симметрия)

The Mirror Tool allows mirroring of a selection across a user-defined axis. In the 2D view, click and drag a line to choose which axis it will use to mirror.

  • Shift+F - Mirror


Hammer overview icon texture projection tool.png

Texture Projection Tool

The Texture Projection Tool is used to do basic UV mapping. Can be useful for complex geometry that needs fine tuning. There are more automated methods for UV mapping covered in other parts of the documentation.

  • Shift+P - Texture Projection


Hammer overview icon paint tool.png

Paint Tool

The Paint Tool allows blending of materials on displacement geometry (often referred to as terrain but not limited to ground type materials).

  • Shift+V


Hammer overview icon displacement tool.png

Displacement Tool

The Displacement Tool is a method to sculpt geometry inside Hammer using displacements as a base. One usage case for this tool is to build rolling hills for a terrain-based map.

Note:Requires a face to be subdivided. The tool will not work on regular geometry. This can be accomplished in the Face selection properties and selecting an appropriate subdivision amount
  • Shift+D - Displacement Tool
Tip:Dota 2 terrain is comprised of a lot of smaller subdivided terrain. This is generally not shaped with the Displacement Tool due to the gameplay requirement of gameplay surfaces being completely flat.


Hammer overview icon asset spray tool.png

Asset Spray Tool (Спрей ресурсов)

The Asset Spray Tool is a work-in-progress, unsupported tool that allows any asset to be "painted" onto surfaces in the world.


Hammer overview icon tile editor.png

Tile Editor (Плиточный редактор)

The Tile Editor allows the easy creation of custom maps using a set of predefined tiles that link together to form a playable gameplay space. In Tile Editor, you can paint terrain, water, paths, trees, plants, and even place shops, barracks and other gameplay objects. See the Tile Editor introduction for details.

Note:Selecting this tool for the first time in a map without tiles will auto-generate a large space to paint tiles in. If this is undesirable, this newly-created Tile Grid can be selected in the Outliner pane and deleted like any other object.

Selection Modes

The different Selection Modes.

Your active Selection Mode defines the element that can be selected. Vertices, edges, faces, meshes, objects, groups, bones, and navigation are all valid selection modes.

Selection modes are covered in more detail in Basic Construction.

  • 1 Vertices
  • 2 Edges
  • 3 Faces
  • 4 Meshes
  • 5 Objects
  • 6 Groups

Undo History

Пример отмены нескольких действий.

Каждое действие сделанное в Hammer отобразиться в Undo History. Нажатие на изменение вернет карту в предыдущее состояние. Бывают случаи когда вам надо отменить несколько действий, в таком случае использование комбинации Ctrl+Z является долгим и не рациональным, и проще использовать Undo History.

  • Ctrl+Z - Отмена действия

Command History

Command History.
Примечание:Command history по умолчанию не включена. Перейдите в View > Toolbars, чтобы включить её.

Любое действие Hammer отображается как команда в панели Command History . Repeat Commands может быть применено к выбранной команде (или к нескольким выбранным командам), для повторения нужных действий.

Более подробно можно ознакомиться в данной статье: Command History.

  • Shift+G - Повторить команду

Outliner

Outliner.

The Outliner pane provides a view of all the objects in a map. Objects can be selected here much like in the 2D or 3D view. Basic searches can be run via the Mapnode name filter field. Advanced filtering options are located under the Entity filter options checkbox, which allows searching of entities by various class and/or any key/value combinations.

Selection Sets

Selection Sets.

The Selection Sets pane displays all the objects in the map. The Auto selection set is generated automatically and contains all the objects in a map. Custom selection sets can be defined via the New Selection Set button. You can use the buttons to the left of a category to hide or show objects en masse.

It may be desirable to place an entire region of a map in a selection set to easily toggle on/off. This would be accomplished via a new custom selection set to help keep the map more organized. This is especially useful in very complex or large maps.

Свойства объекта

Object Properties.

В панели Object Properties отображаются различные свойства, которые могут быть изменены в данном объекте. Object Properties contains everything that defines a particular entity, and also includes the Input and Output tabs of the logic system.

  • Alt+ Enter - вызывает окно Object Properties

Активный материал

Active Material.

Отображает текущий активный материал. Материал будет накладываться автоматически на созданную геометрию. Нажмите Browse, если хотите сменить его. When in Faces selection mod, right-clicking a face and choosing Lift Material Under Cursor from the drop-down menu will make it the active material.

  • Ctrl+M - Lift material under the cursor and make it the new active material
  • Shift+T - Применить действующий материал к выделенному полигону

Assets Tabs

Assets Tabs.

Similar in setup to the Asset Browser, this contains tabs for each of the various types of pieces of content used to create a map: Materials, Decals, Models, Particles, Prefabs, and Selection.

Tip:Any of the viewports can be changed to the Asset pane by clicking the drop down button in the top right of any given viewport.

Полезные настройки

  • Tools -> Options -> View 3D
    • Backplane Distance: Change this value to adjust how far map geometry renders in the 3D viewport. This can help with rendering performance in large complex maps.
    • Forward Speed Max: Adjusts how quickly the camera moves through the 3D viewport.
  • Toggle Grid Navigation Preview: Displays Dota 2's navigation grid inside of Hammer highlighting pathable and unpathable regions.
  • Tools -> Options -> Key Bindings can be used to see a list of all Hammer commands
    • Note: This only shows commands that have hotkeys associated with them.
    • Use the filter field to search for a particular context (e.g. "ToolSelection") or a particular command (e.g. "merge").
  • F1 will open a help menu that shows all the command categories.
    • RMB -> All Commands does the same as above.
    • Either search through the categories or use the filter field to search for a command.


Next: Basic Construction