Hammer: Меню инструментов

From Valve Developer Community
< Ru
Jump to navigation Jump to search
English (en)Deutsch (de)Русский (ru)中文 (zh)Translate (Translate)
Info content.png
This page needs to be translated.
This page either contains information that is only partially or incorrectly translated, or there isn't a translation yet.
If this page cannot be translated for some reason, or is left untranslated for an extended period of time after this notice is posted, the page should be requested to be deleted.
Also, please make sure the article complies with the alternate languages guide.(en)
Меню инструментов редактирования

Carve (Вычесть) Ctrl+⇧ Shift+C

Warning.pngПредупреждение: The Carve operation will carve all objects that touch the selected carving object. Make sure that only objects that you wish to be affected touch the carving object. The below information is purely for educational purposes to detail how the carve tool functions, but it should be strongly advised that carving brushes will produce messy geometry, including: invalid faces, invalid brush volumes, and possibly corrupted brushwork. The carve tool is a relic from the Quake 1 Engine when designers and artists did not have the realtime budget to utilize what we now refer to as displacements and high poly models. The carve tool was intended to solve tedious types of geometry problems such as caves or intricate interconnecting brushwork. Vertex editing is cleaner, and improved; thus, this site strongly advises against the use of the carve tool! If you find yourself making intricate brushwork, you should reevaluate if the geometry would be easier solved as a static mesh or a displacement.
Tip.pngСовет: Admer456 has an exhaustive tutorial on GameBanana which covers how to manually carve without the carve tool, as well as how to properly use carve without creating invalid and/or ugly brushes. Basically, only use carve when the resulting shape is still convex, and doesn't need to be split into multiple brushes (as the splitting into convex pieces is what causes the unoptimized brushwork).

This will take the selected object and carve its shape out of any surrounding objects that intersect it. You can have more than one carve object selected at once, and they will each carve the surrounding solids. For more information, see Reshaping solids(en).

Make Hollow (Короб) Ctrl+H

Opens the Make Hollow(en) dialog, which takes a selected object and generates walls out the shape, making it a hollow room.

Group and Ungroup (Группировать и Разгруппировать) Ctrl+G и Ctrl+U

Using Group on selected objects will bind them together so they may be acted upon simultaneously. For purposes of selecting and transforming, the grouped objects will act as one single object. You can edit the objects separately if you Ungroup them, or use the Toggle group ignore button on the MapOperations toolbar. Note that using Group is not the same as VisGrouping, which controls object visibility.

For more information on grouping, see Grouping and VisGrouping(en).

Tie to Entity (Превратить в объект) Ctrl+T

This command converts a solid (world) object into an entity type object so it can be given parameters that affect gameplay. When you tie an object to an entity, the Object Properties(en) dialog will pop up with a list of all available brush entities. The entity can be made up of several objects at once – simply select multiple objects before you perform the command, and all the selected objects will be a part of the entity. Objects can also be added to an existing entity by selecting the entity and the objects you will to add, and performing another Tie to entity command. You can also join two entities together in a similar way. See Entity creation(en) for more information.

Move to World (Превратить в элемент) Ctrl+⇧ Shift+W

The Move to world command converts an entity object into a non-entity world object, and strips all entity properties from it. The command can be used to convert multiple selected entity objects at once.

Note.pngПримечание: This command will not work when the 'Solids' selection mode(en) is active.

Texture Application (Применить текстуры) Ctrl+A

This will switch the current tool to the Texture Application Tool, and bring up the Face Edit(en) dialog box. These tools are used to edit texture properties of objects on a per face level. The Face Edit dialog also provides access to the displacement geometry tools.

Replace Textures (Заменить текстуры)

This will bring up the Replace Textures(en) dialog which allows you to search, mark, or replace all textures of a certain type.

Texture Lock (Блокировать текстуры) Ctrl+L

This option toggles Texture lock mode on and off. Texture lock allows you to move a brush without disturbing the alignment of the texture on the object. With Texture lock disabled, if you move an object, the texture stays aligned with the original position of the object.

Tip.pngСовет: There are times when it is easier to resize or move an object to fit the current texture alignment instead of the other way around. In this case, disable Texture lock, move the object to fit the texture, then enable Texture lock to move the object with the texture aligned.

Sound Browser... (Обзор звуков) Ctrl+⇧ Shift+S

Opens the Sound Browser(en) dialog, which provides a listing of the available sounds in the game.

Transform (Трансформация элемента) Ctrl+M

This brings up the Transform(en) dialog, allowing you to rotate, scale, and move an object with precise values in any of the X, Y, or Z planes.

Snap Selected to Grid (Привязать к сетке) Ctrl+B

Not all objects will align perfectly to the grid, due to moving or resizing of the objects or changes in the grid size. This command will snap the bottom and left sides of the object to the grid. If more than one object is selected, the command will use the lowest to the bottom and leftmost objects to align all the objects as a single group.

Snap Selected to Grid Individually (Привязать к сетке отдельно) Ctrl+⇧ Shift+B

Identical to Snap Selected to Grid, except that each object in the selection is snapped to the grid on its own, instead of using the bottom and left edges of the group bounding box.

Center Origins (Центрировать метки объектов)

For entities with origin entity helpers, this command moves the origin helper back to the center of the object bounding box. Multiple objects can be selected, and the origin helper of each object will be moved to the center of that object.

See the Show Helpers(en) command on the View Menu for more information about entity helpers.

Align objects (Выровнять элементы)

The Align objects sub-menu allows you to align objects to one another, similar to the Snap selected to grid command, but with additional options as to how the objects are aligned.

Hammer alignobjects.png

Objects can be aligned on their left, right, top, or bottom edges. The object that is farthest in the direction you wish to align stays stationary, and all the other objects are moved to align with that object’s edge. Also, the direction the objects are aligned is relative to the active 2D view.

To align a set of objects:

  1. Select the objects you wish to align in the 2D view you wish to align them.
  2. Select the direction you want the objects to align from the Align objects sub-menu in the Tools Menu. Remember the direction is relative to the current active 2D view.
  3. The objects will be aligned in the direction you chose.
Using the Align Objects command to align a set of object along their left edges.


Flip Objects (Отразить элементы) Ctrl+L и Ctrl+I

The Flip objects sub-menu allows you to flip objects horizontally or vertically (or both, to mirror the object).

Hammer flipobjects.png

You can mirror multiple objects at once. A single object is mirrored about its center point, and a group of selected objects are mirrored about their common center point. Also, the direction the objects are mirrored is relative to the active 2D view.

To mirror an object or set objects:

  1. Select the objects you wish to mirror in the 2D view you wish to align them.
  2. Select the direction you want to flip the objects from the Flip objects sub-menu in the Tools Menu. Remember the direction is relative to the current active 2D view.
  3. The objects are flipped in the direction you chose.
Using the Flip Objects command to Flip an object horizontally.


Create Prefab (Создать заготовку) Ctrl+R

Creates a Hammer prefab(en) object out of the selected objects. Hammer opens a Save As... dialog open in the Hammer prefabs directory. Type in a name and click the Save button to add the prefab to the library.

See prefab(en) for more information.

Options... (Параметры)

This will bring up the Options(en) dialog box which allows you to modify a number of Hammer Editor behaviors.