Hammer Map Operations Toolbar

From Valve Developer Community
Jump to: navigation, search

Hammer mapoperationstoolbar.png


Hammer carveicon.jpg Carve

When the Carve button is pressed, the selected brush will subtract its shape from the non-selected brushes around it. See Carve, under the Tools Menu, for more information.

Hammer groupicon.jpgHammer ungroupicon.jpg Group/Ungroup

Group/Ungroup binds two or more objects together so they may be acted upon simultaneously. See Group, under the Tools Menu, for more information.

Hammer ignoreicon.jpg Toggle Group Ignore (CTRL+W)

Group Ignore allows you to modify individual brushes that are part of a group or entity by temporarily bypassing all object groups. All selection commands work as if there are no groups defined. The Group and Ungroup commands may or may not function while in this mode, depending on how the Allow grouping/ungrouping while Ignore Groups is checked. This option is set in the General Options dialog box. Some commands, such as Tie to Entity, will remove objects from their groups if they are used in this mode. Also see Grouping and VisGrouping for more information on Grouping.

Hammer hideselectedicon.jpg Hide Selected

Creates a new VisGroup with the selected objects and hides it. See Hide Selected, under the View Menu, for more information.

Hammer hideunselectedicon.jpg Hide Unselected

Hides all unselected objects. Identical in function to the Hide Selected function, but applies to all unselected objects. See Hide Selected, under the View Menu, for more information.

Hammer quickhideicon.jpg QuickHide Objects (H)

Temporarily hides the selected object without placing it in its own Visgroup

Hammer quickhide unselectedicon.jpg QuickHide Unslected Objects (Ctrl+H)

Temporarily hides every other visible object except for the selected object

Hammer unhide quickhideicon.jpg Unhide QuickHide Objects (U)

Unhides every Temporarily hidden object

Hammer showallvisgroupsicon.jpg Show All VisGroups

This command will make the all hidden objects visible, including VisGroups. This button’s function is identical to the Show Hidden Objects command, under the View Menu.

Hammer cuticon.jpgHammer copyicon.jpgHammer pasteicon.jpg Cut, Copy, Paste

Performs Windows clipboard operations on the selection. See Edit Menu, for more information.

Mo-togglecordon.png Toggle Cordon State

This function will toggle the visibility and effect of a cordon area you have created with the Edit Cordon Bounds tool. See Cordon Usage for more information.

Mo-editcordon.png Edit Cordon Bounds

This function allows you to create a Cordon in order to test compile a smaller section of the map. See Cordon Usage for more information.

Radius culling.png Radius Culling (C)

Creates a sphere around your location in the 2D viewports showing the maximal visible area in the editor. Increase or decrease the clipping plane in the 3D viewport to adjust its radius.

Hammer toggleselectbyhandlesicon.jpg Toggle Select-By-Handles

When this option is toggled on, you will only be able to select objects by their center "x" handles in the 2D view. This is a shortcut – see Selection box selects by center handles only in the 2D views tab of the Options dialog box for more information.

Hammer toggleautoselectionicon.jpg Toggle Auto-selection

When Toggle Auto-selection is toggled on, you can select multiple objects by simply clicking your mouse button and dragging a selection box around the objects. When this option is toggled off, multiple objects are selected by dragging a selection box around the objects and then pressing ENTER. This is a shortcut to the Automatic infinite selection in 2D windows option in the 2D views tab tab of the Options dialog box.

Hammer aligntoworldfaceicon.jpg Align to World/Face

This button toggles the texture alignment style between world alignment and face alignment. World alignment will align textures according to the world grid coordinates. Face alignment will align textures according to the brush face.

Hammer displacementmaskicon.jpg Displacement Mask

Turns off the display of the non-displacement sides for a brush that contains displacement surfaces. See Face Edit Displacements for more information.

Disp.PNG Dis- & Enable Displacements

Dis- & Enable Displacements .

Hammer displaywalkableicon.jpg Display Walkable

Highlights surfaces in yellow if the angle of the surface is too steep for the player to walk up it.

Hammer displacementedgecollapseicon.jpg Displacement Edge Collapse

Turns off the display of the vertices that are collapsed when two displacements of different resolutions are connected via a Sew command.. or a brush that contains displacement surfaces. See Face Edit Displacements for more information.

Hammer texturelockicon.jpg Texture Lock

This button toggles texture lock mode on and off. Texture lock allows you to move or rotate a brush without disturbing the texture alignments.

Hammer texturescaleicon.jpg Texture Scale Lock

This button toggles texture scale lock mode on and off. Texture scale lock allows you to resize the texture with the brush. Use it in combination with Texture Lock to scale decals.

Hammer runmapicon.jpg Run Map!

This is equivalent to choosing Run Map from the File Menu.

Hammer showhelpersicon.jpg Show Helpers

Show the radius of certain properties in the views. See falloff distance.

Toggle models in 2d.png Toggle models in 2D

Turns the models wireframe in the 2D viewports on/off.

Toggle mode.png Toggle model fade preview

This option allows you to test a model's Start Fade Distance and End Fade Distance by using real-time fading in the 3D camera view.

Cm.png Show collision models wireframe

If "Toggle models in 2D" is activated, the collision models will shown up in the 2D viewports.

Hammer spriteenable.PNG Shows detail models/ sprites on materials

Dis- & Enable func_details and sprites on materials..

No draw toolbar.png Show nodraw faces

Dis- & Enable Nodraw Brushes on all viewports.