Exporting a model/XSI:ru

From Valve Developer Community
Jump to: navigation, search
English
Mod Tool logo

Эта статья покажет вам, как экспортировать модель из XSI Mod Tool для компиляции с помощью Studiomdl.

Чтобы узнать об общем использовании XSI, см. XSI Beginner Tutorial

Добавление текстуры и UV map

Для более полного изучения UV mapping, читайте XSI Texturing.
The 'Textures' dialogue.

В третьей группе левого меню(в режиме mod tool) вы найдете кнопку 'Textures'. Выделите mesh(es), кликните кнопку и в появившемся тулбаре выберите первую кнопку 'Image'(Get-material-phong-значек в виде вилки в правой части диалога напротив "color" в стандартном интерфейсе). Есть две части этого диалога, мы заинтересованы в: "Image -> New» и «Texture Projection -> New. The filename of the image you import into XSI defines the name of the VTF file Source will try to apply to the model in-game (though not its location). To avoid confusion, try to keep the texture name the same as the model name. If you don't want to worry about textures yet you can stick with XSI's default, but your model will be covered in Source's purple "missing material" checkerboard when you try to use it.

Next is the texture projection, or UV map. The XSI SMD exporter will decide what to export by looking at what has UV data rather than what is hidden and what is visible, even if the mesh is intended for collision, so don't forget this step!

Tip:The second and third sections of the Texture toolbar contain shortcuts for applying UV maps.

Отключение автоматического разрыва

Непонятно почему это необходимо - возможно это ошибка SMD экспортера. Тем не менее:

  1. Откройте 'Explorer'. Это можно сделать из меню View - General - Explorer, или нажав 8 на клавиатуре
  2. Разверните(значек"+") все meshes
  3. Вызовите окно параметров двойным кликом мыши по 'Geometry Approximation'
  4. Выберите 'no' в диалоге "Confirm make local" в ответ на предложение перед этим сделать локальную копию данных
  5. Выберите вкладку 'Polygon Mesh' в окне параметров
  6. Снимите флажок 'Discontinuity -> Automatic'

Вы увидите изменение освещения модели, когда снимете этот флаг. Warning: Пренебрежение изменением этого параметра приведет к тому, что все объекты сольются в один!

Замораживание(Freeze) трансформаций и истории

Если у вас есть, non-enveloped meshes, что говорит о том, что модель не анимирована, вы должны замораживать(Freeze) их до каждой операции экспорта. Enveloped meshes должны быть заморожены (Freeze) перед применением Envelope!

Замораживание фиксирует геометрию создавая ее из цепочек манипуляций с примитивами (такими как кубы или сферы с которых начиналась модель) в буквальное представление где каждый полигон имеет свои координаты. Так же, как отключение автоматического разрыва, то что это необходимо, кажется, не больше, чем ограничение экспортера XSI SMD; к сожалению, это мешает и может привести к ошибкам, если вы не будете осторожны.

Для заморозки, вначале выделите все ваши meshes. Затем кликните заголовок 'Transform', в правой колонке инструмментов, и выберите 'Freeze All Transforms', находящуюся сразу после первого разделителя. Затем кликните 'Freeze History -> Modeling' ('Freeze M' из раздела 'Edit' в самом низу той же колонки инструментов в стандартном интерфейсе).

Tip:Как вы догадываетесь, операций заморозки довольно много, и вы можете захотеть расположить кнопки в более доступном месте. Правый клик в любом пустом месте под заголовком 'Freeze History' и выбрать 'Customize toolbar'. Найти в списке 'Freeze All Transforms'(найти проще набрав на клавиатуре freeze) и перетянуть в меню.

Merge meshes

Если ваша модель имеет или будет иметь анимацию вы должны объединить всю ее геометрию в один mesh. Это позволит произвести экспорт в любом случае, но автоматизированная версия процесса уничтожает большинство данных envelope.

Выделите все и выберите "Mesh -> Merge" из меню слева. Это создает новый 'polymsh' объект, который содержит некоторые, но не все данные из существующих meshes. Чтобы объединить несколько последних частей информации откройте обозреватель кнопкой 8 и дважды щелкните на 'polymsh -> Polygon Mesh -> Merge Meshes. Найдите в нижней части нового диалога две кнопки 'Merge' и нажмите их, а затем нажмите кнопку 'Delete' в верхней части, чтобы удалить исходные meshes.

Экспорт SMD

Теперь ваша модель готова для экспорта в SMD. Диалог экспорта находится в основном меню - ValveSource -> Export SMD....

Tip:Снимите флажок 'Remove all unused bones' если вы экспортируете анимированную collision model. В противном случае, вы можете оставить флажки в покое.
Note:ValveSource add-on кажется, не работает с 64-битной версии XSI - кнопка Экспорт SMD отсутствует.

Компиляция!

Имея экспортированные reference mesh SMD и skeletal animation SMD, вы готовы к компиляции модели.