Создание энтити

From Valve Developer Community
Jump to: navigation, search
English


Энтити дают жизнь вашему уровню! Это монстры, двери, выключатели и лампочки, превращающие вашу статичную архитектуру уровня в динамичное окружение. Разумное использование энтитей очень важно для создания интересного, уникального и увлекательного уровня.

В отличие от геометрических примитивов, энтити не создаются в окне редактора Hammer. Большинство пользователей просто выбирают их из списка существующих энтитей. Как только вы выбрали нужную энтити, в редакторе Hammer вы можете изменить её расположение и другие свойства.

Существуют два типа энтитей: точечные и брашевые.

Точечные энтити существуют только в определённой точке. Например, источники освещения, монстры и игроки. (монстры и игроки делают определённые действия, но их действия в карте не изменишь. Они изменяются в игровом коде.) Некоторые точечные ентити являются обычными точками. Например, энтити env_beam, контролирующая лучевые эффекты, использует 2 точечные ентити как цели: вы помещаете 2 точки и луч света проходит между ними.

Брашевые энтити основаны на брашах для их материального существования на карте. Например, двери, платформы и другие двигающиеся объекты. Триггер - это другой тип брашевой энтити; он требует зону для активации, которая задаёт дальнейшие действия для триггера. Точечные энтити, основанные на модели, находящейся в файле на диске, отображаются движком.

Создание и размещение точечных энтитей

Выберите энтити, которую хотите поместить на уровень, используя панель инструментов "New Objects"

Чтобы создать точечную энтити, проделайте следующие действия:

  1. Выберите инструмент Entity Tool.
  2. В панели инструментов New Objects, выберите энтити из списка "Objects".
    Примечание:В окне "New Objects" отображаются только точечные энтити. Чтобы узнать, как создать брашевую энтити, перейдите к следующему разделу.
  3. Щёлкните по окну проекции и выберите нужную позицию для точечной энтити с помощью мыши. Ещё можно щелкнуть по по поверхности примитива в трехмерном виде, и в том месте появится новая энтити.
  4. Нажмите клавишу Enter и вы создатите новую энтити.
  5. Если нужно, то откорректируйте местоположение энтити в двухмерных и трехмерных видах.
  6. Если нужно изменить параметры энтити, выберите пункт Properties в меню Edit
Совет:
Для выбранного объекта можно вызывать меню Object Properties с помощью нажатия клавиш Alt+Enter.


Создание брашевых энтити

Select an entity for the solid from the Class list in Object Properties dialog.

Брашевые энтити более сложны чем точечные, но не должны представлять трудности, как только Вы узнаете их основы.

  1. Создайте браш, где бы вы хотели создать эту брашевую энтити. Вы можете использовать столько брашей, сколько вам надо, при создании этой брашевой энтити.
  2. Выберите весь объект.
  3. Выберите "Tie to Entity" в меню Tools Menu или нажмите горячую клавишу Ctrl+T. Это превратит, выбранные объекты в брашевую энтити.
  4. В Окне Object Properties выберите соответствующую энтити из поля списка "Class". Как только тип энтити выбран, вы можете изменять нужные вам свойства этой энтити.


Brush-based entities are a bit more complicated than point-based entities, but should not pose any difficulties once you know their basics.

  1. Create a brush where you would like it. You can use as many brushes as you'd like when building a brush-based entity.
  2. Select the entire object.
  3. Select "Tie to Entity" from the Tools Menu, or press the Ctrl+T shortcut. This will turn the selected objects into a brush based entity.
  4. In the Object Properties dialog, select the appropriate entity from the "Class" list box. Once the entity type is selected, you can modify the entity properties as needed.
Совет:
Так же, как и для точечных энтити, можно вызывать меню "Object Properties" с помощью нажатия клавиш Alt+Enter.


Заметьте, что брашевые энтити выделяются другим цветом в 2D окнах, обычно фиолетовым.

You will notice that brush-based entities appear as a different color in the 2D windows, typically purple.

Combining solid entities

Multiple solid entities can be also combined into a single entity:

  1. Select the entities or brushes you wish to combine.
  2. Select "Tie to Entity" from the Tools menu, or press Ctrl+T.
  3. A dialog will open with a list of entities in the current selection. Choose which of the entities you wish to keep for the final, combined entity. Select one of the entities, and that entity will also be highlighted in the 2D and 3D Views. Click "OK" to confirm your choice.
  4. The Object Properties dialog will appear, allowing you to change the parameters for the combined entity.

Using entities

Once an entity has been made, it can be controlled through the Entity I/O system. This system controls how entities interact with each other to make the game.

См. также