Entity Creation

From Valve Developer Community
Jump to: navigation, search
Русский 日本語

Entities are the monsters, doors, switches and lights that turn your static architecture into an interactive environment. The available selection depends on the game for which you are mapping.

This article covers how to add them to your map.

Point entity placement

Select an entity to place using the New Objects toolbar.

Placement of point entities is simple:

  1. Select the Entity Tool or press Shift+E.
  2. From the New Objects toolbar, select the entity you want from the "Objects" selection box (which supports text search). If you can't find what you want in the list, it may be a brush entity.
  3. Click in a 2D window, then position the entity cursor with the mouse. You can also click on a brush surface in the 3D view, and the point entity will be created there.
  4. Pressing Enter will create the entity.
  5. Fine tune the entity position in the 2D and 3D views.
  6. Choose Properties under the Edit menu if you wish to edit the entity parameters.
Tip:You can also use the shortcut Alt+Enter to open the Object Properties dialog box for the current selection.

Brush entity creation

Select an entity for the solid from the Class list in Object Properties dialog.

Brush entities are a bit more complicated than point-based entities, but should not pose any difficulties once you know their basics.

  1. Create a brush, or as many as you like.
  2. Select everything you want to form the entity.
  3. Select "Tie to Entity" from the Tools Menu, or press the Ctrl+T shortcut. This will turn the selected objects into a brush based entity.
  4. In the Object Properties dialog, select the appropriate entity from the "Class" list box. Once the entity type is selected, you can modify the entity properties as needed.
Tip:You can access the Object Properties dialog for a brush-based entity the same way you do for a point-based entity: select it and press Alt+Enter. This will not work when the selection mode is "Solids"!

You will notice that brush-based entities appear as a different color in the 2D windows, typically purple.

Combining solid entities

You can add new brushes to an existing brush entity, even if they are already tied to another one:

  1. Select the brushes you wish to combine.
  2. Select "Tie to Entity" from the Tools menu, or press Ctrl+T.
  3. If you have selected more than one brush entity a dialog will open with a list of them to choose from. Select the one you wish to keep for the final, combined entity (it will be highlighted in the 2D and 3D Views when selected) and press OK.

The Object Properties dialog will then appear, allowing you to change the parameters for the combined entity.

Using entities

  • You can move and rotate entities in the same manner as brushes. But you can't resize point entities.
  • Entities can be manipulated when the map is running with the I/O system.
  • You can change which type of entity each entity is at any time. KeyValues shared between the first and second types will be preserved.

See also