创建模型

From Valve Developer Community
Jump to: navigation, search
English

所有Dota 2 Workshop Tools模型需要从一个由3D编辑包导出的网格文件开始。Dota 2 Workshop Tools支持FBX ,OBJ和DMX文件格式。

创建一个模型资源

下面是一些关于怎样把你创建的模型导入到模型编辑器的小例子:

从网格开始

使用现有的网格文件创建模型:

  1. 启动 模型编辑器
  2. 打开 文件(File) 菜单,选择 从网格文件创建新的VMDL(New VMDL From Mesh File)
  3. 浏览网格文件。
  4. 一个新的模型编辑器工程将在视窗部分出现,和网格一同显示。
    • VMDL文件的名字由网格文件产生。例如,一个名称为“test.fbx”的网格会让模型命名为“test.vmdl”。如果网格拥有一个“_mesh”的后缀,则会去掉VMDL文件的名字。
    • VMDL文件会在目录作为新的网格被创建,除非网格在一个名为“dmx”或者“fbx”的目录中。如果是那样的情况,文件会储存在一个目录里。例如,一个存在models/test/fbx/test.fbx中的网格会使一个VMDL存在models/test/test.vmdl中。
  5. 添加碰撞几何形状时,选择主菜单栏的 模型(Model) > 碰撞(Collision)> 添加物理网格(Add Physics Mesh)
  6. 浏览一个碰撞网格。
  7. 预览(Display) > 碰撞体积(Collision Geo) 菜单项目,可以查看碰撞网格。

文件(File) > 新建(New)

在空白模型文件创建一个模型:

  1. 启动 模型编辑器
  2. 文件(File) 菜单,选择 新建(New)
  3. 命名新文件,并储存在当前游戏的目录文件夹中。
  4. 你会看到一个空白工程的模型编辑器。
  5. 选择 模型(Model) > 网格(Mesh) > 添加网格(Add Mesh) 来添加网格。
  6. 浏览网格文件。
  7. 网格在视窗中会显示出来。