Debugging Lua scripts:ru

From Valve Developer Community
Jump to: navigation, search
English

Начало

Отладчик Lua использует сборку Eclipse LDT.

Настройка отладки содержит следующие шаги:

  • Установка Eclipse LDT
  • Создание и настройка нового проекта
  • Настройка новой конфигурации отладчика
  • Открытие окна отладки
  • Подлкючение отладчика Eclipse LDT к игре

Установка Eclipse LDT

  • Скачайте Eclipse LDT со страницы: https://eclipse.org/ldt/.
  • Распакуйте содержимое архива в папку.
  • Из распакованной папки запустите исполняемый файл LuaDevelopmentTools.exe. Выберете папку для workspace(рабочее пространство), где Eclipse LDT будет хранить информацию о проектах.

Настройка нового проекта LDT

  • Нажмите File->New->Lua Project, чтобы открыть меню создания нового проекта
  • Задайте имя проекта
  • Во вкладке Contents, выберете "Create project at existing location...," и выберете директорию вашей карты dota2, например \Steam\steamapps\common\dota 2 beta\game\dota_addons\holdout_example_1.

Luanewproj.png

  • Нажмите Next. Eclipse LDT просканирует содержимое директории, это может занять некоторое время. Когда сканирование завершится, игнорируйте предупреждение "Your project has no source folder defined," и нажмите Finish.
  • Теперь в Script Explorerе можно открывать lua скрипты и ставить точки останова, два раза щелкнув на поле строки кода.

Breakpoint.png

  • Также рекомендуется включить показ номеров строк. Для этого нажмите Window->Preferences->General->Editors->Text Editors->Поставить галочку на строке Show line numbers.

Настройка конфигурации отладки для проекта LDT

  • Нажмите Run->Debug Configurations, чтобы открыть диалог конфигурации Debug Configurations
  • Выберете "Lua Attach to Application"
  • Нажмите "New launch configuration"

Luanewcfg.png

  • Задайте новое имя конфигурации
  • Установите "IDE key" на "server", или "client", чтобы запускать скрипт на сервере или клиенте, соответственно.
  • Установите в Timeout(s) большое значение.
  • Нажмите "Apply". Закройте диалог конфигурации Debug Configurations.

Luadebugcfg.png

Открытие режима отладки в LDT

Чтобы открыть режим отладки нажмите Window->Perspective->Open Perspective->Debug, либо щелкните на кнопку Debug в правом верхнем углу. Debug perspective.png

Подключение отладчика LDT к игре

  • Запустите игру и дождитесь запуска frame loop. Встроенный отладчик запускается только в течение frame loop, отладчик LDT может не дождаться ответа от встроенного отладчика игры, если это займет много времени.(поэтому и ставим большое значение time out в настройках)
  • Нажмите на иконку отладки(жук) и выберете Debug Configurations.

Luastartdbg.png

  • В диалоге Debug Configurations, выберете конфигурацию которую вы создали, и нажмите Debug. Для последующего быстрого запуска отладки, используйте иконку отладки(жук) и в меню выбирайте недавно использованную конфигурацию.
  • В консоли VConsole2 наберите "script_attach_debugger" для отладки сервера VM или "cl_script_attach_debugger" для отладки клиента VM. Для правильной работы убедитесь, что в конфигурации Debug Configuration задан правильный IDE ключ: "server" и "client" соответственно.

Гайд по отладчику LDT

По ссылке находится подробное руководство по отладке lua скриптов, использование точек останова, просмотр значений переменных и вычисление выражений.