Difference between revisions of "User Interface Bugs"

From Valve Developer Community
Jump to: navigation, search
(Current Known Issues in the Steam Beta UI)
(Current Known Issues in the Steam Beta UI)
Line 18: Line 18:
 
* All HL1-engine third-party mods are missing the last character from their name; Source Engine mods are not affected
 
* All HL1-engine third-party mods are missing the last character from their name; Source Engine mods are not affected
 
* Pause update from context menu, then launch game, context menu then says "Pause update" rather than "Resume update"
 
* Pause update from context menu, then launch game, context menu then says "Pause update" rather than "Resume update"
 +
* Starting up the SDK says "Prepairing to play the SDK".  Saying "Play" with a tool is.... weird.

Revision as of 22:03, 6 October 2005

Current Known Issues in the Steam Beta UI

  • Internet games tab in serverbrowser is slow with more than 1000 servers in the list.
  • Add a scrollbar in backup wizard when backing up more games than can fit on one page
  • Sometimes clickable menu items always appearing checked
  • Text wrapping issue on labels, some text still appears to be cut off by a pixel or two (purchase case)
  • Pausing preload of RDKF didn't appear to work, still kept downloading (as shown in pre-load status dialog)
  • Some machines show squares when drawing empty columns
  • Add delete app in context menu
  • Pre-order now button on preload dialog should minimize the preload dialog, currently hides store
  • Support button changes to minigameslist, after going to mini-games list once
  • Purchase summary dialog has list going off the bottom of the page
  • Purchase summary dialog has "Steam Account" and the account name wrapping when they shouldn't
  • 'purchasing...' progress dialog doesn't have much room on the bottom
  • no progress moving when installing games( 'creating cache files' )
  • first-time install says 'updating', not 'dowloading'
  • If you have an out of date video card driver and try to connect to a server via the serverbrowser the command line is incorrect
  • All HL1-engine third-party mods are missing the last character from their name; Source Engine mods are not affected
  • Pause update from context menu, then launch game, context menu then says "Pause update" rather than "Resume update"
  • Starting up the SDK says "Prepairing to play the SDK". Saying "Play" with a tool is.... weird.