Troubleshooting Modeling

From Valve Developer Community
Revision as of 03:39, 2 September 2005 by RumikoHoshino (talk | contribs) (about pink/black checkers problem)

Jump to: navigation, search

Trouble with Exporting

Trouble with Compiling Models

In-HLMV problems

I can't find my .MDL file
See model compile log, and check if the compile was successful.
My model won't show up in HLMV
Try wireframe mode. If you see your model in wireframe mode, it's possibly your texture that has a problem. See "My textures won't show up. It's just black" below. If you can't see anything in wireframe, open your reference .SMD with Notepad. Make sure it contains mesh information.
My model shows up, but size/shape is not right
Go back to the 3D program. If you are using XSI, freeze the model using Freeze and Transform > Freeze All Transforms commands. If you are using 3DsMax, apply the Reset XFrom modifier. Then export your .SMD and compile it again.
My textures won't show up. I see pink/black checkers.
If you see pink/black checkers, it means that HLMV couldn't find textures. There are two possibilities. Case one, .MDL's texture path is incorrect, so HLMV can't find .vmt files. Use Source MDL Texture Info and check your .MDL's texture path. Case two, HLMV could find .vmt, but .vtf texture path in .vmt is incorrect. This often happens when you have moved .vmt/.vtf file location. Open your .vmt, and check $basetexture value.
My textures won't show up. It's just black
Open .VMT file. If you use LightmappedGeneric, change it to VertexLitGeneric. LightmappedGeneric is for brush geometry, not for model geometry.

In-game problems

My model won't show up
Open the console, check the error log. Make sure your model is of the proper type (prop_physics, prop_static, etc.)