Difference between revisions of "Talk:VBSP"

From Valve Developer Community
Jump to: navigation, search
(Leafvis question)
(Leafvis causing a thin line where they end/meet)
Line 18: Line 18:
 
== Leafvis causing a thin line where they end/meet ==
 
== Leafvis causing a thin line where they end/meet ==
 
Been having this problem where I get these lines in geometry where visleafs are ending or meeting another leaf. As I move closer to the "line" it disappears, but at a distance it is quite noticeable. Is there some fix for this? Screen with arrow showing an example: [http://i.imgur.com/1Lt1n.jpg Screen] A strange bit of information: If I disable AA for the game, the lines go away, but it seems isolated to this one map and does not occur on other maps.  --[[User:RTF|RTF]] 00:37, 28 February 2011 (UTC)
 
Been having this problem where I get these lines in geometry where visleafs are ending or meeting another leaf. As I move closer to the "line" it disappears, but at a distance it is quite noticeable. Is there some fix for this? Screen with arrow showing an example: [http://i.imgur.com/1Lt1n.jpg Screen] A strange bit of information: If I disable AA for the game, the lines go away, but it seems isolated to this one map and does not occur on other maps.  --[[User:RTF|RTF]] 00:37, 28 February 2011 (UTC)
 +
"I've noticed this quite a bit myself. It actually seems to be related to lightmap scales in my tests, however as far as I've seen, there is no real fix for the situation, aside recreating the brush itself, or changing how vbsp is cutting a visleaf at that exact location.--[[User:MrFourVideoCards|MrFourVideoCards]] 03:00, 28 February 2011 (UTC)

Revision as of 03:00, 28 February 2011

I'm sure it's been asked before, but whatever happened to the distributed compiling of maps? --AndrewNeo 13:58, 6 Jul 2005 (PDT)

Why did my Vbsp.exe try to use my internet connection when compiling just now?? --Andreasen 20:44, 18 Mar 2006 (PST)

Tested the four "new" options, and vBSP no longer recognizes the linux options. --Demented 14:42, 6 Aug 2006 (PDT)

Orange Box Version not working for mods?

Hey. I've been trying to compile the maps for my mod under the Ep2 VBSP but it doesn't seem to work correctly. When -game points to any custom folder containing a valid GameInfo.txt, vbsp fails to successfully mount HL2 content. It sprews out "Materials not found!:" for all materials used in the map, including and not limited to Tool Textures as well. (Skip, Nodraw, Trigger, everything). It also fails to load the models and thus doesn't place any in the map. As it doesn't know which textures are tool textures, all tool textures are left in the map as solid geometry. I tried compiling for the raw Ep2 and that works, yet if I move the Ep2 GameInfo.txt to any other directory and -game to that directory, it fails. Are any other developers for the Ep2 engine using mods having trouble too, or am I the only one? Or does anything know how to fix this? --Sortie 13:51, 15 Jun 2008 (PDT)

You will need to run it through Hammer. --TomEdwards 14:05, 15 Jun 2008 (PDT)
I see. Hammer-based compiles are just much slower, I prefer to batch compile. Edit: You're right, after some haxing I got the compiling working inside Hammer only. Even though running the same command via a command promt doesn't work. I really want Valve to fix this, anyone know who/where to report such an issue? --Sortie 06:47, 16 Jun 2008 (PDT)
It's known already. --TomEdwards 09:38, 16 Jun 2008 (PDT)

Link

"Can cause memory leaks on Windows with out applying the patch code to your mod found at SDK_Known_Issues_List"
I could not find this issue. Can someone please add a #subheading to the link so no one else has trouble?
--Bit Mage 03:18, 7 July 2009 (UTC)

Leafvis causing a thin line where they end/meet

Been having this problem where I get these lines in geometry where visleafs are ending or meeting another leaf. As I move closer to the "line" it disappears, but at a distance it is quite noticeable. Is there some fix for this? Screen with arrow showing an example: Screen A strange bit of information: If I disable AA for the game, the lines go away, but it seems isolated to this one map and does not occur on other maps. --RTF 00:37, 28 February 2011 (UTC) "I've noticed this quite a bit myself. It actually seems to be related to lightmap scales in my tests, however as far as I've seen, there is no real fix for the situation, aside recreating the brush itself, or changing how vbsp is cutting a visleaf at that exact location.--MrFourVideoCards 03:00, 28 February 2011 (UTC)