Difference between revisions of "Talk:Source SDK Known Issues"

From Valve Developer Community
Jump to: navigation, search
(Faceposer)
(HLMV)
Line 70: Line 70:
 
*According to the combo box, the default view is BoneWeights. It isn't, of course.
 
*According to the combo box, the default view is BoneWeights. It isn't, of course.
 
*Normal mapping is off by default, on my system. Very annoying.
 
*Normal mapping is off by default, on my system. Very annoying.
 +
*All mods built after update show only single player animation sequences in HLMV.
  
 
===Faceposer===
 
===Faceposer===

Revision as of 21:56, 11 August 2006

Community bugs

Bugs found after the august 2006 sdk update.


General/launcher

  • No access to Episode One assets from the tools. Mossman and Alyx can only be viewed in their HL2 versions, and Zombine, the core ball and other such new assets including textures and sounds aren't visible at all. Occurs with the SDK set to both SDK Base and Ep1 itself.
  • When launching the tools via the new -run<tool> switches, |gameinfo_path|. is not searched. This hides all custom mod content when launching from a shortcut. Launching from the SDK menu is not affected.
  • When creating a new singleplayer mod, or setting the appid from 220 to 215 for a singleplayer mod makes the game crash during startup after the valve logo with the error: Error could not load library client. While changing the appid back to 220 makes it work again.--Bluestrike 04:24, 5 Aug 2006 (PDT)
This is because you have the wrong SearchPaths. See Talk:Source SDK Base#SearchPaths. --TomEdwards 04:26, 5 Aug 2006 (PDT)
Ah thx, but they still need to fix it for when creating a new singleplayer mod since its using the new appid but not the updated seachpaths. Also I don't get the "new game" button this way and would like to get rid of the stress test.--Bluestrike 04:37, 5 Aug 2006 (PDT)
See on this page. --TomEdwards 05:20, 5 Aug 2006 (PDT)
Don't see the relevance :), when creating a singleplayer mod the gameinfo has the updated appid, but not the updated seachpath, so I'm just saying that should be fixed so new people creating a singleplayer mod get something that works :)--Bluestrike 14:31, 6 Aug 2006 (PDT)
  • There is no link to vconfig.
  • vconfig crashes on launch with a steam.dll error.
  • There is no mapsrc for episodic or sourcetest. Equally, all of the sample maps are extracted to the hl2 folder.
They haven't released any sourcefiles for episode one by by knowledge so there is should not be any sourcefolders for it either.--Bluestrike 04:14, 6 Aug 2006 (PDT)
  • We now can build hdr maps and have the hdr code, but still need the splitter tool required to makde hdr skyboxes.--Bluestrike 04:14, 6 Aug 2006 (PDT)
  • I get this error: Attempted to create unknown entity type env_tonemap_controller! Can't init env_tonemap_controller or should I post this at #Source_SDK_Base Hdr is working, just not the custom values I want because the tonemap entity isn't recognised--Bluestrike 14:31, 6 Aug 2006 (PDT)
Same issue here. The env_tonemap_controller exists in the fgd, but it doesn't have any properties I can set. Our mod includes the base.fgd and I can see the entries for env_tonemap_controller in base.fgd, but nothing shows up in Hammer. -- Defrag 17:02, 10 Aug 2006 (PDT)
  • When typing in the console, possible commands appear on a dropdown window, but clicking on the one you need with the mouse no longer works, instead you have to type the whole command now. --Bluestrike 14:34, 6 Aug 2006 (PDT)
You can use the arrow and return keys to use the list until this problem is fixed. --TomEdwards 14:36, 6 Aug 2006 (PDT)
  • Short period of "Copying files" dialogue on each load
  • The launcher frequently deletes custom game configs.

Source SDK Base

  • The menu system is not currently working as it should. Using Source SDK Base gives the Video Stress Test/Options/Exit menu, which isn't very helpful. Modders have to copy over various script files to get a functional menu, and even that isn't enough sometimes. A system that reads type from gameinfo.txt and displays the appropriate menu would be great.
  • There is no way to hide the commentary option in the New Game dialog without hacking it to appear outside the dialog's borders. Seeing as it's fair to say that most modders won't be using commentary, this is a fairly large issue. Could Source not check for the existence of *_commentary.txt before showing the option?
    • When you do use commentary, the background texture for the checkbox and label is missing.

Hammer

  • The new View menu option 3D Lighting Preview apparently doesn't work, instead filling the camera view with the black and pink checkers.
Probably won't be usable until Ep2 and the new lighting model. --TomEdwards 03:15, 7 Aug 2006 (PDT)
  • SDK Base loads only base.fgd, which makes sense, but Hammer does not inform users of the need to add the relevant FGDs themselves.
  • Crash when maximising Hammer after a period of minimised inactivity.
  • Hammer has difficulty running games post-compile. It returns an error about being unable to load filesystem_steam.dll when I try with SDK Base, and loads Ep1 with HL2's script files.
  • Corruption when viewing overlays.
  • Unable to load the cs_militia sourcemap (or it takes insane amounts of time but so far I only got a grey and 3 black windows --Bluestrike 05:58, 5 Aug 2006 (PDT))
I've encountered this too. --RDB 14:23, 5 Aug 2006 (PDT)
Me too; in fact, I've yet to hear from anyone who can load it :P -- Defrag
  • When changing from the logic view to a 3d view the screen stays black, Have to select a object and use ctrl+shift+e to be able to view the map.--Bluestrike 05:58, 5 Aug 2006 (PDT)
It appears there is no longer a default camera for the 3D window. One must be created (or ctrl-shift-e must be used) before anything appears in a 3D window. —BJ(talk) 10:46, 5 Aug 2006 (PDT)
Confirmed. I tried slicing the entire map up with huge brushes, and they didn't register in the camera view, so it's not just simply moved to somewhere else in the map, which was my first thought. --Andreasen 02:40, 7 Aug 2006 (PDT)
  • Func_door_rotating act as func_rotating ingame (object doesn't stop spinning)--Bluestrike 05:58, 5 Aug 2006 (PDT)
  • The buggy now starts without its weapon attached (any workarounds?)--Bluestrike 05:58, 5 Aug 2006 (PDT)
Possibly Ep2-related, if that helps anything. --TomEdwards 07:58, 5 Aug 2006 (PDT)
  • Hammer game-launch option (apparently) no longer functions. Simply crashes (i.e., closes without indicated error). Restarting Hammer reports previous incorrect closure - asks if to reload last map. EDIT: problems appear to be resolved by restarting windows. —BJ(talk) 11:14, 5 Aug 2006 (PDT)
  • New npc_citizen entities default to Alyx's model and are armed with Alyx's gun.
  • Hammer crashes always when closing it (after long sessions)--Bluestrike 04:14, 6 Aug 2006 (PDT)
okay now hammer just 'disapeared' for the 2nd time in a hour without any messages. --Bluestrike 05:33, 7 Aug 2006 (PDT)
I've also encountered the magical disappearing Hammer today. It closed itself with no warning or errors. -- Defrag
Hammer crashes when opened from being minimised to task bar, happens every time for me. -- gingerLord
OK here's a reproducable one (at least for me). Select multiple brushes and go into vertex mode. Drag select around a line of handles and merge some vertices (merging multiple vertices on multiple brushes simultaneously) then exit vertex mode. It will bomb out every time without an error. -- Defrag 14:31, 9 Aug 2006 (PDT)
  • env_tonemap_controller is a checkerboard sprite --Bluestrike 04:38, 6 Aug 2006 (PDT)
  • Displacements now let ragdolls and all physics objects clip straight through them, rather annoying --gingerlord 14:19, 6 Aug 2006 (BST)
Check the displacement properties -- they now have flags associated with physics and regular collisions -- Defrag
Checked, although I'm guessing its due to my mod not running new code, fresh SDK code install and map has no problems, but newly compiled maps with old code have problem. All boxes are unticked -- gingerlord
Jinto from the Garry's Mod Forum has found a fix for this issue. Temporary Displacement Collision Fix --TheIdiot 03:07, 10 Aug 2006 (PDT)
Using -novirtualmesh is fine for legacy game DLLs. Running without it is preferable will game DLLs compiled using the latest SDK code; it results in smaller BSP files too. -- Jay Stelly
  • Textures from .svn (of course you need to be using TortoiseSVN for this) folders now show up in Texture Browser, had this problem occasionally before SDK update, now showing up constantly. --gingerlord 14:24, 6 Aug 2006 (BST)
SVN working copy versions of props and sounds also show up in the respective browsers. Very annoying. -- Defrag
  • Cubemap resolution has been upgraded, but the FGD still reports the old values in env_cubmap. 512x512 is actually 1024x1024, etc.
  • 'Use Visgroup colors for object lines' option is nonfunctional. Objects are always shown with their default colours.
  • Viewport label does not appear until mouseover. Gets confusing when you are trying to manipulat them sometimes.
  • The hammer model browser has the option to select a specific mod now, but you can't select any option with the mouse (using the up and down keys works).--Bluestrike 04:20, 7 Aug 2006 (PDT)
  • Using custom detailsprite textures in the worldspawn does no longer work. --Bluestrike 11:00, 10 Aug 2006 (PDT)
  • Texture lighting appears to be broken for me. vrad picks up lights.rad correctly and also reports that it has parsed the correct nunber of texlights, but the texture lights do not affect the lightmaps. Strangely enough, the viewmodel IS illuminated, so something is going awry related to lightmapping during rad. I've had a friend test this and the result was the same. -- Defrag 16:05, 10 Aug 2006 (PDT)

HLMV

  • Wireframe covers the model in the 'missing texture' checkerbox instead of showing wireframe.
  • According to the combo box, the default view is BoneWeights. It isn't, of course.
  • Normal mapping is off by default, on my system. Very annoying.
  • All mods built after update show only single player animation sequences in HLMV.

Faceposer

  • Faceposer crashes when I try to extract a wav in the phoneme editor, displaying a windows error. --Bluestrike 05:58, 5 Aug 2006 (PDT)
Confirmed. Perhaps it now uses a more recent speech API? --TomEdwards 13:06, 5 Aug 2006 (PDT)
  • Faceposer does not appear on the taskbar until it recieves focus.
  • Faceposer's interface can lose all of its icons. This happened some time ago for me and I've never been able to get them back.
  • Expressions: head tilt, head updown and head forwardback are not applied until a the sliders is moved by hand. This will show up if you select an Expression using one or more of those sliders immediately after starting Faceposer.
  • The global Event Tags and the gesture-only Timing Tags look idential.
  • Expression thumbnails are created without removing the 3D View's gestures/sequences. This can result in obscured images if the animation places limbs in front of the face.
    • Same problem when there are multiple actors in the 3D View.
  • The Animations dialogue lets you refresh all thumbnails. This is dangerous and will hang Faceposer and Steam if used on a model will lots of animations (e.g. Alyx). Should be removed or require confirmation.
  • When creating an Expressions event, expressions are duplicated two or three times each in the lower combo box.
  • Help > Goto Homepage still links to VERC. Should link to Category:Choreography, or another VDC page.
  • When pressing play while the scene is already playing, speech events from the first playthrough will continue, overlapping the second playthrough.
  • Clicking 'Edit <event> in <tool>' does not open the tool if it is closed.

Non-bugs

General

  • Changing the SteamAppId to 215 in our mod seems to enable the new engine (version 7, build 2803) but HDR is not functional. building cubemaps you can see that there is no tonemapping going on and I have noticed that certain HDR related console commands are missing (eg tonemap control and mat_forcebloom)
If your mod is using their own client.dll file its still using the old engine and the mods coders need to do their magic on it but I'm not a specialist on that matter tough :) but the hdr testmap worked fine in my sp mod --Bluestrike 07:06, 5 Aug 2006 (PDT)
You must merge the new SDK source code into your mod's DLLs to expose the game hooks. Maps must be compiled with HDR too, but I'll assume you're already doing that. ;-) --TomEdwards 07:08, 5 Aug 2006 (PDT)
Thanks for the help, im sure our coder is going to be very pleased about having to do that :P

Discussion

The shortcut fix doesn't work for me. Hammer loads and everything appears to be fine, but all of my mod's materials aren't displayed properly. HL2 resources are displayed as normal. -- Defrag

What game is the SDK set to? --TomEdwards 07:58, 5 Aug 2006 (PDT)
This Hammer shortcut method still works for me, for each game mode. --wisemx 08:06, 5 Aug 2006 (PDT)
Doesn't work here. I get the "steam.dll not found" error message that occurs when using a standard shortcut; that is, right-clicking on hammer.exe -> create shortcut. --RDB 14:41, 5 Aug 2006 (PDT)
OK, I've hit the problem and it's a bug when launching the tools with the new shortcut switches. I've added it as a bug. You'll have to launch through the GUI menu for now, or use wisemx's solution. --TomEdwards 08:26, 5 Aug 2006 (PDT)
  • Can't find this page using the search box, are talk pages ignored by it? In that case should we make a dedicated page for all these bugs?