Talk:Physics prop

From Valve Developer Community
Revision as of 14:39, 6 August 2018 by Blixibon (talk | contribs) (Created page with "== This is literally another name for prop_physics == <code>'''LINK_ENTITY_TO_CLASS( physics_prop, CPhysicsProp );'''</code> <code>LINK_ENTITY_TO_CLASS( prop_physics, CPhysi...")

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

This is literally another name for prop_physics

LINK_ENTITY_TO_CLASS( physics_prop, CPhysicsProp );

LINK_ENTITY_TO_CLASS( prop_physics, CPhysicsProp );

LINK_ENTITY_TO_CLASS( prop_physics_override, CPhysicsProp );

Not only that, but its classname is changed back to prop_physics after spawning:

if ( FClassnameIs( this, "physics_prop" ) )

{

SetClassname( "prop_physics" );

}

Why do we need an entirely different article for this, exactly?