Difference between revisions of "Talk:Installing and Debugging the Source Code"

From Valve Developer Community
Jump to: navigation, search
Line 1: Line 1:
'''Fresh installation, fresh errors'''
 
 
 
Im using a copy of Visual Studio 2005, freshly installed, nothing changed or edited. I just used the "Create a Mod" wizard and hit "Rebuild Solution" on the game_sdk.sln. Nothing compiles and i get tonnes of errors and even more warnings. On both Debug and Release configurations. What am i doing wrong?<b>[Kyle (SneakyNinja)]</b>
 
 
 
 
----
 
 
 
I am currently trying to find a way to build the SDK from the free Microsoft Visual C++ 2003 toolkit.  Any help/contributions from you or Valve would be most appreciated. '''[Big Ev]'''
 
I am currently trying to find a way to build the SDK from the free Microsoft Visual C++ 2003 toolkit.  Any help/contributions from you or Valve would be most appreciated. '''[Big Ev]'''
 
:You should stop while you're ahead. Look for '''Microsoft Visual Studio .NET 2003''' on eBay ;-) --[[User:Mark WiseCarver|wisemx]] 09:34, 13 Aug 2005 (PDT)
 
:You should stop while you're ahead. Look for '''Microsoft Visual Studio .NET 2003''' on eBay ;-) --[[User:Mark WiseCarver|wisemx]] 09:34, 13 Aug 2005 (PDT)
Line 39: Line 30:
  
 
One thing i have noticed here, if you do not see your hl2.exe in the specified working directory, you must simply run the game type you are trying to mod. So in teh case of the tutorial, just run HL2 after installing the SDK and your ready.
 
One thing i have noticed here, if you do not see your hl2.exe in the specified working directory, you must simply run the game type you are trying to mod. So in teh case of the tutorial, just run HL2 after installing the SDK and your ready.
 +
 +
== Fresh installation, fresh errors ==
 +
 +
Im using a copy of Visual Studio 2005, freshly installed, nothing changed or edited. I just used the "Create a Mod" wizard and hit "Rebuild Solution" on the game_sdk.sln. Nothing compiles and i get tonnes of errors and even more warnings. On both Debug and Release configurations. What am i doing wrong?'''[Kyle (SneakyNinja)]'''
 +
 +
:Maybe nothing. The SDK was created with an earlier version of Visual Studio. It's not at all unusual for things to break in this situation. I haven't tried it on VS2005 yet, and can't get to it this week, either, but hopefully someone else can. &mdash;'''[[User:Maven|Maven]]''' <sup>([[User talk:Maven|talk]])</sup> 15:48, 6 Dec 2005 (PST)

Revision as of 16:48, 6 December 2005

I am currently trying to find a way to build the SDK from the free Microsoft Visual C++ 2003 toolkit. Any help/contributions from you or Valve would be most appreciated. [Big Ev]

You should stop while you're ahead. Look for Microsoft Visual Studio .NET 2003 on eBay ;-) --wisemx 09:34, 13 Aug 2005 (PDT)
Not a bad idea Mark, I'll check out eBay. Also great HL2 tutorials page in your profile.[Big Ev]
Check out this. it should come with the full standard edition too -ts2do

I just installed the SDK for the first time, and tried to compile a new project just to make sure that everything worked. Of course, it didn't. :) client.dll compiled fine, but there were three link errors in the project for server.dll:

hl2mp_client.obj : error LNK2019: unresolved external symbol "void __cdecl Bot_RunAll(void)" ([email protected]@YAXXZ) referenced in function "void __cdecl GameStartFrame(void)" ([email protected]@YAXXZ)

hl2mp_gamerules.obj : error LNK2019: unresolved external symbol "class CBasePlayer * __cdecl BotPutInServer(bool,int)" ([email protected]@[email protected]@[email protected]) referenced in function "void __cdecl Bot_f(void)" ([email protected]@YAXXZ)

Debug_hl2mp/server.dll : fatal error LNK1120: 2 unresolved externals

The third error is pretty easy to understand. I was able to find the two function definitions for the first two errors, and noticed that the offending code for both was inside #ifdef DEBUG statements. Is the SDK not supposed to compile in debug mode, and only in release? Or is there something else that I missed? --ATimson 16:40, 17 Sep 2005 (PDT)

Yes, having a decent grasp of C++ and your compiler. --^Ben

filesystem_steam.dll causing crash

I had a problem starting a debug session when I went through this tutorial. I got an Unresolved Exception in filesystem_steam.dll. After some time, I figured out that you need to add "" to the path that follows the -game command argument, if the path contains spaces. In my case i had to set my command argument to -dev -sw -game "C:\Games\Valve\Steam\SteamApps\SourceMods\My Mod"

Hope this can help someone...

Debugging with multiple GCF's?

I find that I'm unable to debug unless I comment out all of my MountSteamContent's. It produces an error like Appid is 320 something something.

Once commented out it works fine but with obvious missing content.

Garry what up!!! lol—ts2do (talk) 12:39, 15 Oct 2005 (PDT)

Applying Debugging Options

One thing i have noticed here, if you do not see your hl2.exe in the specified working directory, you must simply run the game type you are trying to mod. So in teh case of the tutorial, just run HL2 after installing the SDK and your ready.

Fresh installation, fresh errors

Im using a copy of Visual Studio 2005, freshly installed, nothing changed or edited. I just used the "Create a Mod" wizard and hit "Rebuild Solution" on the game_sdk.sln. Nothing compiles and i get tonnes of errors and even more warnings. On both Debug and Release configurations. What am i doing wrong?[Kyle (SneakyNinja)]

Maybe nothing. The SDK was created with an earlier version of Visual Studio. It's not at all unusual for things to break in this situation. I haven't tried it on VS2005 yet, and can't get to it this week, either, but hopefully someone else can. —Maven (talk) 15:48, 6 Dec 2005 (PST)