Difference between revisions of "Talk:Configuring the Source SDK for Dreamball"

From Valve Developer Community
Jump to: navigation, search
Line 1: Line 1:
 
I'm am having an SDK problem relating to this game.  I can compile and run the sdk maps, but textures that come with DreamBall show up as black in the game.  For example, in the map '''sdk_checkpoints.vmf''', the red and blue dev textures show up as black in the game.  The ball shows up black when I testrun this map as well.  Only the skybox and the brush with the orange dev texture are not black. Does anyone know what the problem is?  I wanted to play with mapping for this, but I can't seem to solve this problem :(   
 
I'm am having an SDK problem relating to this game.  I can compile and run the sdk maps, but textures that come with DreamBall show up as black in the game.  For example, in the map '''sdk_checkpoints.vmf''', the red and blue dev textures show up as black in the game.  The ball shows up black when I testrun this map as well.  Only the skybox and the brush with the orange dev texture are not black. Does anyone know what the problem is?  I wanted to play with mapping for this, but I can't seem to solve this problem :(   
 
<br><br>'''Update:'''<br>
 
<br><br>'''Update:'''<br>
I finally figured out the problem after wasting all night on it.  lol.  It has to do with the compile manager program I'm using.  It wasn't using the "-game" commandline argument to tell the compile tools the game dir.  So the compile tools couldn't find any of DreamBall's custom textures.<br>--[[User:Font38|Font38]] 05:14, 17 September 2009 (UTC)
+
It appears to be a bug in VBSP or something.  It complains it can't find a couple tools textures too, like the tools/skybox texture.<br>--[[User:Font38|Font38]] 05:14, 17 September 2009 (UTC)

Revision as of 03:35, 18 September 2009

I'm am having an SDK problem relating to this game. I can compile and run the sdk maps, but textures that come with DreamBall show up as black in the game. For example, in the map sdk_checkpoints.vmf, the red and blue dev textures show up as black in the game. The ball shows up black when I testrun this map as well. Only the skybox and the brush with the orange dev texture are not black. Does anyone know what the problem is? I wanted to play with mapping for this, but I can't seem to solve this problem :(

Update:
It appears to be a bug in VBSP or something. It complains it can't find a couple tools textures too, like the tools/skybox texture.
--Font38 05:14, 17 September 2009 (UTC)