Talk:Common L4D Mapping Problems

From Valve Developer Community
Revision as of 22:02, 30 August 2010 by Ruanito (talk | contribs) (Hammer not working...)

Jump to: navigation, search

crash to desktop

I'm getting a crash to desktop with my new map. I am trying to test it, and it starts loading, but before the loading bar moves, it's dead. Any suggestions? --CorporalAris 04:17, 23 February 2009 (UTC)

If you're sure it's not the stringtables issue, I'd start with removing all the new entities that came with L4D and see if that fixes it. I've scene some of them (func_simpleladder, beam_spotlight, etc) cause random crashes before. --brandished 19:23, 23 February 2009 (UTC)
Wait, could this be the string tables crash? The map has already ran, and I didn't need to bother with it. I'll have to try that out first. --CorporalAris 12:27, 24 February 2009 (UTC)

It was the env_sun entity... --CorporalAris 20:29, 27 February 2009 (UTC)


crash to desktop: Reloaded

I am having an issue with a particular map; quite simply it loads to a point then crashes to desktop. Trying to load the map again results in a crash to desktop. There are no error messages or anything. I'm going to start looking for what is causing this, but if you have experienced something like this please tell me how to fix it.

Disregard - It turned out that there were an issue with a water brush. Once removed the map worked fine.--Alfonzo 02:21, 12 April 2009 (UTC)


Ladders

I am having issues making functional ladders--either for survivors or infected, though the one I'm working on at the moment is intended for infected. The sv_showladders command present in other source games isn't available in L4D, so I can only see my ladders in Hammer. I don't have a visible ladder object, but from what I understand that's not technically necessary. --Draco18s 22:15, 17 May 2009 (UTC)

Hammer not working...

I launch the "authoring tools", I then open Hammer Editor and it simply doesn't work... It freezes, uses 100% of my CPU and doesn't really open(it's there, but I can't use it, it's freezed)... Any idea? =] --Ruanito 22:02, 30 August 2010 (UTC)