Talk:Adding chapters to your mod

From Valve Developer Community
Revision as of 03:21, 17 December 2018 by Arrowing (talk | contribs) (I'm Having Some Issues: new section)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Hey, is there a limmit to the amount of chapters you can make? If i go over 32 then some come up missing in the game(4,5,6,7,8,9), im trying to get 38 Chapters. Thanks for any help:)

As far as I know, 32 chapters is the limit. If anyone knows of a way to expand this, please let me know!--Fitzroy doll 02:14, 15 May 2007 (PDT)

This article has been incredibly useful, thanks, but I've encountered a slightly strange problem with my single-player mini-mod. For some reason, the skill selection stuff has disappeared completely - any ideas on how I can get it back? My metastasis/resource folder contains ClientScheme.res and metastasis_english.txt, but I'm wondering if I need any other files in there. It's quite urgent, too... :-/ --Cargo Cult 01:44, 1 Sep 2005 (PDT)

Just sent you an e-mail about that. You've got to specify that it's a SP mod in gameinfo.txt. --TomEdwards 02:22, 1 Sep 2005 (PDT)
Ah, cheers. It's a bit obvious when you think about it!
For everyone else, I'll be making all the files available shortly, so it should be easy to convert my mini-mod into something new... --Cargo Cult 02:29, 1 Sep 2005 (PDT)
w00t w00t --Pon 02:37, 1 Sep 2005 (PDT)

Skucker - The problem with Textpad might just be the encoding you have it set on - when you do a 'save as', make sure that you have the right encoding and computer type setup. - RodeoClown 20:45, 25 Jul 2006 (PDT)

Hmmm...

When I load my mod, go into the chapter selection, and click to load the first chapter, it does nothing at all. Does anyone know how to fix my problem? --Flamozoid 11:09, 30 Dec 2006 (PST)

How does the mod know what map to start for that chapter? Did you specify that in the chapterX.cfg file? If you're still receiving errors, check the console for any spews.—ts2do 11:42, 30 Dec 2006 (PST)

Ok now It worked, but it loaded d1_canals_01 instead, crashed hl2, and now when I try loading my game it says "could not load library client..."--Flamozoid 12:48, 30 Dec 2006 (PST)

Nvm, Im good... --Flamozoid 13:09, 30 Dec 2006 (PST)

Other variables

If you specify anything besides the map name in the chapter#.cfg file, like so:

map chapter3_cheesecake1
cl_ragdoll_collide	1
sk_npc_dmg_stunstick	"4"
sk_headcrab_health	"300" //I never said this example was sensible

Well, would this work? And either way, would it carry over for the whole chapter, or would it revert back to the normal values the minute you went to the next map or loaded a saved game, as if you'd entered the commands into the console? And if it did carry over for the whole chapter, would it revert back to normal when the next chapter began, or would I have to revert them to the default values in the next chapter#.cfg file? —Yar Kramer 10:37, 8 Jan 2007 (PST)

New Game wont load

Please help! the same probelm as "hmmmm" question however i cant get it to work :) i've switched logs on in console and everytime i try to load my first chapter this appears:


L 03/27/2008 - 13:11:56: server_cvar: "deathmatch" "0" execing chapter1.CFG Unknown command "m"

I hope 'deathmatch' doesnt have anything to do with it? as it should be all set to single player :)

The 'chapter1.cfg' reads:

map Map1

and yes Map1 is really my map name :)

please help!

no response

tried starting a chapter and no response. also the thumbnail shows a blank.

my chapter1.vmt code: "UnlitGeneric"

{ "$basetexture" "vgui/chapters/chapter1" "$vertexalpha" 1 }

my chapter1.cfg code: map Map1

errors: KeyValues Error: LoadFromBuffer: missing { in file materials/vgui/chapters/chapter1.vmt

Error: Material "vgui/chapters/chapter1" uses unknown shader "��"

when loading chapter it says

execing chapter1.cfg Unknown command "��m"


ALSO i got a glitch in my chapters window. this appears on the top left.. Chapterglitch.jpg


Try not to mix and match resources and scripts from different games and you might fix Chapterglitch.jpg without even trying or noticing (Its apart of the .res files in your Resource folder, either your missing some, or you have used ep1 res files in Orangebox or visa versa)
As for the material error, i'm using firefox and whatever you have typed there has been interperated as a Unicode character.
mikeunicode.png
And also Mike, you need to put your Timestamp (2 dashes and 4 Tilde's) > --~~~~ at the end of each post you make on this wiki so it's easier to track whoever wrote that piece down.--Jenkins08 09:53, 19 April 2009 (UTC)

as far as i know, everything was done using the ep1 engine.. so i dont know how it might have happened..
on my console, the unicode just appeared as 2 boxes that looked kinda like [][] so i dont really know what it means.
i honestly have no idea what these errors are and where they came from.. --Mikes852 19:01, 19 April 2009 (UTC)

Strange Title

i followed all the instructions for the scripts bit so i can have a title but i get this instead of what i wanted Title portal error.PNG
here's the portal_english.txt file:

"lang"
{ 
"Language" "English" 
"Tokens" 
{
"Valve_Primary_Attack"		"Fire blue portal"
"Valve_Secondary_Attack"	"Fire red portal"
"Escaped_Chapter1_Title"	"Chapter 1 title"
} 
}


what's wrong with portal!!!!

The names don't match up. "Escaped_Chapter1_Title" is wrong. --TomEdwards 19:40, 13 February 2011 (UTC)

Wrong Title

I am having the same problem as the user above on my mod. My mod's name is Cloned Cube and the folder where all the files are stored is called /clonedcube. [A picture of the problem: [1] ]

Here is my clonedcube_english.txt:

"lang" 
{ 
"Language" "English" 
"Tokens" 
{
"Valve_Primary_Attack"		"Fire blue portal"
"Valve_Secondary_Attack"	"Fire red portal"
"Cloned Cube_Chapter1_Title"		"Escape"
}
}

My titles.txt looks like this:

//CHAPTER TITLES
$fadein 0.01
$holdtime 3.5
$position -1 0.58
CHAPTER1_TITLE
{
#Cloned Cube_Chapter1_Title
}

My chapter1.cfg file is fine but I don't know what is wrong. I couldn't understand what TomEdwards' response meant. --Cubis 16:07, 14 August 2011 (PDT)

Look at the screenshot. It is trying to display clonedcube_Chapter1_Title. But that doesn't exist, because you have defined Cloned Cube_Chapter1_Title instead. --Artfunkel 12:36, 14 August 2011 (PDT)

The error is still occurring and I changed my titles.txt file. Here's what it looks like now:

//CHAPTER TITLES
$fadein 0.01
$holdtime 3.5
$position -1 0.58
CHAPTER1_TITLE
{
"clonedcube_Chapter1_Title"
}

My clonedcube_english.txt file:

"lang" 
{ 
"Language" "English" 
"Tokens" 
{
"Valve_Primary_Attack"		"Fire blue portal"
"Valve_Secondary_Attack"		"Fire red portal"
"clonedcube_Chapter1_Title"		"Escape"		
} 
}

Hmm... --Cubis 16:10, 14 August 2011 (PDT)

I'm Having Some Issues

I've followed this tutorial, as well as one other in regards to custom menu features, and I simply cannot get my mod to display the image I set as a background image instead of the default Episode 2 background map, nor can I get my chapter thumbnail to show over the default Episode 2 thumbnail. I initially managed to get the background image to work when I first started working on the mod, but then I mounted content for Lost Coast and the Episodes following the information provided here and I've had this issue ever since. Any clue why this is happening?

Also, this isn't necessarily 100% about the page topic, but this other issue I'm having is stemming from information that I found on this page: I'm trying to figure out why my game over messages aren't displaying properly, if at all, when I trigger them.

The first image is the relevant text in my hl2rep_english.txt file, renamed from hl2_english.txt. The second is the relevant text in my titles.txt file.

Mod Titles Error 1.png
Mod Titles Error 2.png

In my test level, I'm fiddling around with triggering a "stuck" game over. I've put the env_message value as both "GAMEOVER_STUCK" and "HL2REP_GAMEOVER_STUCK", in every variant of case sensitive/all caps and with and without a # at the beginning. I've yet to get the desired message to display. In some cases, I get "#HL2_GameOver_Stuck" as the message, in others I get nothing at all. Is there some sort of file compiling I've failed to do? I sincerely appreciate any and all help anyone may be able to offer. - Arrowing 21:21, 16 Dec 2018 (CST)