Difference between revisions of "Talk:Adding Motion Blur"

From Valve Developer Community
Jump to: navigation, search
(What am I doing wrong here?)
m (What am I doing wrong here?)
Line 14: Line 14:
 
src\cl_dll\view_scene.cpp(71): error C2039: 'DoMotionBlur' : is not a member of 'CViewRender'
 
src\cl_dll\view_scene.cpp(71): error C2039: 'DoMotionBlur' : is not a member of 'CViewRender'
 
src\cl_dll\view_scene.cpp(73): error C2065: 'pp_motionblur' : undeclared identifier
 
src\cl_dll\view_scene.cpp(73): error C2065: 'pp_motionblur' : undeclared identifier
src\cl_dll\view_scene.cpp(73): error C2228: left of '.GetInt' must have class/struct/union type
+
src\cl_dll\view_scene.cpp(73): error C2228: left of '.GetInt' must have class/struct/union type type is unknown-type
        type is ''unknown-type''
 
  
 
.. and so and so forth.
 
.. and so and so forth.
  
 
Anyone know what i've done wrong?
 
Anyone know what i've done wrong?

Revision as of 00:57, 22 August 2005

view_scene.cpp \cl_dll\view_scene.cpp(1934) : error C2664: 'IMaterialVar::SetTextureValue' : cannot convert parameter 1 from 'IMaterial *' to 'ITexture *'

       Types pointed to are unrelated; conversion requires reinterpret_cast, C-style cast or function-style cast

\cl_dll\view_scene.cpp(1939) : error C2065: 'pMatMBlur' : undeclared identifier :(


With the fixes that were added, it should be working now. Make sure to get the latest code from here and try again. --Snakez

What am I doing wrong here?

I've followed the tutorial to the letter, but my poor C++ skills are letting me down, it seems :-(

Build errors: src\cl_dll\view_scene.cpp(71): error C2039: 'DoMotionBlur' : is not a member of 'CViewRender' src\cl_dll\view_scene.cpp(73): error C2065: 'pp_motionblur' : undeclared identifier src\cl_dll\view_scene.cpp(73): error C2228: left of '.GetInt' must have class/struct/union type type is unknown-type

.. and so and so forth.

Anyone know what i've done wrong?