Difference between revisions of "Source SDK SE2 Bugs"

From Valve Developer Community
Jump to: navigation, search
(Reports)
(VRAD bugs)
 
(282 intermediate revisions by 64 users not shown)
Line 1: Line 1:
This page is for reporting bugs in the Current Version Of the Source SDK, Currently known as SE2.
+
{{note|Now there is a [https://github.com/ValveSoftware/Source-1-Games/issues GitHub repository] where bugs and features requests can be submitted (it's specified that it's for Linux versions)}}
  
This page has been cleared to accept new reports for the November 2007 release of the SDK. For older bug reports, see [[August 2006 Community Buglist]].
+
This page is for reporting bugs in the [[Source_SDK_Release_Notes|current (beta) version]] of the Source SDK, currently known as the 2010 beta.
  
'''Note:''' After the new SDK has been updated, it's '''very''' important to '''Reset Game Configuration''' before the Episode Two hammer can be launched. The Episode One hammer is now both buggy and crashy for some strange reason, and I wont recommend using it at all. --[[User:Sortie|Sortie]] 15:23, 8 Nov 2007 (PST)
+
This page has been cleared to accept new reports for the May 2010 release of the SDK. For older bug reports, see: <br>
 +
[[December 2007 Community Buglist]]<br>
 +
[http://developer.valvesoftware.com/w/index.php?title=Source_SDK_SE2_Bugs&oldid=134009| January 2008 Community Buglist]
  
For any problem you're having, try running the Episode 1 compatible SDK with any existing maps or mods first. This is done by adding "-engine ep1" to your command line options when you run the Source SDK. You can do this by right clicking on the SourceSDK, going to properties, and clicking on "Set launch options..." Put "-engine ep1" in the dialog, and hit ok. Now try running it again. This will put hammer back to how it was before this update.
 
  
=Work Arounds=
+
=Source SDK Update 05/11/2010=
 +
{{Note| The [[Source SDK Release Notes|new version of the SDK]] ''is'' a '''beta''' and therefore is '''not''' the final version!}}
  
Any work arounds to fix issues with the SE2 release of the SDK should be added to this section. Bug reports should be added to the report section.
 
  
==<s>Recommended/Temporary Solution For: "Missing material..."&"Can't load File..."==
+
Please report any issues you find in [http://developer.valvesoftware.com/bugzilla Bugzilla](Link is Broken!).
  
* You must add this to the launch options for the Source SDK (or use the workaround below) in order to edit games that run using the Ep1 version of the Source engine. (However it seems this hammer version has a lot of errors and the model viewer crashes the editor constantly, [[User:Sortie|Sortie]] 13:08, 8 Nov 2007 (PST))
+
=General Source SDK Issues=
    -engine ep1
 
**To see original document Follow the next link.
 
[[Source SDK Release Notes|Original Solution Page(Source SDK Release Notes)]]</s>
 
  
*'''Note:''' This workaround doesn't support compiling, the files located somewhere else now, and can't connect to '''MaterialSystem.dll''' and '''Steam_FileSystem.dll'''. Use the below work around if you want at least to be able to compile for Episode Two.
+
=Hammer Issues=
===Update Released 20:33, 8 Nov 2007 (PST)===
 
*Error Solved however hammer settings can be changed to start with "-engine ep1" however as stated above compiling does not function in this mode.
 
*Update has caused new errors.
 
--[[User:A2fatalassassin|Stalker]] 20:33, 8 Nov 2007 (PST)
 
  
==Mod Enabling Workaround via Fake Search Paths==
+
==General==
 +
* Still getting blank viewports on Hammer. I believe this is a major problem. Tried to find a solution but didn't found any and I don't want to use 3rd party patches. I know there are a lot of users like me that have the same problem. Already reinstalled the SDK and have the lastest driver for my video card (GTX 460). Please tell us when are you planning to solve this because I really want to keep working on my mod. (Sorry if this is not the place to post this and if there is something that isn't really clear but I think that we all are aware of this issue). -[[User:medl|medl]] 2:45AM, 27 January 2012
 +
:You mean there's no grid showing up? &mdash;[[User:Mattshu|Mattshu]] 22:38, 26 January 2012 (PST)
 +
::No grid in any viewport. I can use the brush and create; but blinded (can't see anything; no gridlines, no brush). I see the result in the Camera View but nothing in the other three. --[[User:Medl|medl]] 06:44, 27 January 2012 (PST)
 +
:::Try pressing Shift+R, you may have the default grid system toggled off. --[[User:Pichubolt090|Pichubolt090]] 02:52, 12 May 2012 (PDT)
 +
::::I have the same problem, and I tried pressing Shift+R, and it still has a black screen on all viewports with no grid. I am trying to make maps for my source mod for Portal, and with any other game I can see the grids and everything. --[[User:darkdarts214|darkdarts214]] 11:15 AM 8 June, 2012 (GMT-5)
 +
:::::Try going into gammeinfo.txt (steam/steamapps/sourcemods/<your mod name>) and changing the appid to 218. That worked for me. --[[User:Yoyodaman234|yoyodaman234]] 17:48, 22 June 2012 (PDT)
 +
::::::I have tried that solution, as well as copying the special 'editor' materials/models/etc from the SDK's GCF, but I still have blank viewports, as well as 3D objects becoming a solid black most of the time. [[User:HiveLordLusa|HiveLordLusa]] 22:23, 13 July 2012 (PDT)
  
I got mods working by changing the gameinfo.txt to use '''SteamAppId 420''', this appearently loads some stuff from the Episode Two gcf's that enables the missing features. In such a case you don't want to use the Episode Two engine for your mod yet (and you don't want to, you can't use your own Binaries for '''server.dll''' and '''client.dll'''), follow these instructions to stabilize hammer:
+
* If you right-click an entity with a model parameter (like prop_static) and open the model selection dialog, closing the model selection dialog and reopening it without closing the entity properties dialog first will cause the model selection dialog to be unresponsive to clicks. [[User:Flarn2006|Flarn2006]] 02:59, 30 January 2011 (UTC)
# Get into a working state of the '''Ep2 Hammer''', try use '''Episode Two''' as '''Current Game'''
+
:A quick solution is to close the unresponsive model viewer, deselect the entity, then ''reselect'' the entity, then ''reopen'' the model viewer. -[[User:Mattshu|Mattshu]] 05:54, 30 January 2011 (UTC)
# Go to Tools -> Options.
 
# Select '''[Your Modname here]''' and change the location from:
 
  '''$SteamDir\SteamApps\SourceMods\[Your Mod Folder Here]\'''
 
  to
 
  '''$SteamDir\SteamApps\SourceMods\[Your Mod Folder Here]\SDK2007'''
 
# Open your Mod Folder and create a new subfolder named '''SDK2007'''.
 
# Insert a copy of your regular '''gameinfo.txt''' into '''SDK2007'''.
 
# Open the file and alter '''SteamAppId''' to '''SteamAppId 420''' in order to use Ep2 content for hammer.
 
# Most important change '''|gameinfo_path|.''' to '''"..\..\..\..\SourceMods\[Your Mod Folder Here]"'''
 
# This search path is based relatively to the Orange Box Bin folder within sourcesdk/bin/. You can't use '''|gameinfo_path|.''' because it points to the folder which this fake '''gameinfo.txt''' lies within, and thus contains no data. Neither is '''..''' possible since Source prevents escaping the root folder using '''...'''.
 
# Lastly launch hammer, hammer will now load the fake '''gameinfo.txt''' and work, and your Steam/Your Mod should use the correct one. In such case the fake '''gameinfo.txt''' shows up on the games list, just ignore it until a final patch is released.
 
# This workaround should enable the modelviewer, the 3d views and the 2d views and all the new Ep2 features without your mod being ported to it at all.
 
'''Note:''' Compiling is only possible via the Episode Two tools. These tools don't work with Episode One, and forces you to play the map as an Episode Two mod, which doesn't support a pair of custom '''Server.dll''' and '''Client.dll''' files.
 
'''Note Edit:''' A 1024unit^3 cubic test map containing nothing but a player start, works unexpectingly ingame. This hints that it's not the file format but something else that is crashing the game. '''Please try to make some test maps and see if you can find out what, and post it here. I imagine lighting or displacement maps.'''
 
(Written by [[User:Sortie|Sortie]] 08:46, 8 Nov 2007 (PST))
 
  
 +
* A Cascade Loop is created in the Torus Creation tool when the user deletes the value in a Required Field and refreshes the Preview. With no value a popup returns stating to put a value in the field, exiting the popup returns the same popup.I.E. Removing the Rotation height value. Suggested fixed Set to 0 if no value is found. - [[User:-Badger-|-Badger-]] 2:11 AM Tuesday, February 01, 2011 (UTC) '''***update***''' This is found with most Fields in the Torus Creation tool, suggestion stands to set default as minimum Value accepted in the event a value is either not found or the value is lower than the minimum. - [[User:-Badger-|-Badger-]] 9:09PM Monday, February 07, 2011 (UTC)
  
=Reports=
+
* (Build 5004) CSS: FUNC_CONVEYOR inputs are showing 2 "SetSpeed" options, neither of which works when referenced. [[User: Worm]] 00:07, 18 July 2010
  
Any issues with the SE2 release of the SDK should be addressed here. If there's a working work around, add it to the work around section.
+
* BUG: "env_embers" "Parent" option needs a fix as it don't work at all (Parent option is broken). Option for "env_embers" to have a working "enable" and "disable" on trigger. (As they can't be turned off and on)
  
== Episode One SDK Issues ==
+
* If the Steam user name is an email address, or has an '@' symbol in it, Hammer will always save the map in steamapps with the user name as the file name. This might also occur with other symbols. [[User:Solokiller|Solokiller]] 08:54, 29 January 2012 (PST)
* Valve/Steam seem to have solved this issue although others have taken it's place, remove the <-s>Strikeout<-/s> if the error is persistent for you.
 
<s>* I'm getting a "Missing material 'editor/flatnocull'" error. It only happens when I insert a custom mod into the gameconfig.txt. I'm wondering if all my paths are correct. Gonna check and report back if I can fix it.--[[User:Spektre1|Spektre1]] 13:14, 7 Nov 2007 (PST)
 
** I'm also getting "Can't load FileSystemOpenDialog.dll" when Hammer first opens, when running a custom mod. --[[User:Spektre1|Spektre1]] 13:21, 7 Nov 2007 (PST)
 
** Definitely seems to be an issue with the ep2 Hammer. If I switch over to Ep1, it runs everything fine. We're gonna need a list of what changes are necessary to upgrade our content and mod to Ep2. I'd want to do that if for nothing else than the new hammer stuff like turning off Nodraw faces. I LOVE that feature. --[[User:Spektre1|Spektre1]] 15:27, 7 Nov 2007 (PST)
 
** I get the same "Missing material 'editor/flatnocull'" for custom mods, maybe we are suposed to use Ep1 untill mods also got updated? --[[User:Bluestrike|Bluestrike]] 14:03, 7 Nov 2007 (PST)
 
** I don't think it's just with the mod's when i try and open hammer it give me that same "Can't load FileSystemOpenDialog.dll" but when i ignore it and continue i get the "Missing material 'editor/flatnocull'" error, and the hammer flashes that like 7 times and then freezes and shuts down. Whatever the problem Valve/Steam needs to fix it soon. I am in the middle of making a map.--[[User:A2fatalassassin|Stalker]] 19:26, 7 Nov 2007 (PST)--
 
*** Exact same problem here. Adding ''-engine ep1'' to the launch options seems to have fixed both errors.[[A newbie]]
 
** I am having even stranger issues. When I open hammer in orangebox i get the usual "Can't load FileSystemOpenDialog.dll" error, but if I switch over to the episode one, all of my materials in my map are gone and the models render as weird infinite lines in the 3D view. The map doesn't even open in the orangebox side. I don't know what valve did but this is really frustrating. I am in the middle of a map as well. -Raider666
 
*** Well hi. The Episode One version doesn't work at all as you pointed out. In order to fix the Episode Two hammer, click the '''Reset Game Configuration''' in '''Source SDK Launcher'''. Then it should work, eventually try my work above above.</s>
 
**[[Image:Fatal_error.JPG ]]
 
**[[Image:Can\'tLoad.JPG ]]
 
  
== Hammer Material Browser==
+
* Pasting func_instance entity keyvalues only affect the first selected entity if multiple selected.
I just started getting this one. Clicking "Browse..." causes Hammer to lock up, and become unresponsive to any input. I have to kill it with Task Manager. --[[User:Spektre1|Spektre1]] 00:38, 9 Nov 2007 (PST)
 
  
== Light Preview Issues ==
+
* The Particle System Browser in CSGO Hammer doesn't read from the vpk, making it necessary to extract the files.
  
* My 3D light preview makes things black, #d raycast seems to freeze hammer and has the same effect as 3d light preview. My cpu is barely doing anything. --[[User:Bluestrike|Bluestrike]] 14:03, 7 Nov 2007 (PST)
+
* "animatedTextureFrameRate" below 1 causes issues.
'''Note:''' The 3D Light Preview is only experimental and isn't release publicly. This will be addressed in the next SDK release.
 
  
==Hammer VGUI Model Browser==
+
* Moving brush entities with groups ignored doens't move the entity origin. Feature or bug?
* Hammer crashes when entering the Model browser, after the Episode 2 SDK update. [[User:Solokiller|Solokiller]] 13:18, 7 Nov 2007 (PST)
 
:Fix: Extract Advisor.jpg from Source Models.gcf (it's under hl2/models) and
 
place it in "Half-Life 2 Episode Two/ep2/models"
 
  
And that should fix the crashing with hlmv. --[[User:Frostbite|Frostbite]] 14:27, 7 Nov 2007 (PST)
+
*Adding a info_player_start entity in a custom Hammer map for Episode Two that DOES NOT have any leaks in it causes Hammer to crash no matter what.
'''Note:''' This and other errors are caused by hammer requiring content from the Episode Two GCF's. Use the searchpath workaround to mount this content.
 
  
Attempted the searchpath workaround from above, but kept getting the crash error. What is the path to the models folder? Is it "Program Files\Steam\steamapps\username\half-life 2 episode two\ep2\models"? IF it is, it didn't exist on two machines, and the fix suggested with the Advisor.jpg didn't work by adding in the \models folder. --[[User:Dbmata|Dave M]] 00:34, 9 Nov 2007 (PST)
+
==Displacements==
 +
* If multiple displacements of different powers are being subdivided, displacements sometimes distort themselves in a certain direction on random vertices. --[[User:Mattshu|Mattshu]] 04:29, 1 February 2011 (UTC)
  
== Texture Keywords Lockup ==
+
==Viewport issues==
* Hammer seems to lock up for me after I enter a keyword in the texture browser (filter works fine). Bug? --[[User:Baliame|Baliame]] 13:20, 7 Nov 2007 (PST)
 
*:It's always done this. Leave it for long enough and it'll complete the operation, and be instant next time you try. --[[user:TomEdwards|TomEdwards]] 07:53, 8 Nov 2007 (PST)
 
  
== Point_spotlight ==
+
==Sidebar Menus==
* Point_spotlight model is "ERROR" in Portal (not tested in any other games). --[[User:Baliame|Baliame]] 14:23, 7 Nov 2007 (PST)
+
===2009 version===
:It does this for all Source Games :( --[[User:Frostbite|Frostbite]] 14:28, 7 Nov 2007 (PST)
+
====Face edit dialog====
 +
*The arrow keys now alter the alignment of the currently selected textures. In previous versions of Hammer the arrow keys moved the camera angles. Can an option be added to toggle this behavior? [[User:Solokiller|Solokiller]] 09:53, 13 June 2010 (UTC)
 +
*The random X and Y buttons sometimes forget what axis they are and have to be reminded by changing the number manually. Might stem from Copy Face function (ALT + Right Click).
  
==2D Draw View Issues==
+
====Face edit sheet====
=== Missing rotate cursor ===
+
* Rotate a texture and select a different one. Now if you want to go back to the first texture and change the rotation from, for example, -35 to -36 and use the up or down button to do so, it will automaticly jump to -359. You'll have to enter -35 again and start over. This has been around for over 10 years, but I thought I might finally report it. [[User:Hezus|Hezus]] 7 October 2010
The rotate cursor is missing when the mouse is above one of the rotate vertices when rotating a brush in the 2D view. [[User:Sortie|Sortie]] 09:15, 8 Nov 2007 (PST)
 
  
==3D Draw View Issues==
+
=Compile Tools=
===Low Resolution Textures in 3D views===
 
For some reason Hammer draws all things, including entity's, at a very low texture setting. As if it was a game and the settings had texture resolution set to very, very low.--[[User:MrTwoVideoCards|Gear]] 14:31, 7 Nov 2007 (PST)
 
  
Yeah, I have the same problem. It seems linked to the problem of the resetting of the Very High texture setting to low, in all Source 2007 games. It's really annoying, and it seems like I can't find any fix within the Windows Registry.
+
==VBSP bugs==
Going to look at some launch options right now and see if there's any fixes there. I imagine something like -DXLevel 81 should make an inpact. [[User:Sortie|Sortie]] 08:46, 8 Nov 2007 (PST)
 
  
Yeah it is horrible, mainly when it comes to sizing textures and aligning them correctly.--[[User:MrTwoVideoCards|Gear]] 12:30, 8 Nov 2007 (PST)
+
==VRAD bugs==
 
+
{{bug|Randomly causes corrupt lightmaps that look like "ink spills".}}
Well, aligning is piece of cake, just remember to use the Left, Right, Top, Buttom, Center, Fit tools. Well that was a lie. :P. Sizing is another problem that always has been within the SDK, better support for scales with more than two decimals, which is, really really usefull within the 3D skybox. Uh, and try to keep the === subcatagories, so we can arrange this article before it goes crazy. Uh, and if any Valve guys read this, mind to increase the Overlay limit? I'm running a litle low here. ;-) [[User:Sortie|Sortie]] 12:42, 8 Nov 2007 (PST)
+
: [[File:Inksplot.png|thumb|An example of "ink spill" bug.]]
 
+
: {{tip| [https://github.com/Enderlux/sourcelightmap Source Engine BSP Lightmap Editor] can be used to manually correct a .bsp lightmap data.}}
Overlay limit FTL, we need a better one.--[[User:MrTwoVideoCards|Gear]] 12:46, 8 Nov 2007 (PST)
 
 
 
=== 3D Shaded Texture Polygons bug ===
 
*When 3d Shaded Textured Polygons is selected, all textures are rendered fullbright except for textures which are solid colour, e.g. all the white texture lights and the orange glow from Portal. Only these textures are shaded. [[User:Got Lag?|Got Lag?]] 19:58, 7 Nov 2007 (PST)
 
=== 3D Screen===
 
* I have quite the opposite but this is after the update. When editing CS:S maps the 3D texture screen does not display objects as 3D objects but merely as lines. Also when objects are selected in any mode Hammer freezes and shuts down.
 
 
 
== General Model Viewer issues ==
 
*When opening the [[Model Viewer]] with my custom mod configuration for the Source SDK, the program doesn't load up the model browser when clicking on <code>File</code> - <code>Load Model...</code>. There was no error report generated. --[[User:JurgenKnops|Jurgen Knops]] 06:41, 8 Nov 2007 (PST)
 
 
 
== Engine Faults ==
 
=== Missing Episode One support for Episode Two maps ===
 
Episode One mods can't use the BSP's generated by the new compile tools, it crashes with a memory-couldn't-be-read message doing load. Of course I can just play the mod with Episode Two as game, but then my own binaries wont be used, and I'm playing vanilla Episode Two, which sucks within a mod.
 
As said beneath, nor can I compile for Episode one, which sucks too. [[User:Sortie|Sortie]] 13:00, 8 Nov 2007 (PST)
 
 
 
== Compile Tools ==
 
=== Missing support for Ep1 Compile Tools ===
 
Seems as I can't use the Episode One compile tools while running the Episode Two hammer (which is the only one who actually works good), vbsp can't load MaterialSystem.dll
 
 
 
  Valve Software - vbsp.exe (Dec 11 2006)
 
  1 threads
 
  Can't load MaterialSystem.dll
 
 
 
As I said above, I need to use the Episode One compile tools in order to play the maps within the game, so a quick fix/work around for this would be pretty appreciated. [[User:Sortie|Sortie]] 13:00, 8 Nov 2007 (PST)
 
 
 
===Compilation Errors in Game===
 
I a slightly different problem; after compiling a map a receive an problem in console stating the "map is out of constraint" or something or other message meaning it's too big. so i am assuming that would be an issue with compiling. I got this error after running Hammer with -engine ep1--[[User:A2fatalassassin|Stalker]] 17:12, 8 Nov 2007 (PST)
 
  
 
=See also=
 
=See also=
 
 
* [[Source_SDK_Release_Notes|Source SDK Release Notes]]
 
* [[Source_SDK_Release_Notes|Source SDK Release Notes]]
 
* [[Source SDK Bugs]]
 
* [[Source SDK Bugs]]

Latest revision as of 00:45, 21 August 2018

Note:Now there is a GitHub repository where bugs and features requests can be submitted (it's specified that it's for Linux versions)

This page is for reporting bugs in the current (beta) version of the Source SDK, currently known as the 2010 beta.

This page has been cleared to accept new reports for the May 2010 release of the SDK. For older bug reports, see:
December 2007 Community Buglist
January 2008 Community Buglist


Source SDK Update 05/11/2010

Note: The new version of the SDK is a beta and therefore is not the final version!


Please report any issues you find in Bugzilla(Link is Broken!).

General Source SDK Issues

Hammer Issues

General

  • Still getting blank viewports on Hammer. I believe this is a major problem. Tried to find a solution but didn't found any and I don't want to use 3rd party patches. I know there are a lot of users like me that have the same problem. Already reinstalled the SDK and have the lastest driver for my video card (GTX 460). Please tell us when are you planning to solve this because I really want to keep working on my mod. (Sorry if this is not the place to post this and if there is something that isn't really clear but I think that we all are aware of this issue). -medl 2:45AM, 27 January 2012
You mean there's no grid showing up? —Mattshu 22:38, 26 January 2012 (PST)
No grid in any viewport. I can use the brush and create; but blinded (can't see anything; no gridlines, no brush). I see the result in the Camera View but nothing in the other three. --medl 06:44, 27 January 2012 (PST)
Try pressing Shift+R, you may have the default grid system toggled off. --Pichubolt090 02:52, 12 May 2012 (PDT)
I have the same problem, and I tried pressing Shift+R, and it still has a black screen on all viewports with no grid. I am trying to make maps for my source mod for Portal, and with any other game I can see the grids and everything. --darkdarts214 11:15 AM 8 June, 2012 (GMT-5)
Try going into gammeinfo.txt (steam/steamapps/sourcemods/<your mod name>) and changing the appid to 218. That worked for me. --yoyodaman234 17:48, 22 June 2012 (PDT)
I have tried that solution, as well as copying the special 'editor' materials/models/etc from the SDK's GCF, but I still have blank viewports, as well as 3D objects becoming a solid black most of the time. HiveLordLusa 22:23, 13 July 2012 (PDT)
  • If you right-click an entity with a model parameter (like prop_static) and open the model selection dialog, closing the model selection dialog and reopening it without closing the entity properties dialog first will cause the model selection dialog to be unresponsive to clicks. Flarn2006 02:59, 30 January 2011 (UTC)
A quick solution is to close the unresponsive model viewer, deselect the entity, then reselect the entity, then reopen the model viewer. -Mattshu 05:54, 30 January 2011 (UTC)
  • A Cascade Loop is created in the Torus Creation tool when the user deletes the value in a Required Field and refreshes the Preview. With no value a popup returns stating to put a value in the field, exiting the popup returns the same popup.I.E. Removing the Rotation height value. Suggested fixed Set to 0 if no value is found. - -Badger- 2:11 AM Tuesday, February 01, 2011 (UTC) ***update*** This is found with most Fields in the Torus Creation tool, suggestion stands to set default as minimum Value accepted in the event a value is either not found or the value is lower than the minimum. - -Badger- 9:09PM Monday, February 07, 2011 (UTC)
  • (Build 5004) CSS: FUNC_CONVEYOR inputs are showing 2 "SetSpeed" options, neither of which works when referenced. User: Worm 00:07, 18 July 2010
  • BUG: "env_embers" "Parent" option needs a fix as it don't work at all (Parent option is broken). Option for "env_embers" to have a working "enable" and "disable" on trigger. (As they can't be turned off and on)
  • If the Steam user name is an email address, or has an '@' symbol in it, Hammer will always save the map in steamapps with the user name as the file name. This might also occur with other symbols. Solokiller 08:54, 29 January 2012 (PST)
  • Pasting func_instance entity keyvalues only affect the first selected entity if multiple selected.
  • The Particle System Browser in CSGO Hammer doesn't read from the vpk, making it necessary to extract the files.
  • "animatedTextureFrameRate" below 1 causes issues.
  • Moving brush entities with groups ignored doens't move the entity origin. Feature or bug?
  • Adding a info_player_start entity in a custom Hammer map for Episode Two that DOES NOT have any leaks in it causes Hammer to crash no matter what.

Displacements

  • If multiple displacements of different powers are being subdivided, displacements sometimes distort themselves in a certain direction on random vertices. --Mattshu 04:29, 1 February 2011 (UTC)

Viewport issues

Sidebar Menus

2009 version

Face edit dialog

  • The arrow keys now alter the alignment of the currently selected textures. In previous versions of Hammer the arrow keys moved the camera angles. Can an option be added to toggle this behavior? Solokiller 09:53, 13 June 2010 (UTC)
  • The random X and Y buttons sometimes forget what axis they are and have to be reminded by changing the number manually. Might stem from Copy Face function (ALT + Right Click).

Face edit sheet

  • Rotate a texture and select a different one. Now if you want to go back to the first texture and change the rotation from, for example, -35 to -36 and use the up or down button to do so, it will automaticly jump to -359. You'll have to enter -35 again and start over. This has been around for over 10 years, but I thought I might finally report it. Hezus 7 October 2010

Compile Tools

VBSP bugs

VRAD bugs

Bug: Randomly causes corrupt lightmaps that look like "ink spills".
An example of "ink spill" bug.
Tip: Source Engine BSP Lightmap Editor can be used to manually correct a .bsp lightmap data.

See also