Source SDK Bugs

From Valve Developer Community
Revision as of 00:57, 24 November 2005 by Lunchtimemama (talk | contribs) (Hammer VGUI Model Browser)

Jump to: navigation, search

Tues November 22nd, 2005
We're going to run a short beta of the new Source SDK tools.

To run it, run Steam from a command line or shortcut with -beta sdk appended. If you find any bugs, please edit this page and put it in the correct category. See SDK Beta Changelist for a current list of changes.

Note: Be sure to run the game you wish to edit before running the SDK, to make sure you have the latest updates.

SDK General Issues/Bugs

Issues with the Source SDK launcher or items that don't fit under other categories.

  • If you roll-back from the beta SDK by removing the command line you will need to re-extract hammer and its other files from the SourceSDK GCF using GCFScape.--Skidz 15:52, 23 Nov 2005 (PST)
  • If you are receiving the "Unable to load C:\<SteamFolder>\counter-strike souce\bin\filesystem_steam.dll" run the game you are trying to play so its content can be refreshed. This will normally fix the problem.--Skidz 15:57, 23 Nov 2005 (PST)

SDK Launcher

  • Day of Defeat: Source game configuration lost when refreshing SDK content.
    • Is this solved with the latest DoD:S Update? If not, run DoD:S and then try again. --King2500 14:05, 22 Nov 2005 (PST)
  • No Configuration appears after running DoD:S.
    • This can be fixed by extracting a new GameInfo.txt from the DOD:S GCF file using nems GCFScape tool. --Skidz 15:50, 23 Nov 2005 (PST)
  • When I try to open Hammer in the sdk launcher after downloading the beta It wont open and it tells me "The system cannot find the file specified" - X23
    • Please look above for a fix.
  • I get the 'copying files' dialog briefly everytime I launch the SDK

Hammer Editor

Put bugs having to do with the Hammer level editor under one of these categories.

General Hammer issues

  • On map load, the viewports aren't drawn. I'm using an independent window configuration. It's hard to tell when large maps are finished loading because of this.
  • Using SHIFT to invert override rotating objects in 15 degree rotations is non-functional.
Workaround: Use the Transformation Dialog (Ctrl-M)
Workaround 2: hold ALT when rotating.
  • Displacement Alphas in hammer when compiled appear inverted in-game. Such as using sand with sand/rocks as the alpha. If you have it setup in hammer one way when you compile and play it will invert the alpha. Additional notes are that this bug occured even without the new sdk beta and therefore is a bug that I hope is fixed soon. Thanks --RomeoGuy 16:57, 23 Nov 2005 (PST)
Workaround: Invert Alpha before compile, but is tedious.
  • Some of the models are being rendered incorrectly by hammer. Most notably are any humanoid NPC models. You can view them in the model browser but if it attempted to be loaded into hammer itself results in crash. This therefore causes any old map with a messed up model to crash. Interesting though is that some of the messed up models load fine. One of the combine electric gate models had screwed up model while the other did not yet the whole prefab loaded properly into hammer without issue. (And just to be specific on model issues. If I look in model broswer for example with NPC models it will draw a like blobish looking thing where it appears triangles are not in the right spot but are all over the place from seeing how the texture on the model is all stretched extremely). I currently know of no workaround although the new update to the beta sdk severly cleared up the npc models so they have only a couple odd triangles, they still will not load in hammer without crash. -RomeoJGuy
  • Hammer crashes when trying to load a map or make a new file.
Needs more information than that, what are your system specs + software running at the time of crash.
A64 3200+ @ 2309 Mhz, 2x512MB PQI PC3200 DDR, Gigabyte Radeon 9600 (np) 128/128mb, Omega 2.6.75a Drivers, Win XP SP2, I'll try new drivers now and restart...
Make sure you clean the drivers out properly.
Okay, it's fine now... I made a mistake before, I accidentally opened Steam withOUT the -beta sdk parameters... hence the problems.
  • npc_* > Properties > Model > Dropdown is not filtered.
  • Some people are complaining about losing their cursor, unfortunatly no more information than that.
Cursor is lost over the model viewer after clicking in the filter text-box.
Workaround: Restart Hammer.
Workaround 2: Try and drag a model name (using the invisible cursor) onto the filter text box (dont let go) until a menu pops up.
I noticed that for me I only get this issue not from using the textbox, but if I hit the arrow next to the textbox for I guess a dropdown box but it never appears when you click it.
  • Selection of a Displacement only considers the original box it was made from
  • After mere minutes of use, Hammer takes up almost 500mb of RAM. Memory leak?
    • Could also be because of the number of resources loaded for the map.
  • When trying to launch the Day of Defeat: Source Hammer Editor, A configuration error appears. "Warning - The Configuration information for this game you're trying to edit is invalid or missing. [Run Anyway] [Cancel] [Help...]" The [Run Anyway] option does not work. The Hammer Editor fails to launch.
    • Run DOD:S once.
  • Hammer crashes when loading some maps created from non-beta hammer
  • Cursors don't always do what they're representing i.e. a drag cursor appears over a button or a text box.
    • Cursors appear to not update properly when they're hovered from one object type to another. i.e., When a brush is selected, and the Object Properties dialog overlaps the selected brush; if the user moves the icon over the Object Properties dialog, the cursor is still a 4-way arrow.
  • Skewing does not snap to grid anymore.
Crappy workaround: Snap the vertices manually to the grid. This really sucks, though.
  • Flipping displacements does not work. Horizontal flips don't even appear to do anything if the displacement is square. However, the texture is always affected, even if the brush isn't. (Curiously, a vertical flip followed by 180degree rotation is equivalent to doing nothing).
  • Face Edit Tool: Changing the texture alignment of a face between World and Face will reset the texture shifts to zero.

Hammer 2D and 3D Views

  • pasting or manipulating light_spot entities turns the light cones green. properties remain the same.
workaround: restart hammer.
  • Rotating models does not go smoothly anymore, it now is like having shift pressed when rotation. The old way allowed for much more freedom.
  • When opening a map, there's a phantom 64x64x64 selection box painted around the origin.
  • The rotation handles on brushes are open circles instead of solid.
  • The camera handles when using the camera tool are open circles instead of solid.
  • Overlays are not rendering correctly in the 3D views.
  • 3D view FPS meter not functioning correctly.
    • 2d/3d views are now rendered on demand meaning they are only rendered when you are doing something in them (moving the 3d view around, etc) and therefore the fps meter will show as though it is not functioning
  • Textures are stretched in 3d view when scaling an object, and then retain original scales when brush is set to desired size.
  • Arrow-key movement broken on 2D grid views, viewport goes black.
    • Arrow-key movement is broken specifically when the Vertex tool is active.
Workaround: Hold Spacebar and drag mouse.
  • Brush skewing ignores Snap-to-grid.
  • Cloning a brush using shift results in the new brush being off-grid.
A result of the fact that you can now drag selections by the midpoints of their sides, not just their corners. If the selection is not a multiple of twice the grid size when dragged, its sides won't match up with the grid.
Workaround: Drag from the corners.
  • The 'hold-mouse-button-down method for depth-cycling through objects' method for selecting things in the 3D viewport has disappeared. This'll make sense if you've used it, anyway. ;-)
Workaround: Use PageUp and PageDown keys. --JeffLane 16:22, 22 Nov 2005 (PST)
  • 3D Textured Shaded view doesn't always shade, client dependent.
Could be GFX related, my card is a 9100 and only PS 1.4 (DX81) compatible.
  • When opened, Hammer's 3D view is slow and jerky, but after a few minutes it speeds up to normal framerates.
  • 'Animate models' in 3D view doesn't work fully - it only advances frames when the viewport updates (moving the camera, etc). However, Hammer is so much more processor-efficient this way...
  • Pressing escape after drawing a new brush exits the tool instead of clearing the selection, same with vertex selections.
  • Vertices on non-selected brushes are hidden, making vertex manipulation difficult. (bug?)
  • When placing an entity in top 2D view then moving and dragging in any of the other 2D views the entity position (in the top view) is reset to another position. This also happens in the side and front views.
  • The Rotate tool (Ctrl + M) Verticies are mixed up, the labeled Z axis is now the X (or Y) axis, the Y axis is the Z axis and Y axis is X.
  • After SDK updated for the second time on the 22/11/05 Hammer viewport is now stuck in fullscreen mode and keyboard shortcut will no longer change it back to 4-view (Was it changed?)
    • Works here, Ctrl+A.
      • It will not respond to this shortcut. It was the first thing I tried.
    • Make sure you haven't changed the window settings to independent.
      • Where is this option?
  • You can't select wireframe'd props/actors in 2D views by clicking. You've got to drag a selection box or select the ent's bbox (which isn't drawn!).
  • Sometimes Brushes ignore grid lines and go between them. Even with Snap To Grid enabled.

Hammer VGUI Model Browser

  • After deleting a filter entry, then closing and re-opening the browser, the deleted filter is back again.
  • Model viewer currently loads it's GUI incorrectly the first time; on close and re-open, it functions as expected.
    • Resizing the window also fixes this.

Owie..

  • Error encountered with all human models in the browser, using a NVIDIA GeForce 4 MX 440 (DX7).
  • Error duplicated with all human models, using an ATI Radeon 9600 (DX version unsure, likely 8 or 9).
  • Error duplicated as well with human models, and a selection of other models such as one of the combine electric gate models. I am using an NVidia GeForce FX Go5700, DX 8.1 (This problem here also results in hammer crashing if it tries to load the problem models into hammer itself. Only the electric gate model has loaded successfully.)
  • Cannot duplicate with a geforce 6800GT newest drivers.
  • Choppy performance.
  • Rotating the model will reset view translations.

Hammer Autovisgroups

Put bugs related to the new Autovisgroup features here.

Hammer Autosave

  • Hammer Try’s to save to removable media, when it’s read only, same with read only folder rights. (This might not be a good idea for those working on source mods as final projects at Universities, or schools)

Hammer - Misc

  • Could you make it easier to import something from Hammer into 3DS Max? For example, the only way at the moment is to export to .DXF, and that generally loses information. Perhaps an export to .Max, or an importer plugin for Max?
    • Workaround: XSI has a great map import feature. You could base a plugin off that or possibly import to XSI then save your file and import it into MAX.--Skidz 15:55, 23 Nov 2005 (PST)
  • Nothing has yet been said for when we are going to see a lighting preview option, but could you perhaps add the option to change the lighting in the shaded 3d view? So we can change it like in the model viewer and get a general idea of how certain types of lighting will look like ingame.

FacePoser

  • Wireframe view is currently not functioning correctly (purple and black checkerboard texture).
  • Options -> Make Screenshot fails to create a screenshot.
  • The Close Captioning tool doesn't have the "Edit" menu specified in the documentation (semi-related link: sound name tokens and closed captions).
  • Options -> Background Color and Options -> Ground Color are non-functional
  • Popping sounds when playing .wav files in the Phoneme Editor. (Scrubbing through audio is painful on the ears.)
  • The gesture_updown and gesture_rightleft flexes appear to do nothing.


Model Viewer

  • Wireframe view is currently not functioning correctly (purple and black checkerboard texture).
  • The gesture_updown and gesture_rightleft flexes appear to do nothing.
  • Error encountered with all human models in the browser, using a NVIDIA GeForce 4 MX 440 (DX7). (Identical to error encountered with Hammer VGUI Model Viewer)

Compile tools and other SDK tools

Put bugs with the compile tools (vbsp.exe, vvis.exe, vrad.exe, studiomdl.exe, bspzip.exe etc.) under here.

  • When compiling finished, getting error. Unable to load C:\<SteamFolder>\counter-strike souce\bin\filesystem_steam.dll
    • Make sure you run CS:Source at least once before you compile to make sure you have the latest updates.
      • Works now! Thanks --CPhighwind 06:52, 23 Nov 2005 (PST)
  • vvis.exe doesn't run. Getting the Sorry for the inconvenience crash message
  • Compiling with batch files does not work, Popup window with can't find steam.dll error when starting at vvis.exe. Also a Filesystem_steam.dll missing.
  • The compile tools don't close when you stop the Hammer.exe process.
    • I don't think this is necessarily a bad thing. This way a crashed Hammer won't kill your map compile. Nailed 23:27, 22 Nov 2005 (PST)
  • All Expert Compile configurations are gone.
    • If you roll back from the beta they will get restored.
  • I have a large map with alot of displacements, previous to the Beta SDK I managed to get my map to 16mb (down from 27Mb) by removing some, after the Beta SDK compile with no changes my Linux specific data is over 400% and my map is now 37Mb. Computer 3.2Ghz P4B, 200GB Sata, 1GB DDR-400, FX5900 128MB AGP, XP Pro SP2. Many thanks
    • If you are working on a singleplayer map then you can compile with -nolinuxdata. This stops the Compile tools from storing the needed data for linux servers. Therefore if you are making a multiplayer map you cannot omit this data as then linux servers will not be able to run your map correctly.
  • Valve please contact me for the source to CST, I cant be assed at the moment supporting the tools any more, and would like to see my hard work put into the offical stuff - amckern@yahoo.cm +61 0417-650-440 (Mobile Phone only) --Amckern 16:28, 23 Nov 2005 (PST)