Source SDK Bugs

From Valve Developer Community
Revision as of 04:56, 23 November 2005 by Amckern (talk | contribs) (Hammer Autosave)

Jump to: navigation, search

Tues November 22nd, 2005
We're going to run a short beta of the new Source SDK tools.

To run it, run Steam from a command line or shortcut with -beta sdk appended. If you find any bugs, please edit this page and put it in the correct category. See SDK Beta Changelist for a current list of changes.

Note: Be sure to run the game you wish to edit before running the SDK, to make sure you have the latest updates.

SDK General Issues/Bugs

Issues with the Source SDK launcher or items that don't fit under other categories.

  • If you roll-back from the beta Hammer will be missing. You may need to use GCFScape.

SDK Launcher

  • Day of Defeat: Source game configuration lost when refreshing SDK content.
    • Is this solved with the latest DoD:S Update? If not, run DoD:S and then try again. --King2500 14:05, 22 Nov 2005 (PST)
No Configuration appears after running DoD:S.
    • This can be fixed by extracting a new GameInfo.txt from the DOD:S GCF file using nems GCFScape tool. -skidz

Hammer Editor

Put bugs having to do with the Hammer level editor under one of these categories.

General Hammer issues

  • Using SHIFT to invert override rotating objects in 15 degree rotations is non-functional.
Workaround: Use the Transformation Dialog (Ctrl-M)
Workaround 2: hold ALT when rotating.
  • Displacement Alphas in hammer when compiled appear inverted in-game. Such as using sand with sand/rocks as the alpha. If you have it setup in hammer one way when you compile and play it will invert the alpha.
Workaround: Invert Alpha before compile, but is tedious.
  • Some of the models are being rendered incorrectly by hammer. Most notably are any humanoid NPC models. You can view them in the model browser but if it attempted to be loaded into hammer itself results in crash. This therefore causes any old map with a messed up model to crash. Interesting though is that some of the messed up models load fine. One of the combine electric gate models had screwed up model while the other did not yet the whole prefab loaded properly into hammer without issue. (And just to be specific on model issues. If I look in model broswer for example with NPC models it will draw a like blobish looking thing where it appears triangles are not in the right spot but are all over the place from seeing how the texture on the model is all stretched extremely). I currently know of no workaround although the new update to the beta sdk severly cleared up the npc models so they have only a couple odd triangles, they still will not load in hammer without crash. -RomeoJGuy
  • Hammer crashes when trying to load a map or make a new file.
Needs more information than that, what are your system specs + software running at the time of crash.
A64 3200+ @ 2309 Mhz, 2x512MB PQI PC3200 DDR, Gigabyte Radeon 9600 (np) 128/128mb, Omega 2.6.75a Drivers, Win XP SP2, I'll try new drivers now and restart...
Make sure you clean the drivers out properly.
Okay, it's fine now... I made a mistake before, I accidentally opened Steam withOUT the -beta sdk parameters... hence the problems.
  • npc_* > Properties > Model > Dropdown is not filtered.
  • Some people are complaining about losing their cursor, unfortunatly no more information than that.
Cursor is lost over the model viewer after clicking in the filter text-box.
Workaround: Restart Hammer.
Workaround 2: Try and drag a model name (using the invisible cursor) onto the filter text box (dont let go) until a menu pops up.
  • Selection of a Displacement only considers the original box it was made from
  • After mere minutes of use, Hammer takes up almost 500mb of RAM. Memory leak?
  • When trying to launch the Day of Defeat: Source Hammer Editor, A configuration error appears. "Warning - The Configuration information for this game you're trying to edit is invalid or missing. [Run Anyway] [Cancel] [Help...]" The [Run Anyway] option does not work. The Hammer Editor fails to launch.

Hammer 2D and 3D Views

  • When opening a map, there's a phantom 64x64x64 selection box painted around the origin.
  • The rotation handles on brushes are open circles instead of solid.
  • The camera handles when using the camera tool are open circles instead of solid.
  • Overlays are not rendering correctly in the 3D views.
  • 3D view FPS meter not functioning correctly.
  • Textures are stretched in 3d view when scaling an object, and then retain original scales when brush is set to desired size.
  • Arrow-key movement broken on 2D grid views, viewport goes black.
    • Arrow-key movement is broken specifically when the Vertex tool is active.
Workaround: Hold Spacebar and drag mouse.
  • Brush skewing ignores Snap-to-grid.
  • Cloning a brush using shift results in the new brush being off-grid.
A result of the fact that you can now drag selections by the midpoints of their sides, not just their corners. If the selection is not a multiple of twice the grid size when dragged, its sides won't match up with the grid.
Workaround: Drag from the corners.
  • The 'hold-mouse-button-down method for depth-cycling through objects' method for selecting things in the 3D viewport has disappeared. This'll make sense if you've used it, anyway. ;-)
Workaround: Use PageUp and PageDown keys. --JeffLane 16:22, 22 Nov 2005 (PST)
  • 3D Textured Shaded view doesn't always shade, client dependent.
Could be GFX related, my card is a 9100 and only PS 1.4 (DX81) compatible.
  • When opened, Hammer's 3D view is slow and jerky, but after a few minutes it speeds up to normal framerates.
  • 'Animate models' in 3D view doesn't work fully - it only advances frames when the viewport updates (moving the camera, etc). However, Hammer is so much more processor-efficient this way...
  • Pressing escape after drawing a new brush exits the tool instead of clearing the selection, same with vertex selections.
  • Vertices on non-selected brushes are hidden, making vertex manipulation difficult. (bug?)
  • When placing an entity in top 2D view then moving and dragging in any of the other 2D views the entity position (in the top view) is reset to another position. This also happens in the side and front views.
  • The Rotate tool (Ctrl + M) Verticies are mixed up, the labeled Z axis is now the X (or Y) axis, the Y axis is the Z axis and Y axis is X.

Hammer VGUI Model Browser

  • After deleting a filter entry, then closing and re-opening the browser, the deleted filter is back again.
  • Model viewer currently loads it's GUI incorrectly the first time; on close and re-open, it functions as expected.
    • Resizing the window also fixes this.

Owie..

  • Error encountered with all human models in the browser, using a NVIDIA GeForce 4 MX 440 (DX7).
    • Error duplicated with all human models, using an ATI Radeon 9600 (DX version unsure, likely 8 or 9).
    • Error duplicated as well with human models, and a selection of other models such as one of the combine electric gate models. I am using an NVidia GeForce FX Go5700, DX 8.1 (This problem here also results in hammer crashing if it tries to load the problem models into hammer itself. Only the electric gate model has loaded successfully.)
    • Cannot duplicate with a geforce 6800GT newest drivers.
    • Choppy performance.

Hammer Autovisgroups

Put bugs related to the new Autovisgroup features here.

Hammer Autosave

  • Hammer Try’s to save to removable media, when it’s read only, same with read only folder rights. (This might not be a good idea for those working on source mods as final projects at Universities, or schools)

Hammer - Misc

  • Could you make it easier to import something from Hammer into 3DS Max? For example, the only way at the moment is to export to .DXF, and that generally loses information. Perhaps an export to .Max, or an importer plugin for Max?
    • Workaround: XSI has a great map import feature. You could base a plugin off that or possibly import to XSI then save your file and import it into MAX. -skidz


FacePoser

  • Wireframe view is currently not functioning correctly (purple and black checkerboard texture).
  • Options -> Make Screenshot fails to create a screenshot.
  • The Close Captioning tool doesn't have the "Edit" menu specified in the documentation (semi-related link: sound name tokens and closed captions).
  • Options -> Background Color and Options -> Ground Color are non-functional
  • Popping sounds when playing .wav files in the Phoneme Editor. (Scrubbing through audio is painful on the ears.)
  • The gesture_updown and gesture_rightleft flexes appear to do nothing.


Model Viewer

  • Wireframe view is currently not functioning correctly (purple and black checkerboard texture).
  • The gesture_updown and gesture_rightleft flexes appear to do nothing.


Compile tools and other SDK tools

Put bugs with the compile tools (vbsp.exe, vvis.exe, vrad.exe, studiomdl.exe, bspzip.exe etc.) under here.

  • When compiling finished, getting error. Unable to load C:\<SteamFolder>\counter-strike souce\bin\filesystem_steam.dll
Make sure you run CS:Source at least once before you compile to make sure you have the latest updates.
  • vvis.exe doesn't run. Getting the Sorry for the inconvenience crash message

Game-specific issues

Put SDK bugs dealing with specific Source-engine games here.

Half-Life 2

Half-Life 2 Deathmatch

Counter-strike: Source

Day of Defeat: Source