Difference between revisions of "Source Engine Beta Fixed Bugs"

From Valve Developer Community
Jump to: navigation, search
(discussion not needed now that it's fixed.)
 
(13 intermediate revisions by 9 users not shown)
Line 1: Line 1:
 
[[Category:Steam]][[Category:Feedback]]
 
[[Category:Steam]][[Category:Feedback]]
{| style="width:100%;vertical-align:middle;background:transparent;"
+
{{Source Engine Beta}}
| <div style="text-align:left;height:240px;overflow:auto;">__TOC__</div>
+
 
|align="right"| <div align="left" style="width:100%;">{{Source Engine Beta}}</div>
 
|}
 
 
== Awaiting verification ==
 
== Awaiting verification ==
 
This section contains bugs that the developer thinks have been fixed in an update, but need verification from the submitters. If the bug isn't fixed, please elaborate on the steps required to reproduce, because it's most likely that the developer has only found one case, or have fixed a separate but similar bug.
 
This section contains bugs that the developer thinks have been fixed in an update, but need verification from the submitters. If the bug isn't fixed, please elaborate on the steps required to reproduce, because it's most likely that the developer has only found one case, or have fixed a separate but similar bug.
Line 20: Line 18:
 
:::Right again... --[[user:TomEdwards|TomEdwards]] 06:53, 13 May 2006 (PDT)
 
:::Right again... --[[user:TomEdwards|TomEdwards]] 06:53, 13 May 2006 (PDT)
 
::::And that reminds me: this is also a problem with HLDMS, which as we know from above uses the beta engine or something close to it. Hitting Alt+F4 is one way around the issue, for now. --[[user:TomEdwards|TomEdwards]] 06:55, 13 May 2006 (PDT)
 
::::And that reminds me: this is also a problem with HLDMS, which as we know from above uses the beta engine or something close to it. Hitting Alt+F4 is one way around the issue, for now. --[[user:TomEdwards|TomEdwards]] 06:55, 13 May 2006 (PDT)
 +
 +
===sv_accelerate 10===
 +
*'''Expected''': servers used 'sv_accelerate 5' before the update.
 +
*'''Observed''': after the update, servers run on 'sv_accelerate 10'
 +
*'''Steps to reproduce''': join any server with the version of the game before the update
 +
Now check 'rcon sv_accelerate', it will be at 5. update the server, and check again. 'rcon sv_accelerate' will now show 10.
 +
*'''Note''': I am not sure if this is intentional or a bug.
 +
 
 +
[[User:Winn|Winn]] 07:13, 25 May 2006 (PDT)
 +
:sv_accelerate was always default 10! BUT before the update skill1.cfg was executed (now cvar skill is default 2 and skill2.cfg is executed)[[User:SIzzLeopard|SIzzLeopard]]
  
 
== Verified as fixed ==
 
== Verified as fixed ==
Line 32: Line 40:
 
*'''Steps to Reproduce''': Enter and Source based game (This was tested on HL2DM and CS:S), Open the server browser, pick any server and click on '''View server info'''.
 
*'''Steps to Reproduce''': Enter and Source based game (This was tested on HL2DM and CS:S), Open the server browser, pick any server and click on '''View server info'''.
 
*[[User:RP|RP]] 04:16, 12 May 2006 (PDT)
 
*[[User:RP|RP]] 04:16, 12 May 2006 (PDT)
 
+
:"'''After update''': ''Verified Fixed'' by [[user:TomEdwards|TomEdwards]]
::::"'''After update''': ''Verified Fixed'' by [[user:TomEdwards|TomEdwards]]
+
::This is still an issue in [[HLDMS]]. See [[Half-Life Deathmatch: Source Bugs#Server_Information_Window|Half-Life Deathmatch: Source Bugs]]. &mdash;[[User:Matveims|Matveims]] 00:56, 27 May 2006 (PDT)
 +
:::HLDMS uses an outdated version of the engine. It'll be fixed when it starts sharing with the other games. --[[user:TomEdwards|TomEdwards]] 01:25, 27 May 2006 (PDT)
  
 
===[[Image:Css.gif]] Counter-Strike: Source===
 
===[[Image:Css.gif]] Counter-Strike: Source===
Line 47: Line 56:
 
*[[User:Mendasp|Mendasp]] 06:28, 13 May 2006 (PDT)
 
*[[User:Mendasp|Mendasp]] 06:28, 13 May 2006 (PDT)
 
:Confirmed it myself on CS:S (crashes right before the load ends)--[[User:RP|RP]] 07:26, 13 May 2006 (PDT)
 
:Confirmed it myself on CS:S (crashes right before the load ends)--[[User:RP|RP]] 07:26, 13 May 2006 (PDT)
::''VALVe fixed it'' --[[User:Steamfraiser|Steamfraiser]] 07:19, 26 May 2006 (PDT)
+
::'''VALVe fixed it''' --[[User:Steamfraiser|Steamfraiser]] 07:19, 26 May 2006 (PDT)
 +
:::*'''Valve did NOT fix this.'''--[[User:Bc-17|Bc-17]] 11:25AM, 7 Oct 2006 (PDT) Crashes on my fully updated system. Check my user page to compare system specs if you think it might be hardware-related (which I doubt).
  
 
====White walls in Aztec====
 
====White walls in Aztec====

Latest revision as of 22:38, 13 August 2014

Awaiting verification

This section contains bugs that the developer thinks have been fixed in an update, but need verification from the submitters. If the bug isn't fixed, please elaborate on the steps required to reproduce, because it's most likely that the developer has only found one case, or have fixed a separate but similar bug.

Please move fixed issues to the section below and add "After update: Verified Fixed by ~~~".

Engine

No Cursors ingame

  • Expected: (CS:S, DoD:S) Cursor available after a kick, to close the kick window and go back to the main menu. Cursor ingame to close the modt or to cancel a mapchange.
  • Observed: (CS:S, DoD:S) No Cursor, you have to use the enter button, after a kick you have to close the game by taskmanager.
  • Steps to reproduce: Join a game or get kicked
  • DeepBlue 16:55, 12 May 2006 (GMT)
I was kicked from a Garry's Mod server just now and had the cursor as normal. --TomEdwards 08:57, 12 May 2006 (PDT)
Gmod is based on HL2 code and not HL2DM code if i'm not mistaken--RP 06:12, 13 May 2006 (PDT)
Right again... --TomEdwards 06:53, 13 May 2006 (PDT)
And that reminds me: this is also a problem with HLDMS, which as we know from above uses the beta engine or something close to it. Hitting Alt+F4 is one way around the issue, for now. --TomEdwards 06:55, 13 May 2006 (PDT)

sv_accelerate 10

  • Expected: servers used 'sv_accelerate 5' before the update.
  • Observed: after the update, servers run on 'sv_accelerate 10'
  • Steps to reproduce: join any server with the version of the game before the update

Now check 'rcon sv_accelerate', it will be at 5. update the server, and check again. 'rcon sv_accelerate' will now show 10.

  • Note: I am not sure if this is intentional or a bug.

Winn 07:13, 25 May 2006 (PDT)

sv_accelerate was always default 10! BUT before the update skill1.cfg was executed (now cvar skill is default 2 and skill2.cfg is executed)SIzzLeopard

Verified as fixed

These issues have been verified as fixed.

Engine

Misplaced Server Details buttons (ingame)

  • Expected: The server info and buttons are propertly displayed (See picture- Taken without the beta command)
  • Observed: The server info text and certain buttons are messed up (See picture - Taken with beta command)
  • Steps to Reproduce: Enter and Source based game (This was tested on HL2DM and CS:S), Open the server browser, pick any server and click on View server info.
  • RP 04:16, 12 May 2006 (PDT)
"After update: Verified Fixed by TomEdwards
This is still an issue in HLDMS. See Half-Life Deathmatch: Source Bugs. —Matveims 00:56, 27 May 2006 (PDT)
HLDMS uses an outdated version of the engine. It'll be fixed when it starts sharing with the other games. --TomEdwards 01:25, 27 May 2006 (PDT)

Css.gif Counter-Strike: Source

Speaker Test

  • Expected: Using the "Test Speakers" button should load up the sound test map.
  • Observed: Loading the Test Speakers map causes a crash identical to that of the Video Stress Test crash. --Steamfraiser 13:10, 15 May 2006 (PDT)
It is indeed fixed --Steamfraiser 07:19, 26 May 2006 (PDT)

Video Stress Test not working

  • Observed: When loading the Video Stress Test it crashes to the desktop when it's almost done loading ("Initializing game data").
  • Steps to Reproduce: Try to run the VST.
  • Mendasp 06:28, 13 May 2006 (PDT)
Confirmed it myself on CS:S (crashes right before the load ends)--RP 07:26, 13 May 2006 (PDT)
VALVe fixed it --Steamfraiser 07:19, 26 May 2006 (PDT)
  • Valve did NOT fix this.--Bc-17 11:25AM, 7 Oct 2006 (PDT) Crashes on my fully updated system. Check my user page to compare system specs if you think it might be hardware-related (which I doubt).

White walls in Aztec

  • Expected: The walls in Aztec to be properly textured as they have been.
  • Observed: The walls have turned a very bright white. (See Picture)
  • Steps to reproduce: Load Aztec using the BETA command. Happened in an online server and in a listen server even after a restart of CS: Source. Verifying the game cache for CS: Source did not work. Other maps (Dust, Italy, Havana) have appeared fine. The walls reverted back to normal after I removed the command and restarted Steam.

After update: Verified Fixed by Zips

Verified as still broken

These issues have been reported as fixed, but have been verified as still broken.